BF1942 loads, Monitor turns off

By acidosmosis ยท 5 replies
Mar 5, 2004
  1. I just installed Battlefield 1942 again after doing a complete re-install of XP a few weeks ago.

    When BF1942 loads the screen immediately goes black and the monitor goes into "standby" where the power light blinks.

    BF1942: Latest version
    DirectX: 9.0b
    ATI drivers: Latest version

    In my last XP install I didn't have any problems with BF1942, now this is occuring. I'm not having any other problems that I have noticed that would have anything to do with this. The Painkiller demo runs fine, but these are the only two games that I have installed right now.

    Has anyone else had this happen?
  2. Rory7

    Rory7 TS Rookie Posts: 119

    Weird. Is the copy genuine?
  3. acidosmosis

    acidosmosis TechSpot Chancellor Topic Starter Posts: 1,350

    Yes, I own 3 copys.
  4. LNCPapa

    LNCPapa TS Special Forces Posts: 4,272   +456

    Out of curiosity are you forcing some D3D refresh rate at the current setting for Battlefield? If you're forcing a refresh rate too high or that your monitor is having a problem sync'ing to then perhaps you are out of range therefore getting a blank screen? Just a thought. I'd check to see if any refresh rates are manually set.
  5. (=DoM=)

    (=DoM=) TS Rookie Posts: 230

    Acid, theres a line you enter into one of the BF files which fixes a problem with Refresh rates, im not sure what the command is, try typing this into google;

    BF1942 refresh rate

    or something...

    My friend had this exact same problem, and he added a line to one of the files which makes the refresh rate dynamic and all of his problems went away.

    Just a thought

    Hope you fix it, i know BF players start twitching if they dont get thier fix after a couple of...hours (i know i used to)....before the rehab
  6. wilsonjg

    wilsonjg TS Rookie

    I had same problem I didnt edit any lines of code i just made my graphics card force 75 mhz refresh rate im using ATI Asus 9600 xt and the new catalyst driver availble from the ati site for download. as soon as i done it, it worked hope this helps

    Summary: Go to your graphics set up find where it conrtols refresh rates make it enforce its own and not let it do what the game wants.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...