Big Mouse mystery

By buffaloranger ยท 6 replies
Sep 23, 2006
  1. I have a Dell Laptop Inspiron 9300. MS XP. USB Belkin Wireless mouse and Targus wired mouse are both suddenly malfuntioning. (No they are not connected at the same time.) I am an IT guy, working with a bunch of other IT guys, and none have heard of this type of malfunction until I showed them.

    The below applies to both mice.

    Cursor can be moved around fine. I can click on a desktop folder and open it - but then clicking on the X doesn't close it. Right clicking on folder in toolbar does nothing. Folders on desktop can be highlighted but not moved, file snaps back to where it was. NO I DON'T HAVE THE DESKTOP LOCKED, AUTO ARRANGE OR ALLIGN TO GRID CHECKED. I have even gone in to regedit and confirmed the hexadecimal settings are "no auto arrange", "no allign to grid". After a couple folders are opened, nothing else can be opened including START button. Forced reboot is the only escape.

    When I start the system I can use the touch pad with no problems, desktop icons can be moved around, folders can be opened and closed. Once I insert a USB mouse, the touch pad malfunctions like stated above. Even removing the mouse doesn't restore the mouse pad functionality. That really seems strange.

    I have tried both mice in multiple USB ports on the system. Is this a driver issue? Both mice were plug and play. I used the Targus wired mouse with no problems for 9 months and then upgraded to the wirless mouse a month ago - with no problems until 2 days ago.

    Could friggin Itunes be somehow screwing this up? I mention it only because my Itunes is jacked up also, giving error messages when I attempt to update it. I have reinstalled and attmpted repair of the newest Itunes 7.0 to no avail. But that's a question for the Apple website. I just want my mouse to work.
  2. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    If it is as you describe, it makes absolutely no sense.

    Do these issues occur in Safe Mode?

    Do these (or other bizarre) issues occur with a parallel install of Windows or using another OS like Knoppix (Bootable, easy to use Linux CD)? Try it and see.

    Since no one here has probably seen this problem, we'll need to get started in the right direction. Best of luck.
  3. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    Yes, that is strange indeed. I know I had some issues with my wireless mouse, until I installed the drivers for it. It was also plug and play, but has some extra features with the drivers. It might be worth a shot, unless of course it's a generic run of the mill wireless mouse.
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    If you can, go back to iTunes 6, the new V7 is the pits, just check Google for "itunes 7 problems" and be disgusted!
  5. buffaloranger

    buffaloranger TS Rookie Topic Starter

    OK, I have some resolution, or at least a work around.

    I tried a 3rd mouse on my laptop. A factory Dell mouse. It worked just fine no problems. I tried the Targus mouse on a different laptop, that worked just fine, no problems. When I tried that Targus mouse again on my laptop, I had the same problems again as described above. Then the touch pad and any other mouse I tried lost the ability to open / move folders (Yes, I disconnected the Targus first) requiring a forced reboot.

    I changed out the batteries on the wireless mouse and that worked fine.

    The targus mouse, that used to work fine on my laptop is somehow causing conflicts with the software on my laptop. This mystery won't be solved, but the work around is that I will never use that mouse on my laptop again. That and always have spare batteries available for my wireless mouse!

    Thank you all very much for your time and assistance.
  6. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    If you want to use that Targus mouse, perhaps you could change the interrupt in either BIOS and/or Device Manager.
  7. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    I have found mouse conflicts with the Touch pad software on 2 of the 4 Laptps I have owned Dell,HP .Since I only ever use either mouse or touchpad at the same time , I just disable the pad.
    Interesting fact the Ltp's that have those Mouse peg controls in the center of the Keypad are the ones that have the conflicts.
    Go figure.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...