BIOS update problem...

By blur ยท 9 replies
Apr 29, 2003
  1. Sigh. I used Intel Express BIOS to update my Intel D850EMVRL M/B. During the process, the computer hung before rebooting. Per their instructions, I hit the reset switch (although I guess I should have powered off completely).

    Now, when the computer boots, it brings up the M/B indentifier (with the serial of the new BIOS) along with the "press F2 for SETUP, F12 for network boot" stuff at the bottom. However, that's as far as I get. I can't enter setup or do anything else.

    Am I hosed here? Any suggestions would be much appreciated.

  2. StormBringer

    StormBringer TS Maniac Posts: 2,244

    Sounds like you messed up. I don't recommend using those BIOS updater things. Many people have had problems with them and as result ruined the BIOS. You can try flashing using the floppy method, but I wouldn't hold my breath.
  3. Arris

    Arris TS Evangelist Posts: 4,730   +379 can sell you a new chip for your bios which will save your motherboard, or you could contact the retailer where you got it from, or the board manufacturer. They might take it back also.
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    The easiest way is to get a replacement ROM, for example from the store where you bought your mobo or the place Arris suggested. Any computer repair shop will probably agree to fix the problem too.

    Another way is to find a friend with an identical mobo and do the voodoo with changing ROM chips in a running comp.. Scary stuff, wouldn't recommend.

    Or you can also find someone with a ROM writing device (electronics repair shop, university etc.). They can write the new BIOS on the chip (if the type is supported).
  5. blur

    blur TS Rookie Topic Starter

    Unfortunately, you were right...

    Well, I tried to revive the board using the Iflash floppy utility and taking the jumper off to set the board to recover mode. Surprisingly, I got the "beep and LED flash" that let me know "everything went okay" per Intel's directions. However, after replacing the jumper to the normal configuration, the boot sequence still never gets past that opening screen, though the BIOS version line changes appropriately (I have now tried several versions of the BIOS.)

    So, I guess it's a difficult plan B choice now...

    Thanks for your help.
  6. blur

    blur TS Rookie Topic Starter

    A new twist...

    Well, a funny thing happened on the way to Plan B. For some reason, I decided to try to Iflash the BIOS using the floppy recovery tactic trying different BIOS revisions. The latest two for my motherboard, Intel D850EMV2, did not work (rev 24 and 23). However, the one prior to that, found in Intel's old files list, worked perfectly! Now the motherboard boots to Windows, etc.

    Isn't that strange? Unfortunately, I think my problems are all originating from a bad power supply. I have an Enermax 430W quiet power supply. It fried the connection to my floppy drive (the prongs welded themselves to the power cable with a puff of acrid smoke). I think something happened on the board, too. I have since switched out the power supply and replaced the floppy to undergo this recovery operation, but I'm a little concerned that something is wrong with the MOBO.

    When I shut down, windows closes and the drives shut off, but the fans still run and the board still shows to be juiced up. I have to manually switch off the (new) power supply to get the board to power down.

    Hmmm... do you think I have a board problem remaining?
  7. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Re: A new twist...

    This isn't necessarily manfunctioning hardware. It might just be that when you changed BIOS, WIndows no longer recognizes power management (APM or ACPI), and thus it can't shut the computer down automatically. It will, however, shut down the drives. You could check if APM or ACPI is enabled and/or if there are any problems with them in Device Manager.
  8. farmer

    farmer TS Rookie Posts: 48

    Sorry to bring this thread back up but I'm having a bit of the same problem. I have the Intel D875PBZ mainboard and this thing refuses to let me change the Bios. Tried the "Express" method and the dos flash, neither worked. Was gonna try the Bios recovery method, but after reading here I think I'll pass on that one for now.

    Any ideas or suggestions appreciated....

  9. frobi

    frobi TS Rookie

    You can erase the bios pass word by doing the following without jumpers, opening the lap top or looking for the cmos battery. I did it on Dell Inspiron 7000

    Unplug the laptop

    Remove the battery ( Laptop battery).

    Inside the hole where the battery was, there will be pins which connect to the battery when inserted.

    Take a flat metal butter knife and touch the clips (short them) as many times you can.

    Replace the battery, start the laptop and press F2.

    Bios window will show up.
  10. Matthew

    Matthew TechSpot Staff Posts: 5,333   +101

    This thread is not only 5 years old but it's regarding corrupt BIOS due to a failed update, not the BIOS password. Furthermore, there is absolutely no reason to take a butter knife to your motherboard to clear the CMOS. :confused:
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...