Bios will not recognise hard drive after restart during XP Pro install...

Not open for further replies.
Hi all,
Am in need of a little guidance, or advice.
I just bought a barebones system and have had a nightmare getting the OS (xp Pro, SP2) installed.

Basically it gets through the initial checking system configuration, formatting and creating a partition and copying all the files. When it restarts, after letting the option to boot from CD expire, the system stalls, or just seems to stop. I can't hear the hard drive doing anything, and the HD light isnt flashing either.

Has anyone come up against this before? Any advice? I have a feeling that part of the BIOS is corrupted, or could be incompatible with the drive, but thats not likely given that it all came as a bundle.

I've tried pretty much everything I can think of and will be going mad for the rest of the weekend untill I can call the company's tech support on Monday to have a rant at them about providing a new system with this kind of glitch...

But if any of you can offer some advice as to how I can sort myself out in the meantime, I would be eternally grateful!

the problem id it doesnt have the drivers to see the hd...It must be a sata hd ...I just had the same problem a couple of weeks ago..You need to look on the cd that came with your motherboard and find the raid(sata) drivers ...copy them to a floppy disk...when you go to load xp pro w/sp2 it will ask you when it starts to load up to press F6 if you need to load and scsi or raid f6 then it will ask you to put the floppy in..that will fix your problem..good luck!
cheers, but...

Its a parallel ATA and I don't have a floppy drive. Could your problem still be relevant? The CD that came with the machine does have RAID drivers. God knows which one I need to use and how I am meant to get a floppy drive in the thing... might not be worth bending the warranty in that way?

Thanks though...
choosing your RAID type depends on what you want to do, how any drives you have in total, and how secure you want your data.
parallell ata...

Just got the one drive. An 80 GB Hitachi parallell ATA.
I suppose the data should be pretty secure, but I'm not exactly a government agency or pedo, so I don't need lead-lined boxes and retina scanners...
don't think you need the raid just to get the ide up and running it sounds more like you have a memory stick problem
go to bios and disable error stops except for keyboard
it may boot now and then it may freeze after boot if one of your sticks are bad
make sure you are using a 80 wire 40 pin ide cable some drives are backwards capable some put up a fuss
if that does not work try boot with lowest amount of ram
if you do have ar aid setup you may have the wrong ide connetion the raids for ide that I am used too are 2 independent ide connectors for raid control
so how many on board connections to you have?
if not then I bow to more wisdom and the raid may need drivers for the controller
I had exactly the same problem. The PC would not recognise the hard drive when it restarts. I eventually discovered that the bios recognised the hard drive if the PC was completely powered down rather the just restarted.

During windows XP installation the installer does a software restart resulting in the bios not recognising the hard drive. When the PC needs to restart try pressing the power off button, then pressing it again to restart once the system is completely shut down.

Similar Problem

I have a similar probelm that needs resolving. I recently had a problem with my computer booting up bios (no beeps, no visuals on screen). I tried many things to fix it including removing the BIOS battery temporarily to allow the BIOS to restart, hoping that solved the probelm. It turns out that didnt help and i eventually fixed it by the usual jiggling of different connectors and components. In the end i was able to boot the computer up to the POST screen and was excepting to have to basically set the Bios up again. It all seemed to be going fine when at the verifying DMI pool data.... part of teh OS boot up i got an NVIDIA boot up error, saying that it could not find my hard drive and couldn't not load up the OS. I have gone through a few of the BIOS settings numerously trying to find out if it was something i missed in the BIOS setup but am unsure, i am pretty sure it is not hardware related, but would love to know how i coudl try to fix it.
Sorry i forgot to add taht my BIOS does recognise the HDD in the POST screen and in the BIOS setup screens and it has it set as the Primary Master Drive, which is what it should be.
did you "jiggle" those things while its still pluged in to the mains??

PC specs please.

Disconnect power from mains. Open up your pc case, discharge yourself from static then remove non essential components (cards, expansions, drives) untill you have the basic barebones system [ram, vid, cpu, mobo, psu, sound] and try to boot up. if successful, then install each component untill you find the one responsible. if not, continue

take out the ram(s), video card, hdd. Note any damage/irregular marks on any components including the motherboard. eg: funny looking capacitors, burns/scorches, funky smell etc... If everything seems ok, then install them back in, using 1 stick of ram for troubleshooting. try and boot. swap ram sticks if still wont go and try again.

install the hdd in another machine as slave and read off it (and backup your essential files while you're at it).

write down the make and wattage rating for the psu while your at it and post here.
Im sure its not a hardware problem. As i was able to boot off the windows xp CD. If it was a hardware issue it would only be to do with the HDD. Im pretty sure it has something to do with the BIOS setup, and have already tried most obvious hardware solutions, which was what i kind of meant from "jiggle", sorry i wasnt more clear on that.

But at your request the PSU is 300 W
ok cools.. any changes to the system recently? environment/hardware/software etc?

if you can access safe mode try reinstalling your drivers for the video card and also update the chipset drivers for your motherboard. flash bios if neccesary.

then read this thread if still not work, if its a windows booting problem then follow my instructions at the bottom of the thread on repairing windows..
Not open for further replies.