BIOS won't detect HDD

By dranman ยท 4 replies
Oct 31, 2006
  1. Hello,

    I recently flashed my BIOS to upgrade and the computer crashed (checksum error) on reboot was requesting BIOS password. I erased CMOS memory with jumpers. Then the computer was able to get to BIOS setup. It does not detect the hard drive, though it does detect both the floppy and the CD. It reports both primary master/slave as not detected. I have tried to resore custom defaults and load optimal defaults without any improvement.

    I have used PEbuilder to try to boot from the CD-ROM, and it will boot to a Windows type environment. In that environment, I can access the C: drive (hard drive) and view the files, so it appears that the drive is working fine, only it is not being detected by BIOS.

    Since the initial BIOS flash crashed, I have since done recovery with the latest version of BIOS, without any improvement.

    I have an intel D865PERC motherboard

    Please help!
  2. powertunez

    powertunez TS Rookie

    remove your HDD cables and power cable from your mother board then start the computer without the HDD attached when the POST is finished and you het an error, power off , re-attach cables and power on computer again. if not working manually detect your HD in the BIOS.
  3. sl33py

    sl33py TS Rookie

    you might also check the cable select or master settings for the drive. I am guessing this is IDE. Try powertunez suggestion and if that doesn't do it try switching to master from cs or to cs from master.

    good luck!

  4. dranman

    dranman TS Rookie Topic Starter

    Follow Up

    The hard drive is indeed IDE. I tried to set it as both cable select and as master without BIOS detecting it. Also, I tried unplugging it from the motherboard (including power) and restarting it. It beeped a few times, then went to the usual "looking for boot device". I then restarted it with the hard drive reattached and it still was not detected. I don't understand what you mean by "manually detect" the hard drive, because in the BIOS setup it simply says "Primary Master / Slave Not Detected" and there does not seem to be a way to modify it. Any other suggestions?
  5. powertunez

    powertunez TS Rookie

    try your secondary IDE port

    try your secondary IDE port. check BOIS if both IDE ports are enabled.

    if it is not working best you can do is borrow an IDE cable and try that on your HD ,if it works than you know yours is faulty.

    If it is still not working then try another HD, if that works than yours is dead.

    Goodluck. dranman.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...