1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Bioshock Win2K fix

By Per Hansson ยท 32 replies
Aug 24, 2007
  1. To play Bioshock on Windows 2000 you need two files, dbghelp.dll and xinput1_3.dll

    You can get dbghelp.dll from a Windows XP or 2003 install, the version I used which worked was 5.2.3790.3959 from a 2003 SP2 server install

    You can find the xinput1_3.dll on the install DVD or in the root of the demo zipfile in a folder called "dx redist"
    In there open the file APR2007_xinput_x86.cab and extract the dll file

    Now you need to open it in a HEX Editor, I use Hex Workshop.
    Search for the textstring: "TraceMessage" and replace that with "GetUserNameA"

    Place both dll files in the games install dir under \Builds\Release
    (Don't overwrite the files in your winnt/system32 dir!)

    Please post any problems or issues in this thread, my Win2K install is not very "clean" so more fixes might be needed... Oh, make sure to install the latest nVidia beta display driver for Bioshock too:
    Direct Link: http://www.nvidia.com/object/winxp_2k_163.44.html

    There was a fix by ATI also, ask Google ;-)
    Oh, and be sure to run the installer for DirectX too, i.e. in the above referenced "dx redist" directory

    With these fixes I was able to play through the demo just fine, I think it will work for the full version also...
  2. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,966   +223

    I've made available the two files I mentioned in my previous post


    What the fix does is replace the call TraceMessage with something we will have access to, the side effect to this fix is that it should not be possible to use an X-Box Controller for the game (well I suppose there never was since xinput does not get installed at all for Win2K anyway so...)

    And now some keywords for the google bot

    The procedure entry point MiniDumpWriteDump could not be located in the dynamic link library dbghelp.dll

    Unable to locate DLL
    The Dynamic link library XINPUT_1_3.dll could not be found in the specified path.

    The procedure entry point TraceMessage could not be located in the dynamic link library ADVAPI32.dll
  3. naughtyfrd

    naughtyfrd TS Rookie


    I bought BioShock over Steam without checking the OS requirements. Thank you so much for this fix, you've made at least one person very happy with it.
  4. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,966   +223

    Welcome to Techspot and thank you very much for your feedback!

    I was not 100% sure the Bioshock Windows 2000 fix would work for others as I have played around allot with compability fixes for other games so my Windows 2000 install is not very stock anymore :)
  5. Techinator

    Techinator TS Rookie

    I don't see any reason why this wouldn't, but just to ask before I think about buying Bioshock, this should work with the retail CD version, correct? I know this sounds kind of like a stupid question, but I just wan't to get your opinion.
  6. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,966   +223

    Hello and Welcome to Techspot Techinator,
    I think it would work, but I give absolutely no guarantees

    It is only my educated guess that it will work. However as far as I know the STEAM and Retail versions are the same, i.e. they have the same copy protection and all (SecuROM with online activation)

    That is to say I think there is nothing which is different in the two versions, and since we are not modifying any of the games own files it should not set off any copy protection measures either...
  7. Celluloid

    Celluloid TS Rookie

    I'm in with Per, as long as the fix is outside the game own files and do not concern any part of the copy protection scheme, there wouldn't be any reason of (bad) interaction.
    I haven't got my hands on the retail version yet, though.

    On the bright side, I've used these exact same steps to be able to launch the PC demo of MOH Airborne, which refused to launch with the exact same errors.
    It would be nice if any game developpers not officially supporting win2k could give the hint about this fix on its website or, better, provide this 'unsupported fix' shipped with the retail version.

    By the way, thanks for this post !
    I've read about the trick on the 2K forums and had actually already done half the job (getting different versions of the three dll), but it was nice to see the fix confirmed on other boards :)
  8. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,966   +223

    Celluloid; Welcome to Techspot forums

    I wasn't aware someone else had fixed it already, could have saved me some effort lol
    Be sure to send a few pointers this way also ;)
  9. Rimmer100

    Rimmer100 TS Rookie

    Thanks for this!

    Just signed up to say a big "Thank you". I hadn't checked the requirements so didn't realise that Bioshock didn't run on 2K till I had bought it.

    The patch you produced worked flawlessly and I am now enjoying wandering around the world of Rapture.


  10. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,966   +223

    Welcome to Techspot Rimmer100!

    I'm glad to hear about your success!
    Was this the Retail or Steam version?
  11. Rimmer100

    Rimmer100 TS Rookie


    This was the Steam version. So far I've not had any crashes and the game seems to be working as I would expect.

    The fact that it has hi-lighted that I need to buy / build a new PC however is somewhat upsetting ;)
  12. Celluloid

    Celluloid TS Rookie

    The fix also works fine with the retail version (european version).
    So far ( end of medical pavilion ), absolutely no problem.
  13. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,966   +223

    I'm glad to hear that, and also that you're enjoying the game :)
  14. Finchy

    Finchy TS Rookie Posts: 350

    To anyone reading this, note that Bioshock will not run on Shader Model 2 Hardware. This mainly affects ATI users (like me) because even if you have an X800 it will not work (i think ATI ony started supporting SM 3 in the X1000 series).

    This is a pain in the proverbial boot-oks because thousands can't play it.
    Apparently it can be hacked to run, so why are Irrational discriminating thousands of gamers for just an afternoons work for a patch (took hackers only an hour to fix)
  15. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,966   +223

    I agree that it is kinda odd, Unreal Engine 3 does support Shader Model 2.0 cards and onwards so I really don't understand how 2K games could find it a sensible idea to make their game incompatible with such a big user market...


    As a matter of fact in my brothers computer sits a ATI X850XT, so I might try this unofficial fix some day, however last I read the patch only worked for the plane crash part of the game, as soon as you got into the buildings there where textures missing etc

    EDIT; Seems work is progressing quickly on the patch: http://bioshocksm2.blogspot.com/
  16. Lomendil

    Lomendil TS Rookie

    Hi !

    First, a big "thank you" for you Per, Bioshock works now perfectly on my Win2K system.
    That's really a pain developpers forget that nice OS.

    But I now have a little problem with the MoHA demo. I thought I could fix it with the same files, as it was the same error displayed, but it seems it was too easy ;)
    I can start the game but I get stuck with the EA logo video :(

    Any idea ?

    And, again, merci !
  17. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,966   +223

    Hi Lomendil, welcome to Techspot and I'm glad to hear you too got Bioshock to run on Windows 2000 :)

    Your problem with Medal of Honor: Airborne might be that it needs another version of the dll files (though that is kind of unlikely)

    Unless you can get an error it's very difficult to help...
  18. Lomendil

    Lomendil TS Rookie

    Finally I helped myself :D

    For those who encounter the same problem, it's quite simple : just rename or delete the video file corresponding to your langage.

    It's located in the /MOHAGame/CookedMovies/ folder.

    When done, the game just skip the video and show you the menu.


    I also had another problem : I couldn't hear any sound ! Quite frustrating for just a game, isn't it ? ;) I just switched "5.1" to "Stereo" and everything worked fine.

    Hope it can help another Win2K user !
  19. JDSilver

    JDSilver TS Rookie Posts: 24

    All my thanks!

    Thanks a great deal, Per Hansson, for that valuable information! I went as far as to install it before I realized the OS requirements :)

    Works with the US retail version, everyone.
  20. BionicShock

    BionicShock TS Rookie

    I still have errors on mine Though
    But thanks your way made it work but i still have this 1 error
    I get the BioShock Splash then it fades out
    Then i get this White Screen like a..a... What do i call it.. The page where you choose options and start game type of thing
    Then after that i get this

    BioShock.exe Application Error
    "The Instructions at 0x10972xxx in the memory 0x0000000 could not be ''read'' "
    Press okay to terminate or Press CANCEL To debug
    I put 3 "x" 's after the 2 because i cant remember the other numbers
    What do i do please help. If you need my computer specs tell me ill be here.
  21. BionicShock

    BionicShock TS Rookie

    Edit : Last time i couldnt make it work because it said things about the dynamic link lybrary dbghelp.dll, But i got past that thanks to your way, but that one error i posted earlier is still bugging me So help me with that one and thanks for your guideance
  22. BionicShock

    BionicShock TS Rookie

    BioShock Win2K Error

    Here are my Specs:
    System Information
    Time of this report: 10/16/2007, 21:53:54
    Machine name: CHIOMA-204633B1
    Operating System: Windows 2000 Professional (5.0, Build 2195) Service Pack 4
    Language: English (Regional Setting: English)
    System Manufacturer: Dell Computer Corporation
    System Model: OptiPlex GX110
    BIOS: Default System BIOS
    Processor: Intel Pentium III processor, ~860MHz
    Memory: 382MB RAM
    Page File: 396MB used, 428MB available
    Windows Dir: C:\WINNT
    DirectX Version: DirectX 9.0c (4.09.0000.0904)
    DX Setup Parameters: Not found
    DxDiag Version: 5.03.0001.0904 32bit Unicode

    Display Devices
    Card name: Intel Corporation 810 Graphics Controller Hub
    Manufacturer: Intel Corporation
    Chip type: Intel810
    DAC type: Internal
    Device Key: Enum\PCI\VEN_8086&DEV_7125&SUBSYS_00B41028&REV_03
    Display Memory: 4.0 MB
    Current Mode: 1024 x 768 (24 bit) (75Hz)
    Monitor: Plug and Play Monitor
    Monitor Max Res: 1600,1200
    Driver Name: i81xdnt5.dll
    Driver Version: 5.11.0001.0133 (English)
    DDI Version: 7
    Driver Attributes: Final Retail
    Driver Date/Size: 6/19/2003 07:05:04, 489712 bytes
    WHQL Logo'd: Yes
    WHQL Date Stamp: n/a
    VDD: n/a
    Mini VDD: i81xnt5.sys
    Mini VDD Date: 6/19/2003 07:05:04, 68336 bytes
    Device Identifier: {D7B78E66-3265-11CF-1D73-B520A7C2C835}
    Vendor ID: 0x8086
    Device ID: 0x7125
    SubSys ID: 0x00B41028
    Revision ID: 0x0003
    Revision ID: 0x0003
    Video Accel:
    Deinterlace Caps: n/a
    Registry: OK
    DDraw Status: Enabled
    D3D Status: Enabled
    AGP Status: Enabled
    DDraw Test Result: Not run
    D3D7 Test Result: Not run
    D3D8 Test Result: Not run
    D3D9 Test Result: Not run

    Sound Devices
    Description: AC'97 Sound Card
    Default Sound Playback: Yes
    Default Voice Playback: Yes
    Hardware ID: PCI\VEN_8086&DEV_2415&SUBSYS_00B41028&REV_02
    Manufacturer ID: 1
    Product ID: 100
    Type: WDM
    Driver Name: ichaud.sys
    Driver Version: 5.00.2160.0001 (English)
    Driver Attributes: Final Retail
    WHQL Logo'd: Yes
    Date and Size: 10/22/1999 09:54:42, 32592 bytes
    Other Files:
    Driver Provider: Microsoft
    HW Accel Level: Standard
    Cap Flags: 0xB5B
    Min/Max Sample Rate: 8000, 48000
    Static/Strm HW Mix Bufs: 1, 0
    Static/Strm HW 3D Bufs: 0, 0
    HW Memory: 0
    Voice Management: No
    EAX(tm) 2.0 Listen/Src: No, No
    I3DL2(tm) Listen/Src: No, No
    Sensaura(tm) ZoomFX(tm): No
    Registry: OK
    Sound Test Result: Not run
    DirectPlay Service Providers
    DirectPlay8 Modem Service Provider - Registry: OK, File: dpnet.dll (5.03.0000.0900)
    DirectPlay8 Serial Service Provider - Registry: OK, File: dpnet.dll (5.03.0000.0900)
    DirectPlay8 IPX Service Provider - Registry: OK, File: dpnet.dll (5.03.0000.0900)
    DirectPlay8 TCP/IP Service Provider - Registry: OK, File: dpnet.dll (5.03.0000.0900)
    Internet TCP/IP Connection For DirectPlay - Registry: OK, File: dpwsockx.dll (5.03.0001.0904)
    IPX Connection For DirectPlay - Registry: OK, File: dpwsockx.dll (5.03.0001.0904)
    Modem Connection For DirectPlay - Registry: OK, File: dpmodemx.dll (5.03.0000.0900)
    Serial Connection For DirectPlay - Registry: OK, File: dpmodemx.dll (5.03.0000.0900)

    DirectPlay Voice Wizard Tests: Full Duplex: Not run, Half Duplex: Not run, Mic: Not run
    DirectPlay Test Result: Not run
    Registry: OK

    DirectPlay Adapters
    DirectPlay8 Modem Service Provider: Communications cable between two computers
    DirectPlay8 Serial Service Provider: COM1
    DirectPlay8 Serial Service Provider: COM2
    DirectPlay8 IPX Service Provider: IPX Adapter 1 - (00000000,00121792E12E)
    DirectPlay8 TCP/IP Service Provider: Linksys Wireless-G USB Network Adapter -

    Im using DX 9.0c

    Do you have any idea why it wont work?
  23. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,966   +223

    You need a Shader Model 3 compliant graphics card for Bioshock

    But the other specs of your computer are way too low for it too. Bioshock is a very demanding game

    1.2 Minimum System Requirements

    CPU: P4 2.5 GHz single core.
    System RAM: 1GB*
    Video Card: Pixel Shader 3.0 compliant video card with 128 Meg Ram and floating point*frame buffer blending.
    Sound Card: 100% DirectX 9.0c compatible sound card
    Hard Drive: 7 GB

    1.3 Recommended System Requirements

    CPU: 3GHz dual core processor
    System RAM: 2 GB
    Video card:* Pixel Shader 3.0 compliant video card with 512 Ram (Nvidia(R) Geforce(R) 7900 GT or better)
    Sound Card: 100% DirectX 9.0c compatible sound card
    Hard Drive: 7 GB
  24. BionicShock

    BionicShock TS Rookie


    SO if i switch to Shader 3 would i be able to play?
    Or is my comp too crappy?
  25. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,966   +223

    Erm, just compare your specs to the minimum reqs? Your not even meeting them at one third!

    Sorry to be so blunt but...

    Ram, yours: 384MB, min = 1GB
    CPU, yours: 866Mhz min = 2.5ghz
    Integrated Intel graphics, enough said really
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...