Bizarre Networking Problem

By Corribus ยท 10 replies
Jun 22, 2005
  1. I am having a strange (or at least, to me) networking problem, which may boil down to something simple.

    Here's my background information:

    I have two computers, a PC (Windows XP Professional) and a Mac, both connected to a SMC7004ABR Broadband Router. The two computers obviously don't communicate with each other, but the setup is generally sufficient so that both computers can be connected to the external network simultaneously. I've had this setup for about 2 years and aside from occasionally needing to reset the router, I have had no problems. Generally speaking I reset the router by releasing and renewing my IP address information so that the IP address readings By going to this address in my browser, I can then access the router itself and reset it. Pretty simple.

    Here's my problem:

    Today I booted up my computer (PC) and I received an error about a "Generic Host Process". I went to windows and downloaded and installed the corrective update (KB894391). Clearly, my internet had to be working to do this. After updating and rebooting, though, I found that I had no internet access, although the mac still has access. Removing the router and connecting my PC directly to the cable line gives me access and restores my original IP address (that's how I'm connected now). This is usually the case when my router resets. So I reconnect my router and go to winipcfg and release my IP information and renew, to my surprise instead of, I have as my IP address and as my Gateway. Though my computer tells me that I am connected, I can neither access the web or my router ( in my browser. At this time, the mac is still working when the router is plugged in. PC works only when connected directly to the wall, so I figure it's something software related.

    Just FYI, I've tried the following with no success:

    I uninstalled the KB894391 update which seemed to cause the problem, but the problem still persists.

    I went to System Restore and tried to restore from a few days ago when the internet was working, and the system failed to restore.

    I used a different router (Apple Airport Extreme Basestation) with the exact same result (mac connects, PC doesn't, IP address for PC is

    I tried removing the windows firewall, and that didn't work.

    Rebooting the PC also doesn't work.

    Incidentally, I have a laptop (PC) too and I get the same problem with it as well, though it's been a while since I tried to connect it to my home network, so I don't know the time frame for the problem there.

    I should preface that I'm a network *****, but if anyone knows what I'm missing here, I would greatly appreciate it.
  2. Grok451

    Grok451 TS Booster Posts: 85

    Go into the properties for your Local Area Connection for TCP/IP and check to see that it is still set to "Obtain an IP address automatically" and "Obtain DNS server address automatically." Go into the advanced TCP/IP settings and remove any reference to in the default gateway area. You man need to reboot.
  3. Corribus

    Corribus TS Rookie Topic Starter

    They are both set to be obtained automatically. I could find no references to the IP address anywhere in the advanced settings (4 tabs: IP settings,DNS, WINS, and options) on the TCP/IP menus; perhaps there's somewhere else I'm not looking.

    Thanks for the help,
  4. dicksyo

    dicksyo TS Rookie

    Better start all over again (use the old settings).......As the Good Man said... better check your IP address maybe some No. are missing or messed up.......... Did I give some advice?

    ............Blind man can't help see blind man........
    ............But I didn't said I'm totally blind, just the other half...( :angel: )
  5. hdlk126

    hdlk126 TS Rookie

    I work for a cable company and install, as well as go out to fix, cable modems and routers all the time. I have seen the IP before with a router but I'm having a hard time remembering what i ended up doing to fix it? If it were me, and nothing else would work...I would unplug the cable modem, and the router...and turn off both computers overnite. If your modem is unplugged overnite you might be able to get a different IP address from your service provider...I've seen Bad IP addresses do strange things? This is definetely not guarenteed to work by any's just an idea. Good Luck, Jeremy
  6. Corribus

    Corribus TS Rookie Topic Starter

    I will try this tonight. Thanks for the suggestion. It just seems strange to me that this would happen all of a sudden after a Windows update, and then uninstalling the update doesn't fix the problem. Seems very illogical to me.

  7. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Well computers are ALL about "illogical" behavior. Otherwise there would be a single 1000 page book that had a fix for every issue :)

    Your 10.0.xx address is ALSO a private address range, as is So it is likely your router IS giving your PC this address. These are the private IP ranges: - - -

    I would use the MAC to scrutinize the router settings and make sure it doesn't have some kind of IP filter set, check the DHCP range settings. And anything else that looks suspicious. If all else fails, you may have to reset the router. Not turn off/on. But actually RESET it to factory settings, and start over. This will reset your password too etc...

    You can also try manually setting a static IP somewhere below the DHCP range. Like try to manually set or something. With the router IP as the gateway.

    Also try a different port on the router, and do winipcfg release/renew again.

    Lastly, it is not impossible that your NIC went bad and is not working right. This can cause issues like this I believe.

    good luck
  8. Corribus

    Corribus TS Rookie Topic Starter

    I appreciate the reply; oddly enough, I plugged the router back in to check it with the MAC and now it works. Did nothing different than before, and now it works; I have a IP address. Go figure.

    Thanks for the help, nonetheless, everyone.
  9. Grok451

    Grok451 TS Booster Posts: 85

    Is there any possibility that your Mac or something else on your local network is acting as a DHCP server? Try pinging the address that winipcfg reports as your default gateway. If you get a response, something on your network must be acting as your gateway and is giving your PC an IP before your router does.
  10. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    You were saying something about illogical behavior? lol
  11. Corribus

    Corribus TS Rookie Topic Starter

    I don't think it had anything to do with the Mac. I tried the address and the browser couldn't find it. Plus it seemed to occur whether the Mac was hooked up or not. In any case, it appears to be working now, somehow, so.. I guess I shouldn't worry about it until it happens again.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...