Black and white picture problem from Sky

By skydragon786 ยท 5 replies
Nov 25, 2006
  1. I'm wondering if someone can please help me, because this is starting to do my head in.

    I have an ATI X1600 graphics card, but it has no place on it which would enable me to record video from Sky TV via the SCART connection on the Sky Digibox (No s-video port), so I bought a PCI TwinHan Digital and Analogue TV capture card. The card has four places to connect wires - One is for S-video, one is for analogue and one is for FM. I also bought an S-Video to Scart cable.

    I connected the S-Video end to the TwinHan card, and the Scart end to one of the Scart bits at the back of the Digibox. However, this gives me a problem - The problem being that the picture comes out in Black and White on the PC. Anyone know how I can sort this problem out? My S-Video to Scart cable is a Gold-plated Profigold SCART to S-Video cable. The TwinHan card was this one:

    Any help would be appreciated. I have checked all over the internet, but none of those ideas work.
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415

    Your gonna giggle, but I link my laptop to my TV from the S-Video socket and I used a lead I made from a Scart with Svideo socket and an old broken Svideo plug, this works fine,


    I bought a proper lead from a shop and when I used it guess what...?


    Seems that some of the Svideo leads arent wired right.

  3. Jesse_hz

    Jesse_hz TS Maniac Posts: 545

    Ok, so I don't know much about ATI/AMD gpus, but I know that tv-signals are of two parts, luminance (the amount of light or just black and white), and chrominance, if the graphics card can't understand the chrominance information, it will only decode the luminance and that alone makes a greyscale (black/white) image.

    Different TV standards/formats have different ways of encoding the chrominance, but the luminance is almost always the same, therefore try and see if you can change the TV format in the settings menu of the digital sat-box or see if you can change the way the graphics card interprets the signal, most likely this will be somewhere in your driver settings.
    Ididmyc600, I once had the same problem when using a proper s-video lead and I fixed it by simply choosing composite in my Nvidia driver settings dialog. I was still using a s-video lead, but the signal running through it was composite, since the TV didn't understand s-video signals.
  4. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415


    So why did the home made lead work OK ?

  5. Jesse_hz

    Jesse_hz TS Maniac Posts: 545

    Not sure. Have you tried with other "proper" leads besides the one you bought?
    Seem odd that a store bought one would have wrong internal wiring.
  6. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415

    Not yet, when I get some time i'll link it up and check the settings.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...