1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Blank Screen! Which component is broken?

By gobblet ยท 5 replies
Mar 13, 2005
  1. Hello. Basicly as the thread title says, I'v got something thats broke and needs replacing but I don't know what that is exactly. I don't really want to replace all the parts when only one needs fixing.

    I recently put together my own computer. I had initially great success, everything up and running smoothly first power up (first time me ever building a computer from the ground up aswell...). My specs are as follows:

    Abit KV7 - VIA chipset
    AMD AthlonXP 3000+ (400mhz FSB)
    Radeon 9600
    2x512Mb RAM (1028Mb total, 2x200mhz)
    Sony DVD-ROM drive (IDE)
    80GB Maxtor HDD (IDE, Master)
    9.5 GB Seagate HDD (IDE, Slave)
    Akasa CPU heatsink/fan (up to 3400+)

    My OS is WinXP SP2 with all the latest updates, patches and drivers for everything, all official (no beta drivers, no omega's etc).

    Everything was running smoothly until I decided to upgrade the BIOS. I downloaded the program from the Abit website that lets you flash in windows (stop laughing at the back, I can't hear you...) instead of through DOS. Everything worked and I restarted and as instructed in the readme went into the BIOS to check all my settings (FSB settings, master/slave settings etc) hadn't been reset, which they hadnt.

    Here's where my problem begins. Out of complete curiosity I decided to change "CPU command decode", which is default at "normal" setting, to "fast". I have read that it basicly means higher performance - lower stability, so what can be the harm, I can always change it back to normal, I'll give it a try. Saved and restarted. Now I get no screen (light on monitor is amber which i'm fairly sure means no signal), the keyboard won't work (the capslock/numlock/scroll-lock lights won't show in either USB or PS/2 mode)
    and obviousally at the POST stage of starting the computer the mouse is no use to me. It seems like all I/O devices on my computer no longer work.

    If you managed to read all that then back to my question, how do I find out which bit is broke? I have tried switching the jumpers to short the CMOS, remove the battery but it doesn't affect the outcome, I still get a blank screen. Is the CMOS the problem? I could order a new BIOS chip for next to nothing, but it could also be a problem with the graphics card, or the processor, or... You see my problem.

    If anyone has any suggestions I would be very grateful. This is my first post on this forum so go easy. :D

    Thankyou in advance.
  2. JimShady23

    JimShady23 TS Maniac Posts: 373

    Sorry didnt register
  3. luvhuffer

    luvhuffer TechSpot Paladin Posts: 443

    So you changed the jumper on CROM to 1-2 to see the setting. When the system didn't boot you tried to clear the CMOS with it's jumper. Did you remember to reset the Clear CMOs jumper pins back to 2-3? OK here's what I want you to try. Start and stop your computer 4 times. Turn it on with the power switch, then turn it off by holding in the power switch tiill it shuts down. Don't use the reset button, power it all the way off. On the 3rd or 4th time, the mobo will automatically reset the BIOS to default so it can boot. I think. It does on my IC7 anyway. Another thing. When you flash a new BIOS from Windows, you have to still shut down your system, turn the power supply off and clear the CMOS and reboot, after flashing the new BIOS. Make sure it's switched off or even better unplugged whenever you clear the BIOS. Now I have to do some reading. I never heard of CPU Fast Command Decode before this post. Is that an AMD specific setting? Let me know how it goes OK?
  4. gobblet

    gobblet TS Rookie Topic Starter

    Ok I tried what you suggested, the monitor still wont light up. I think I forgot to mention in the previous post that all the fans/hdd's start up. I can't hear any beeps but then I never have when it worked becuase I think the polarity of the jumper on the motherboard is the wrong way around.

    I have tried all possible combinations of battery/1-2jumper/power settings, I have taken the battery out and leaft it for 1.5 days now (as I have heard it can take awhile for the CMOS memory to drain this way) but still no avail.

    CPU fast command decode is an option on the KV7 motherboard softtop BIOS. To be honest I have no idea what it does, it seemed like abit of a "make computer go faster" button and I was cautious, but my curiousity got the better of me. That won't happen again :eek:.

    Thanks for your help, but I have a feeling this might be a case of a defective part. :(
  5. shadow_29

    shadow_29 TS Rookie Posts: 211

    well first of all do you have onboard video?,my first reaction would have been that you only require to reset the cmos but you already said that it didnt work.the problem could be anywhere from the cpu to mobo,videocard to a ram stick,the only way you can isolate the problem is by trying your systems part on one by one in another working cpu or replace the part of your own pc one by one with spare/old parts that you got lying around.
  6. gobblet

    gobblet TS Rookie Topic Starter

    Unfortunatly there is no on-board graphics on the KV7. I'm currently trying to do exactly what you said on my previous PC but it's difficult on a 6 year old motherboard. :p Only thing i'm fairly sure of is the RAM is ok. I'm about to order a new mobo but finding a Nforce2 motherboard with exactly what I need (400mhz FSB, onboard line-in/mic along with 2 IDE channels) is a challenge...

    Thanks for all your help thought :wave:
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...