Blue Screen of Death - Error caused by Device Driver. Please help if you can.

By zoril ยท 9 replies
Apr 1, 2006
  1. Hi there,

    This is my first post in the forum. It is nice to meet you all:)

    I have crashed twice in last two days with the BSOD. My computer is a three week old Dell Dimension 9150 Pentium D dual core processor with 1 gig ram.

    The two BSOD messages were different. The first started RQL_NOT_LESS_OR_EQUAL with the message if this is the first time restart the computer, + a few suggestions from disabling bios memory options like caching or shadowing (that I didn't know how to do). The technical information was:-**STOP:0X0000000A (0x00650065, 0x0000001C, 0x00000000, 0x8050177F
    Beginning dump of physical memory, physical memory dump complete.

    Microsoft online crash analysis came back with - Error caused by a device driver, but there was no indication of which. No device driver showed in the BSOD. I looked in the system hardware and there were no exclamation marks or no other equipment etc.

    The next day the same thing happened again, only this time there was an indication where the device driver problem was:-

    The message this time was - **STOP: 0x0000008E (0xC0000005, 0xBF80D2F1, 0xF7721778, 0x00000000

    ** Win32k.sys - Address BF80D2F1 base at BF800000, Datestamp 43446a58

    I had a looked at the system event log and application log but nothing out of the ordinary was logged at the exact time of the crash. There were errors there mostly to do with Fax machine which I never have installed

    I did a search for Win32k.sys (inc hidden files and folders) and came up with 4 entries:-

    1.) C:\windows\system32 (file version - 5.1.2600.2770)
    2.) C:\i386 (file version - 5.1.2600.2770)
    3.) C:\windows\$hf_mig$\KB896424\SP2QFE (file version - 5.1.2600.2770)
    4.) C:\windows\$hf_mig$\KB890859\SP2QFE (file version - 5.1.2600.2622)

    As you can see for some reason the 4th file version seems to be different? I haven't try to change it yet. The size of the first three is 1,797KB the last one is 1794KB...

    I am afraid that I have very little computer knowledge and am uncertain how to create a mini dump file and am a little wary about going into the bios in case I do something silly and wreck the computer. My last BSOD was an hour ago. It took me a while to get back online as the BSOD reappeared on starting, until I used F8 then went to the desktop in safe mode.

    At the time of both crashes I was surfing the internet. Over the last 3 weeks I have installed many software programs, from security applications, to my wireless router, but no additional hardware has been added.

    Any help or advice would be greatly appreciated..............Howard:)

    P.S. I just ran memtest for about an hour or so and no errors showed up re memory etc. I must apologise if my post is not too clear. Perhaps some points are a little vague. My technical knowledge re WindowsXP Professional or computers, I am afraid is very limited. I looked in C:\windows\minidump but there is only one entry there I am afraid...
  2. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    your minidump file is under a folder called minidumps located in your windows directory. You will have to zip the file and upload it so we can analyze it.
    In the current format we cannot read it.
  3. zoril

    zoril TS Rookie Topic Starter

    Ohh apologies - I thought I needed to send it in .txt format. Sorry about that. The one I sent a few mins ago I changed to .txt. Shall I leave it in .dmp, zip it then send it that way?. I just enclosed it now. Thanks for the reply.................Howard
  4. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    your minidump debugs to win32k.sys driver error.

    Reload all your drivers with the latest drivers, ensure your BIOS is up to date.

    if your RAM checks out, then the only only areas it could be are bad drivers or faulty hardware. I suggest fixing your drivers first with a clean OS install and update of all drivers. (move all important data off)

    A small possibility is a virus, though unlikely.

    If you are running a firewall, ensure it is compatible with your Video and also up to date.

    what software and hardware are you using?
  5. zoril

    zoril TS Rookie Topic Starter

    Hiya:)) I have probably way too much software installed the .jpg shows my programs at least most of them....

    Hardware:- 3.5 Floppy Drive, 13 in 1 Media Card Reader, Sata 250 gig hard drive, Cyberlink power dvd, ATI Radeon x300 SE 128mb Hyper Memory, integrated Sound Blaster Audigy, Dell 2 usb button scroll entry level mouse,
    Dell quietkey keyboard, BTVoyager 1050 USB Adaptor (British Telecom) BTVoyager 2091 modem(British Telecom), Pentium D 3 .00ghz 9150 PD 930 processor - Dual Core.

    I have so much software as you see, the real problem will be finding out which one is causing the problem - that is assuming that the problem is software related:( I have read though that a number of people have experienced problems with some security applications/detectors causing the bsod.

    This computer being 3 weeks old, I would hope that the drivers are up to date, but I will visit Dell site to make certain. With the armory of virus, trojan, malware and rootkit checkers, although a virus can never be ruled out, it it is less likely to be that. A clean reinstall would be a nightmare as I have so much software, but as a last resort I would have to do that.

    The memory test I ran 4 times with no errors reported. Probably I would have to run it over night to be more certain. The error logs re Microsoft Fax I don't know if that is an issue here, but there were many errors there. My firewall is Sunbelt Kerio Personal firewall - main antivirus NOD32, although I use AVG also.

    Trojan detectors BOC Trojan hunter, Ewido. Protection - Process Guard, Reg Defend. Malware - Webroot SpySweeper, Ad Aware, Spybot Search and Destroy, Spywaredoctor.

    I also have Hijack This 1.91 to see what is running on my computer at any one time. There are other programs also. I probably don't need as many....

    Thanks for the trouble that you are taking to help me. Hopefully you can make out the programs. I had to reduce resolution to get under the 100k size and it is a bit blurred I am afraid. I think that it can be expanded to regular size (by holding the mouse cursor bottom right of the image for a few seconds).

    I was wondering if the Dr.Watson log would be of any help to you?

    Thanks again.....Howard
  6. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    could be your registry got corrupt. Quite likely in fact. Run norton systemworks registry repair to fix.
  7. zoril

    zoril TS Rookie Topic Starter


    That may well be a possibility re the registry - Currently I use Registry first Aid, Tweak now Registry Cleaner Pro and Registry Mechanic. I was also trying to see if there was any decent hardware diagnostic tools that might help.

    I just noticed this in the event viewer (see illustration). Could it be a factor re my problem? :- Apologies for the poor quality of the image. I think that it can also be enlarged one "notch"..

    Many thanks,

  8. jppranker

    jppranker TS Rookie

    I am having the same problem win32k.sys was wondering if someone could look at my minidump but I do want to hijack the thread will start another if necessary. Thanks
  9. zoril

    zoril TS Rookie Topic Starter

    I just noticed in my settings while automatically restart is unchecked overwrite would appear to be checked, but is greyed out so that I have no option to enable or disable the overwriting option. Can this be done in the registry? It may be the reason I only have the one entry in shown in windows/minidump.

    Overnight I ran Memtest86 V1.65 (23 passes) no fails. While this is no guarantee that all is ok re ram, memory etc, it does help and is maybe an indication that the memory might be ok. I believe that this particular freeware program is meant to be very good from several sources.

    JPpranker - Many thanks for offering to start a seperate thread re posting your minidump. It would avoid overlapping responses. Also the seperate threads would mean we could both follow suggestions from each one where applicable, including those unrelated to the minidumps.

  10. oldgolfer

    oldgolfer TS Rookie

    I experienced the same problem of intermittent memory dumps saying it was caused by hardware or software recently installed.
    Kerio personal firewall is the problem and over the past 3 days I spent considerable time with Kerio tech support and they made several adjustments to my computer which didn't solve the problem. The did acknowledge that Sunbelt Kerio firewall is causing the problem.
    Their advice is;
    An update will be released next week to cure the problem.
    In the meantime they recommended that when I get a Kerio pop up advising me of some computer action DO NOT REPEATEDLY SELECT DENY AS IT KEEPS POPPING UP. PUT A CHECK MARK IN 'ESTABLISH A RULE' THEN SELECT EITHER ACCEPT OR DENY. This will result in a given warning pop up only showing one time.
    They advised this will stop the memory dumps until the new download is available.
    Will it work, the tech says so, the value of his information is the he says the Kerio software is causing the problem.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...