Blue screens, then flashing LED's, no power up!

Not open for further replies.
Hey guys, new to the forums. Ive recently had a problem with my computer. I would be playing Guild Wars, or doing w/e (most of the time when GW was up) and a blue screen would show up, saying some kind of memory dump or something. It would restart my computer and then go to windows xp and say windows has recovered from a major error or something. But today it happened, and then it restarted, got to the windows boot screen and just stopped. So i hit power off and now it wont even power on!

When i try to hit the power on, the LED's inside flash, the fans start for like half a second, and everything just goes dead again. The lights on the NIC work, but it just wont start up now. I had a similar thing happen to me once before with my previous mobo and it just blew something in the circuitry. Was wondering if it was that maybe because it had similar conditions, but it would keep flashing, instead of just once. Any help would be appreciated, thanks!


Posts: 68   +0
ouch sounds like you fried something you could try and stick your computer in the freezer for fifteen minutes or so and see if that works for you that would be my best guess.
  • Thread Starter Thread Starter
  • #3
new prob

Well I was searching through some of the previous threads and i tryed to switch the power supply. Yea I think that was it because Im using an older psu and it is now working, but now there is a new problem. When I start up the computer, it checks for RAM, and then decects IDE drives (slower then usual) then goes to another soyo boot up screen, and says:

Scan devices, please wait....
Serial_ch0 Master: No Device
Serial_Ch1 Mater: No Device

I was then thinking that I didnt have enough power so i stripped the floppy and cd rom drives off, and still the same thing. It will say that and just stay there, nothing else, almost as if it doesnt detect the hd. Need help!! thanks!


Posts: 7   +0
Perhaps you could try to put your HD in another computer to see if it's detected over there. Just to make sure you didn't fry your HD as well. Also you could try to put your HD on another IDE channel to see if that works.

(Not sure how much you know about computers .. so going to explain that bit to you:
The big grey wire running to your Mainboard is connected to a blue connector (IDE 1) you could try to just move that over one spot to the white one next to it to see if anything happens)

Other then that .. I have no idea.

Good luck with your problem.
When that happened to me (memory dump thing and hdd not detected), I checked the ide cables, power supply etc, everything was alright. And then I noticed that sometimes bios would detect the HDD and sometimes not. What I did next, when it did detect my hdd was try to see if I could reinstall my OS (my last resort believe me), and it wouldn't even let me format the hdd from the bios. I replaced my hdd, problem solved. I am not saying you have to do this also, but I tell you I did try every known rule in the book and didnt get that hdd going. I hope that with your case is different and wish you luck in your repair :approve:
Not open for further replies.