Boot problem, Bios cannot detect any HD

Not open for further replies.

after a couple of days of searching the web looking for an answer to my problem i have not succeded and so have decided to see if anyone here can help!!

My problem starts with my pc not booting up past:

'Verifying DMI pool data' resulting in 'Disk boot failure please insert system disk and press enter'

I have had previous trouble with the machine (which was corrected) and had enough of tackling problems myself and so took the machine into a shop to be repaired. They replaced the power supply and ran some diagnostics. When it returned it worked fine for about a week or so and then i started getting the same error:

'Disk boot failure please insert system disk and press enter'

i ran a chkdsk on the c drive in another machine and it did not return any errors. After much deliberation i then decided to re-install windows and reformat the drive (c:). The fresh install worked fine for about two days before recieving the message again:

'Disk boot failure please insert system disk and press enter'

at this point i began to do some research on the internet about what the problem maybe and found out techniques that others had used with success (such as FIXMBR) my intention was to run this command and see the outcome but first i thought i would run a chkdsk to see if the drive had gone bad. this time it did return with errors and i ran a /r to reapir the drive.

This is where i get a bit stupid, i have two drives installed on the machine (1 for OS and one for Data) just so that i wouldnt lose any data if the OS system had to be re-installed. After the chkdsk /r had completed on the OS drive i realized that my second drive was plugged in. i switched off the machine and unplugged the second drive.

Now when i boot up the machine the bios cannot detect any drive (apart from the cd/dvd drive). The OS drive (1st drive) is definatly connected and so is the power cable to the drive.

im very confused by this and my freind has said that to him it sounds like a controller issue? can anyone else offer their 2 cents?!!!

OS: windows XP home edition
motherboard: Abit S478 Intel 875P ATX A L
HD: Maxtor DiamondMax Plus9 80GB SATA150


Posts: 7,787   +856
TS Special Forces
It could be a controller issue. Did you install the SATA/RAID controller drivers?
in all honesty i do not know, after the re-install of windows the pc booted up fine and restarted several times and i presumed it was stable. would it have been able to boot up if it did not have the controller drivers installed?

where can i get these drivers from?

thanks for your quick reply!


Posts: 1,997   +2
I am not sure it is a driver or motherboard controlled issue - more likely the drive's own card. This can also be caused by a poor PSU output.
What happens if you try booting with just one drive connected (no CD/DVD drives either)?
wow thanks for the quick response again, im at work atm, i wasnt expecting such fast replies. I will try what you suggest when i get in and let you know.

at a guess i would say that bios will not pick up the drive and i will get the 'disk boot failure' msg, but i do not know for sure. i was going to take the drive out and see if it will boot on another machine when i got in aswell.

thanks again


Posts: 1,997   +2
You could also try running the Maxtor diags software which can be found on the Seagate website (they bought Maxtor).
Hi i tried to run the drive from my pc as a slave in another and it cannot even detect the drive in the other machines bios. I have ordered a new hard drive as this drive was about 3 years old, i will keep you posted as to wether the problem still persists!
Not open for further replies.