1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Both DVD & CD burners suddenly not burning

By billyellis · 12 replies
Sep 29, 2006
  1. Hi there,

    I recently went through a trojan removal with the help of this board, but I am still a newbie, so please forgive me if I commit any TS faux-pas...

    Yesterday my DVD burner locked up at 22% of the project completed (green LED indicating reading of the disc solid on). I was using Disc Copier (Roxio) from another DVD I had burned previously, so I tried again, this time actually copying the files to the HD first and then using Easy Creator and it froze again at 22%.

    Today I tried to burn a music CD on the CD-RW drive (my DVD drive stopped recognizing blank CDs a while ago), and that is also giving me error messages:

    E8004139a: IDispatch error #4506
    E80070057: The parameter is incorrect

    This is happening before it even begins to burn. The disc is ejected and still shows up as a blank CD if I try again later.

    Both drives have always worked fine. Lately I had the trojan and virus issues mentioned above, but both drives were working after that hassle. I am now running Ewido (including the Shield), as well as Ad-aware's Ad-watch in the background, though, so perhaps updates to those programs since could be involved?.

    Other changes that are probably unrelated (but maybe not) are in Firefox, which is the most recent update ( A few days ago Firefox stopped recognizing any of my customizations, and every time I reopen or open a new window it is in default layout/window size/etc. I can't remember if I have burned any DVDs since I installed that FF update a few days ago...

    Has anyone heard of any interaction issues with the programs I mentioned? I have searched for burner issues here a little, but there are a million and each are different, although I did try one of the solutions suggested to one of the posters (e.g. setting the IMAPI service to Automatic) whose problem sounded similar. But that post was over 2 years old, so I was not surprised when that suggestion did not work for me.


    Edit: FF also will not Bookmark pages unless I select a different folder destination than the default either
  2. Rick

    Rick TechSpot Staff Posts: 4,512   +65

    I haven't seen this before, but I found something that might be related.
  3. billyellis

    billyellis TS Enthusiast Topic Starter Posts: 154

    Thanks for the post Rick.

    Unfortunately, even after converting all files to 192kbps or higher, I get the same error...

    But I am mostly worried about the DVD burner not working. My drive is pretty full, and if I can't take stuff off (or back up) as needed, I am going to have an awfully hard time working. :(
  4. billyellis

    billyellis TS Enthusiast Topic Starter Posts: 154

    Bumping this post since I posted late Friday and may not have been to visible to everyone by Monday...

    Still looking for any advice here. I don't know what happens when a drive goes out, but I assume that it doesn't work at all. In this case, it is burning to just under 1Gb and then freezing up in the DVD drive. I have been able to burn data to CD in the CD drive. Since the software seemed to be able to handel that much, I tried burning one CD's worth of data (~700Mb) on DVD as a session, then burning another as another session. The first burn went OK, but the 2nd then froze up the same way. I don't really know anything about how burners work, but it almost sounds like it could be a memory/buffer issue to me. Anyone know more about how these drives work?


    P.S. Any anyone with advice on why FF is refusing to remember my customizations would be a big help. That is really starting to irritate me...
  5. fimbles

    fimbles TS Evangelist Posts: 1,191   +207


    Dodgy lazer assembly on your dvd?

    Try uninstalling and reinstalling drives?

    Get rid of ff.. but i doubt this is the problem.

    Give lens a clean.. sorry i couldent be more help.

    Ps: sorry for the dupe rick.
  6. Rick

    Rick TechSpot Staff Posts: 4,512   +65

    This is the exact same thing I posted word for word. Please read through the thread before responding.
  7. Rick

    Rick TechSpot Staff Posts: 4,512   +65

    To rule out your CD burner, I'd like you to try a free CD burning program. Download the shareware version of Nero from http://ww2.nero.com/nero7/enu/nero7-demo.php and give it a whirl.

    If you don't care for the huge download, you can try another freeware burning program like http://www.cdburnerxp.se/

    If it works, then we can blame your Roxio software. If it doesn't work, then we know we should be looking at your Windows system or drive.
  8. billyellis

    billyellis TS Enthusiast Topic Starter Posts: 154

    Thanks Rick.

    I will download Nero and try it out when I have a good chunk of time tomorrow. I have been using the CD drive to burn data (and music once I converted the mp3's into enough different formats that whatever error was embedded in there disappeared).

    So the problem is only with the DVD drive and burning at this point. I assume that Nero does DVD burning as well as CD burning? I will check it out...
  9. Rick

    Rick TechSpot Staff Posts: 4,512   +65

    Yes, it does. CDBurnerXP also supports DVD formats as well. :) But neither copy protected DVDs.
  10. billyellis

    billyellis TS Enthusiast Topic Starter Posts: 154

    OK, I installed Nero and I am still getting errors. I tried burning with default settings, then with everything reduced to the slowest speeds, etc. I saved the log of the last attempt and attached it to this post. It is gibberish to me, but it is much more descriptive than any error messages I have ever gotten from Roxio software...

    2 things that were different using Nero:

    a. The drive pops in and out without any prompting from time to time. I have never used Nero before, so I don't know if that is normal? I am using DVD+R media, by the way. I have used this media successfully before, but maybe Nero doesn't like it?

    b. It doesn't seem to be writing much to the drive before failing, whereas Roxio at least was burning almost 1Gb before crapping out.
  11. Rick

    Rick TechSpot Staff Posts: 4,512   +65

    According to your log, your DVD burner is not running DMA mode - this is definitely a problem and generally a software issue. Keep in mind this may not be the problem, but it needs to be fixed regardless.

    For IDE burners, there are two modes: DMA (good) and PIO (bad). PIO is incredibly slow and brings your computer to a crawl, which in turn is responsible for many other problems including buffer underruns and wasted CDs. DMA is newer, faster and always supported with modern drives.

    First thing you should do is enable DMA. If you can't, then we need to figure out why you cannot. If you still have problems afterward, then you can try a firmware update. Your drive appears to be a BTC dual-format burner, which should be updated using this utility: http://www.drvupdate.com/. Even if the problem goes away, its a good idea to update your firmware as it fixes bugs, improve performance & reliability etc...

    A nice guide with photos - How to Enable DMA:

    Directly from Microsoft:
  12. billyellis

    billyellis TS Enthusiast Topic Starter Posts: 154

    Thanks Rick.

    The DVD drive had indeed been switched to PIO (apparently Windows likes to do this on its own without asking after several data errors). Since switching it back, I have successfully burned several DVDs, so I think I am OK... knock on wood.


    Thanks for your help.

    And for anyone else having this problem: if you follow the links above and then look around bit (I searched for PIO and DMA since I wanted to know what they were acronyms for), the next step to take if you keep getting reset to PIO or if you are not allowed to make the change (DMA option is greyed out), you can then try uninstalling the IDE controller in question and reboot. Supposedly Windows will then automatically re-recognize the "new" device and reset to DMA, or at least give you the option back to select DMA.
  13. Rick

    Rick TechSpot Staff Posts: 4,512   +65

    Yes. This is very annoying, especially for laptop users with removable drives. :)

    I'm glad to see you resolved it.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...