BSOD: System Error, Category 102, ID 1003

Status
Not open for further replies.
Okay, before I get flamed about this, I do realise that there were posts similar to this one made quite recently. Unfortunately the solutions suggested in these have not worked for me. This is not surprising as the category 102 system error can be the result of quite a number of different things going wrong as I understand it.

Symptoms:
I also experience the blue screen, the restart and discover the category 102 system error in my event logs. This happens every time I place my machine under load (I'm busy stress testing a web application).

Specs:
P4 2.8 Ghz, 512MB Ram, Win XP Pro (SP2)

I've tried:
1. Reading the minidumps by following the instructions posted by cpc2004 in another thread but failed to do so as it kept on complaining about symbols.
2. Running memtest - nothing to report.

I'm attaching my minidumps in the hope that someone will be able to read them and help me out. I'm at my wit's end :eek:

Edit: This may or may not be relevant. VMWare was recently installed on the machine.
 

Attachments

howard_hopkinso

Posts: 21,238   +17
Hello and welcome to Techspot.

3 minidumps crash at vsdatant.sys. This is your Zonealarm firewall. It is known to cause problems on some systems/configurations. They have a bugcheck of C2.

Try updating Zonealarm. if that doesn`t help. Uninstall Zonealarm, and try a different firewall programme, such as the Kerio firewall from HERE

3 minidumps crash at ntkrnlmp.exe. This is a NT Kernel & System file. They have a bugcheck of 50.

It could be that Zonealarm is the cause of all your crashes, so deal with that first, and test your system.

If after doing that you still get BSOD`s, go HERE and follow the instructions.

0x000000C2: BAD_POOL_CALLER

A kernel-mode process or driver incorrectly attempted to perform memory operations. Typically, a faulty driver or buggy software causes this.

0x00000050: PAGE_FAULT_IN_NONPAGED_AREA

Requested data was not in memory. An invalid system memory address was referenced. Defective memory (including main memory, L2 RAM cache, video RAM) or incompatible software (including remote control and antivirus software) might cause this Stop message, as may other hardware problems (e.g., incorrect SCSI termination or a flawed PCI card).

Regards Howard :wave: :wave:
 
  • Thread Starter Thread Starter
  • #3
Geez that was quick. :)

I'm going to try and update Zonealarm as you suggested. I may even uninstall it to see if it fixes the problem. I'll report back on that once I'm done.

Thanks for your help. It's really appreciated!
 

howard_hopkinso

Posts: 21,238   +17
If you decide to uninstall zonealarm without having another firewall in place. You should disconnect from the internet to avoid your computer being attacked.

Regards Howard :)
 
  • Thread Starter Thread Starter
  • #5
Okay, I decided to uninstall Zonealarm. It's probably worth the risk as this particular computer will not see the internet any time soon.

I've started up another stress test running against the machine in question and I'm happy to report that so far so good. It's been much more stable (it usually crashed 3-5 minutes into the test). I don't want to speak to soon but I suspect my problem is solved.

Once again thanks for the help and advice.
 
  • Thread Starter Thread Starter
  • #6
Okay, two stress tests completed! I think it's safe to say that the problem is solved.

howard, your help is really appreciated. As soon as I figure out how to read the minidumps I'll do my best to help out others.
 

howard_hopkinso

Posts: 21,238   +17
That`s good news.

If you would like to read minidumps. Take a look at this short tutorial HERE.

As well as the !analyze -v command. A really useful command is the !thread command. This will let you see the owning process.

Regards Howard :)
 

cpc2004

Posts: 1,994   +0
Hi Howard,

FYI

Mini021406-01.dmp BugCheck 10000050, {bad0b148, 0, 8056c77b, 0}
Probably caused by : ntkrnlmp.exe ( nt!ObpRemoveObjectRoutine+cb )

Mini021406-02.dmp BugCheck C2, {7, cd4, 2060006, 84490740}
Probably caused by : vsdatant.sys ( vsdatant+3e6e1 )

This problem is exactly the same as the following problem. Both problems use the same version of ZoneAlarm.

vsdatant.sys Tue Nov 15 14:37:24 2005 (43798224)

https://www.techspot.com/vb/showthread.php?p=247222#post247222
 

howard_hopkinso

Posts: 21,238   +17
cpc2004 said:
Hi Howard,

FYI

Mini021406-01.dmp BugCheck 10000050, {bad0b148, 0, 8056c77b, 0}
Probably caused by : ntkrnlmp.exe ( nt!ObpRemoveObjectRoutine+cb )

Mini021406-02.dmp BugCheck C2, {7, cd4, 2060006, 84490740}
Probably caused by : vsdatant.sys ( vsdatant+3e6e1 )

This problem is exactly the same as the following problem. Both problems use the same version of ZoneAlarm.

vsdatant.sys Tue Nov 15 14:37:24 2005 (43798224)

https://www.techspot.com/vb/showthread.php?p=247222#post247222

As always. Thanks for the info cpc2004.

Regards Howard :)
 
Status
Not open for further replies.