1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

BSOD when playing ANY 3D game

By trancecan · 30 replies
Nov 8, 2005
  1. I have been suffering this problem for a long time, and it's now getting much worse. ANY game I try to play, I get a BSOD very quickly, usually within a minute or two of starting the game. (I used to be able to play for a while)

    I RARELY get a BSOD when just in regular windows, surfing the net, etc...

    I have swapped out my video card with my brother's and the problem is still there, so I know it's not the video card or video drivers. I even wiped out the C: drive and re-installed XP from scratch.

    Interestingly, I DID get a few BSOD's while trying to run the setup program. The first part went fine, but in the second part of the install when it's graphical....there came the BSOD's. After a few tries finally got a clean install.

    Could it be a power supply problem? If I'm close to maxing this PSU out and I run a 3D game, does that increase power usage? Here's my specs:

    Intel Pentium 2.4c
    ASUS P4C800E-Deluxe Motherboard
    1xATI Radeon 9800 Pro (128MB) - AGP8X
    1xPCI TV Tuner Card
    2x512MB PC3200 Samsung RAM (as per ASUS QVL list)
    2x160GB Maxtor SATA Hard Drives (connected to the Intel ICH5R Raid Controller)
    1x120GB Maxtor SATA Hard Drive (connected to the Promise Controller)
    1xLG Super-Multi CD/DVD Burner
    5x80mm Case Fans
    Enermax 350W Power Supply

    I have tried removing, cleaning and testing the memory, ran tests for over 12 hours and no errors on either stick. I tried running windows wth just 1 stick of ram installed...same BSOD problem...tried just the other stick..same BSOD problem. So, I don't *think* it's the RAM...hopefully someone can make sense of these minidump's.

  2. trancecan

    trancecan TS Rookie Topic Starter

    I didn't mention...this is not related to any specific game, but any application which uses 3d graphics. I can't make it through 3DMark05, sometimes I get through the first test, sometimes not. Also it happens during dxdiag's Direct3D tests (not always, but it does happen).

    Also, my case is well cooled, currently at 26c, CPU is at 34c (cpu gets up to mid-high 40's during a game).
  3. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Hi trancecan,

    Form the stack trace. I find memory access fault. Probably it is faulty memory.

    You can run memtest to stress the ram. If memtest reports the ram is faulty, ram is bad. However Memtest is not a perfect tool to test the memory as some faulty ram can pass memtest.

    1. Check the temperature of the CPU and make sure that it is not overheat (ie temperature < 60C)
    Make sure that the CPU fan works properly
    2. Reseat the memory stick to another memory slot
    3. Downclock the ram
    4. Clean the dust inside the computer case
    5. Make sure that the ram is compatible to the motherboard
    6. Check the bios setting about memory timing and make sure that it is on
    If it still crashes, diagnostic which memory stick is faulty
    1. Take out one memory stick. If windows does not crash, the removed memory stick is faulty.
    2. If you have only one memory stick, replace the ram
    f7230f6c f75d0ac8 e14b6ab8 00000453 00000000 0x0
    f7230fac f75d0bbb e14b6a78 00000453 00000000 Ntfs!NtfsLookupNtfsMcbEntry+0x9b
    f72310b8 f75d107c f7231564 e14b69e0 00000453 Ntfs!NtfsLookupAllocation+0x5b
    f7231288 f75d0cf6 f7231564 83035c88 e14b69e0 Ntfs!NtfsPrepareBuffers+0x270
    f7231470 f75d36fe f7231564 83035c88 e14b69e0 Ntfs!NtfsNonCachedIo+0x20e
    f7231550 f75d2fbf f7231564 83035c88 00000001 Ntfs!NtfsCommonRead+0xbdd
    f7231700 804e13d9 8675a020 83035c88 867ca828 Ntfs!NtfsFsdRead+0x22d
    f7231710 f7674459 f723175c 804e13d9 84579dd0 nt!IopfCallDriver+0x31
    f7231718 804e13d9 84579dd0 83035c88 83179d18 sr!SrPassThrough+0x31
    f7231728 b7c572a3 838b22d0 83179d18 83345848 nt!IopfCallDriver+0x31
    WARNING: Stack unwind information not available. Following frames may be wrong.
    f723175c b7c51950 83035c88 838b22d0 8317e630 naiavf5x+0x82a3
    f7231770 804e13d9 83179c18 83035c88 00453000 naiavf5x+0x2950
    f7231780 804fb09e 00000000 83345838 83345848 nt!IopfCallDriver+0x31
    f7231794 804fb0c5 83179c18 83345809 83345850 nt!IopPageReadInternal+0xf3
    f72317b4 804fadec 838b22d0 83345870 83345850 nt!IoPageRead+0x1b
    f7231828 804e9893 28cb08c0 ca113000 c032844c nt!MiDispatchFault+0x280
    f723187c 804f9802 00000000 ca113000 00000000 nt!MmAccessFault+0x642 <--
    f72318bc 804f2d12 ca113000 00000000 f72319e0 nt!MmCheckCachedPageState+0x476
    f7231904 804f3023 838b0a50 f7231944 00004000 nt!CcMapAndRead+0x94
    f7231998 8057dbaa 838b22d0 f72319d8 00004000 nt!CcPinFileData+0x24a
    f7231a0c 80591683 838b22d0 f7231a34 00004000 nt!CcPinMappedData+0xf4
    f7231a5c 8058068e e1037008 e249e538 e1037008 nt!CmpPinCmView+0x3d
    f7231a78 805d7642 e1037008 00450cc0 ca111cc4 nt!HvMarkCellDirty+0x6c
    f7231a90 805d7730 e1037008 00450cc0 ca111cc4 nt!CmpMarkKeyValuesDirty+0x23
    f7231aac 805d725b e1037008 00450cc0 ca111cc4 nt!CmpFreeKeyValues+0x17
    f7231ae8 805d73a5 e1037008 003cdb70 c9a8eb74 nt!CmpSyncKeyValues+0x26
    f7231b2c 805d77ed e2859000 00000400 00000001 nt!CmpCopySyncTree2+0x1f4
    f7231b5c 805d79f0 e1037008 00000110 e1037008 nt!CmpCopySyncTree+0x4f
    f7231ccc 805ae3f6 00010003 f7231d64 f7231ce8 nt!CmpSaveBootControlSet+0x2a7
    f7231cdc 804dd99f 00000005 f7231d64 804e39c3 nt!NtInitializeRegistry+0x5e
    f7231cdc 804e39c3 00000005 f7231d64 804e39c3 nt!KiFastCallEntry+0xfc
    f7231d58 804dd99f 00000005 0007fe8c 7c90eb94 nt!ZwInitializeRegistry+0x11
    f7231d58 7c90eb94 00000005 0007fe8c 7c90eb94 nt!KiFastCallEntry+0xfc
    0007fe44 00000000 00000000 00000000 00000000 0x7c90eb94
  4. trancecan

    trancecan TS Rookie Topic Starter

    Well I guess it's possible that BOTH of these sticks of memory are bad and that both are passing memtest ok...and are working fine except when trying to use 3D graphics.

    Could a power problem cause this type of problem making it appear as though it's the ram that's bad?
  5. cpc2004

    cpc2004 TS Evangelist Posts: 1,994


    Do you follow my instruction to perform the problem diagnostic? Inadequate power may also trigger memory corruption.
  6. trancecan

    trancecan TS Rookie Topic Starter

    Yes I did the whole thing before posting my minidumps.

    Temps are normal (cool actually), the case is squeaky clean and dust free inside and out.

    I am running MBM and have it logging everything in 4 different file formats hoping to be able to see the stats at the moment it crashes (voltage, temps, etc..) but whenever the crashes happen it corrupts the log files so when I reboot they are blank.

    According to the power supply calculator I found linked from somewhere on here, I should be using approx. 290 watts. They say most power supplies don't achieve much better than 70% efficiency, especially as they age. So I'm really suspecting it's the power supply now.

    Is there something about running 3D graphics that makes the computer consume more power? If so...that could explain why I run fine under normal conditions but crash when getting into any 3D graphics.

    I am going to run memtest again overnight to see if anything happens. Thanks for helping!! I'm trying to solve this the most economical way I can. So I don't want to run out and buy new ram if it's actually something else like the motherboard or CPU. Because if that's the case, I'd move up to something that uses the new CPU sockets. At least if I buy a new power supply I can bring that with me through any mobo/cpu upgrade.

    I'll report back when I get more info.

  7. osram

    osram TS Rookie Posts: 47

    well im having the same problem recently.

    ive got the newest mb drivers, some decent gfx drivers.. about a 3 week "new" service pack installed and the system runs absolutely fine.

    but when i try to run a 3d game it crashes immediately and reboots, no BSOD although i dont know if it is enabled anyway.

    i assume it is the mainboard or the ram. as i bought a 400 watt (450) superflower PSU. (I can only recommend it.) my old 350 watt psu appeared to be absolute crap but it didnt change anything.

    i have also been running memtest all night long and it hasnt found any errors. i wonder why the cache is "enabled" in memtest because with cache enabled the memory-values dont remain saved in the ram anyway. (compared to microsoft memory diagnostic tool.)

    but also MMD tool doesnt recognise any errors...

    my last cpu (2600+ amd athlon xp) perished. so i have a 1200+ installed now and still waiting for the 2700+ i ordered.

    Anyway i cant tell whats the problem. ive searched through so many boards past 2 weeks now.

    and im absolutely fed up of the people saying that it COULD BE THE PSU.

    the guy which works at my favorite computer store says he has a 410W PSU running about 6 harddisks, 4 dvd drives.. a burner ETC.

    So i would be really happy if some1 has got an idea how to fix problem. Someone who knows enough about this problem for real.

    ******** -.-

    btw: ive got a gigabyte mobo waiting with 2x 512mb (dual channel) for the new cpu when it arrives. so i can finally exchange everything, and then it hopefully works.

    Still it might be nice to have an answer to this problem. for the other people too...
  8. kirock

    kirock TS Rookie Posts: 1,221

    What video card are you running?
    How much RAM do you have?
    The 1200XP is very old CPU, did you reinstall the heatsink and Fan properly, using thermal paste?
    Reinstall DirectX9.0c.
    Increase your Hunkmegs/heapmegs in each game to at least half the amount of RAM you have.(eg, if you have 512Mb, then set HunkMegs to 256).

    How long does it take before the computer crashes? Is this immediately or a few minutes? Immediate crash would suggest a driver conflict. If you can enter the game and just get started then crash it might suggest CPU overheating, PSU problem (yes 400W piece of crap PSU will still give you probs)(a piece of crap is a piece of crap, no matter how new it is), or video card overheating.
  9. osram

    osram TS Rookie Posts: 47

    ehm... no.

    i have a spire special thingy vent on the cpu and there shud still b some cooling paste between it.

    the temperature doesnt seem to be the problem. it crashes immediately. i only know that my 2600+ was seriously overclocked, and the gfx card is a gigabyte geforce 6600 GT with passive cooling, although it hardly raises above 40 degrees. i dont think my cpu raises over 60-70 degrees either, and if that would be the case it shouldnt just reboot after starting a 3d game like ut2k4 for instance.

    how can i activate the BSOD or error report without just rebooting directly?

    since i reinstalled the system freshly i only used one driver so i dont think it is a driver conflict.

    i really hate this problem and many many people are suffering badly.
    "we are living in a world of pain! oh yes we are." 0_x

    It would be nice to have a freeware tool to check ram/mainboard effectively.

    it is just so annoying. the direct X 9.0 c is FRESH.

    Ans also as a remark: fallout 2 is running without problems as it is 2d.. only sometimes with the video sequences ive been having crashes.

    I really assume some 3d-processing part of my computer is causing trouble. (mobo?) i just cant say.. the graphics card is pretty new and ive been having the same problems with my old radeon 9000 before. only that i could play guildwars for about 10 minutes, respectively counterstrike for max. around 40 minutes.

    awesome. puke:
  10. kirock

    kirock TS Rookie Posts: 1,221

    Did you adjust your BIOS settings down from the OC settings when you replaced the CPU (1200+), it really won't like the old OCed values. Try increasing your page file value to 1.5X your RAM size. R click MyComputer/Properties/Advanced/Performace settings/Advanced Tab/Virtual Memory

    Turn on BSOD: same as above except not Performance, but Start Up and Recovery settings/uncheck "Automatically restart".

    I have the 6600GT PCI-e card and it runs great, can play CS:S all day (often do on weekends), so it shouldn't be that, unless the 1200+ CPU is just too slow to keep up with the games you are playing. Even if you crank all settings to minimum 3D games crash?

    PS: Edit, 40 mins or even 10 mins then a crash really is suggesting overheating, maybe of the PSU, that 400W unless it's top of the line is suspect.
  11. trancecan

    trancecan TS Rookie Topic Starter

    STILL crashing like a madman here too.

    I've added heavy duty cooling on both the video card and CPU. That helped marginally, I can actually get through the 3dMark05 tests now without crashing. I can even play the game "Pirates" now. Still some other games crash (Age of Empires 3). Lately it's started to BSOD on me during windows shutdown.

    To turn on BSOD so it doesn't just reboot on you, go to System Properties (Control Panel->System...or Right click on My Computer and choose "Properties")

    In system properties click the "Advanced" Tab and hit the "Settings" button in the "Startup and Recovery" section. You will then see where to remove the checkmark for "automatically restart"

    I'm still not decided on what to do next. I may replace the PSU, mostly because mine's 2 years old (Enermax) 350W and even though the calculator someone linked to on here says I only need 300W, I'd just feel better I know I've eliminated that possibility. The only thing remaining after that is to replace my mobo and CPU. If I'm going to do that, I'll be replacing BOTH at the same time to move from the 478 socket to an LGA775. That's a $300 move.

    Keep at it osram, please do post if you figure out the trouble.
  12. kirock

    kirock TS Rookie Posts: 1,221


    Replace that 2 yr old Enermax 350W. They are not bad, but not the best and probably only run at 70-75% rated power continuosly. 350X0.75=262.5W (ouch).
  13. osram

    osram TS Rookie Posts: 47

    ummmm well as im saying in almost every reply the PSU is not the problem. i have a 400W superflower power supply, actually it has up to 450 W max. value as it is a very mighty psu. it has 3 levels of vent-speeds, and it keeps running for 5 minutes after shutdown to get the rest of the hot air out of the case. (with those nifty blue LED lights blinking and lightning around too.)
    also it has patented modular cables which you can connect to the psu at desire; and a pretty unique special separate powercable for the graphics card. WOW! seriously i could even take a precious p00 on my psu while running my computer and it would still work. believe me. just look for the superflower glowing 400W thingy on google and you will c. And well yeah, my old psu didnt even manage to supply 250W of current, although its written 300W on it. so cheap.. and bad. incredible. it still didnt make any difference, i could even play guildwars for 10 minutes and cs source for nearly an hour with the old setup though. now things r even worse, even with my mighty superflower azn psu. i badly think its the motherboard.. too bad those ramtests r useless, and too bad i dont have any other used ramstick to switch and check.

    NO: i am not running my 1200+ amd on 2800+ overclock. -.- it changes automatically on new setup; unless it'd be my broken 2600+.

    i broke my other cpu becos my stupid friend kept telling me that his cpu is exactly the same and is running fine on 11.5 by 166/33.
    and it wasnt true. stupid stoner.. seriously, im glad i quit smoking pot since a while.

    i am so happy my new cpu is coming in a couple o days becos i will just replace my mobo, ram and cpu. its all ready lieing around.. but this doesnt imply that i wont hate you all for the rest of my life if we dont manage to find a solution.

    btw: many people with the PCI-Express 6600 GT are having this problem too.. it really doesnt make any difference. i cant imagine changing agp aperture size or the windows crap cache file size will solve the problem.

    man i really hate you all and every new
    "progressive" computer invention. hard enuff to order a socket A processor for my "oldschool" mobo/ram. what a pain in the assmar sir.
  14. kirock

    kirock TS Rookie Posts: 1,221

    Ok you've convinced me it's not your PSU, so I won't harp on that point anymore. Have you run DxDiag, do you get any errors/conficts?. Start menu/run/type "DxDiag" without the quotes.

    Also make sure you have Fast Writes turned off in the BIOS, that's famous for causing instability and crashes. You might also want to up the Vcore voltage on that old CPU by 0.05 or even 0.1 volts. There's a thread around here somewhere which fixed a similar prob for some else. You can maybe search my posts (prob late Aug/05).

    Good luck with the new mobo and CPU, but what are you going to do with your RAM, if it's bad, then you just transferred the problem? Then again at least you'll know what the problem is!


    Edit: forgot something. You are turning off active virus scanner, especially Norton Symantic, any of these programs are nitorious for crashing complex programs like games and graphics software. Also run GameXp, it automatically turns off alot of useless Windows services that are not needed. It's freeware and completely harmless.
  15. osram

    osram TS Rookie Posts: 47

    well ive run dxdiag. it doesnt find any conflicts. everything fine...

    ive also found the errormessage which always shows up in the logs when i suffer a crash from a 3D game:

    Ereignistyp: Fehler
    Ereignisquelle: System Error
    Ereigniskategorie: (102)
    Ereigniskennung: 1003
    Datum: 06.12.2005
    Zeit: 10:54:12
    Benutzer: Nicht zutreffend
    Computer: XXXX
    Fehlercode 10000050, 1. Parameter 8c6a3119, 2. Parameter 00000001, 3. Parameter bfade471, 4. Parameter 00000000.

    Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.
    0000: 53 79 73 74 65 6d 20 45 System E
    0008: 72 72 6f 72 20 20 45 72 rror Er
    0010: 72 6f 72 20 63 6f 64 65 ror code
    0018: 20 31 30 30 30 30 30 35 1000005
    0020: 30 20 20 50 61 72 61 6d 0 Param
    0028: 65 74 65 72 73 20 38 63 eters 8c
    0030: 36 61 33 31 31 39 2c 20 6a3119,
    0038: 30 30 30 30 30 30 30 31 00000001
    0040: 2c 20 62 66 61 64 65 34 , bfade4
    0048: 37 31 2c 20 30 30 30 30 71, 0000
    0050: 30 30 30 30 0000

    many people say it can be due to memory issues?

    also ive managed to run sim city 4 which is dx7 and needs direct 3d.. but with nicer games like max payne 2 it just crashes maybe even in the intro movie.

    also ive run the dxdiag dx7 test with the stupid cube spinning around and have had a crash after 3 seconds.. but sometimes it runs all the way through and doesnt crash.

    i have a gigabyte dual channel and 2x fresh 512 mb memsticks waiting for the processor.. so ram wont be the issue.

    its just annoying there are no decent freeware memtest tools out there.. they cant find errors on every type of ram.

    and doesnt find anything on mine, even when running all night long.

    thanks for your efforts kirock, but i also hope there will b more people posting to this fred. as there so many similar freds lungering around in here. what a waste..

    edit: ah yes and the fastwrite is off. i wont change any voltage though.. also my voltage on the 12V rail is at 12.6V which is a good value i think. although i dont have no experience with electronics at all.

    and another thing: its an offline computer. has no antivirus/firewall etc. at all. freshly set up. no chance of spyware/viri or similar.
  16. renehasp

    renehasp TS Rookie

    try changeing the video card.

    What if it is the memory on the video card. Is there any way a friend can lend you another 3d video card?

    I had a problem like this like a year ago. I bought a no name nvidea card and nothing but problems and bluescreens I got fed up and returned it to compusa and and bought a better one from pricewatch and bamb it's been running fine since.
  17. osram

    osram TS Rookie Posts: 47

    well i will try to install my old radeon 9000 pro which has a broken off transistor but strangely worked anyway at least for a while in the old setup..

    im really getting annoyed as id rly like to try "spellforce".. the intro looks very cool, but as soon as it should enter the game it will crash, as usual.

    i will read on in the other topics: i wonder why there is no sticky about this problem becos there are so many different threads about the same problem. everyone should answer to the thread i am writing/asking in.. seriously.

    i have to say once again: i hate you all. ^^
  18. osram

    osram TS Rookie Posts: 47

    righty... right. 0.X

    this is scaring the **** out of me.

    when i install my radeon 9000 pro it hangs up in the bios screen with a message that the cpu frequencies are improperly set once again.

    oh boy. wtf 12x100/33 should be correct for a 1200+? or is it only 10x100? before it didnt give me that alert message. what a mess.. thats the normal bios setting, it should be correct.

    i wont run my machine any longer until i get my cpu.

    *BUMP* !!!!

  19. osram

    osram TS Rookie Posts: 47

    well i am really getting annoyed.

    ive seen that the public open board list with the numbers 1. to 130. on the start of the line etc. doesnt even have this thread listed. not even on the second page.

    great.. i wonder why.

    some help would still be appreciated; as the only place to find a solution is apparently this techspot.com board. *cries*

  20. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    if no one replies, they're either not interested or don't know the answer or your question is too vague (or a combination of the three.)
  21. osram

    osram TS Rookie Posts: 47

    well you probably wouldnt be talking like that if you had the same problem ;)
  22. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    um, no. I fully understand this is a voluntary forum. No one here is required to help anyone. We strictly help when we can. No one is paid to help.
  23. osram

    osram TS Rookie Posts: 47


    well i will transfer my questions to the "hardware" section as apparently no one in the whole wide world knows an answer to the questions posed in this, and many other threads.

    i got my processor yesterday when i got back from work.

    now i have new questions. sorry for pushing this thread and bumping etc.

    but it surely wasnt due to plain boredom. bye.

    i also wish good luck to trancecan and the others who've been writing in this thread.
    enjoy this endless problem without any answers.
  24. kirock

    kirock TS Rookie Posts: 1,221

    I have a 1200 still running and occasionally (3 times in 4 years) it hangs with that BIOS message as well. All I have to do is confirm the clock frequency and she boots fine. I just assume it's a minor glitch in the oscillator as it starts.

    In your case since you can't run the 6600GT, I'd say you are in need of a new CPU and mobo. Trying to save the 1200 seems useless, I think your crashing probs are related to the 1200XP, it just can't run fast enough for the 6600GT GPU (games really start transferring data between the CPU/RAM/GPU).

    You said you way OCed your 2600 and killed it, so you know the procedure. Why don't you try to get the 1200 up to say 1400 or 1500, see if that helps. If you kill it, so what it's a 1200! Might as well amuse yourself while you wait for your new CPU/mobo to arrive.

    Have you tried Prime95?? It's a probgram to find huge prime numbers, but is used by OCers to define a stable OC setting. If your system can't run Prime95 for 20 minutes, then you've got probs with heating, or RAM, or clock settings etc. Try that.

  25. osram

    osram TS Rookie Posts: 47

    well thanks for your reply. i dont need prime 95 atm to verify if my system is able to be overclocked or not ;)

    before going to work today my amd 2700+ reached 83 degrees celsius with a closed case.

    it had nothing to do with the 1200+ or the graphicscard. i am pretty sure it was the ram/mobo. i wasnt very nice to my hobo mobo mojo jojo recently o.O

    this thread is kinda continued somewhere in the cpu/mobo etc. section.. sounds like a tv-soap to me. :vomit:

    enjoy. ^^ next episode: osram is havin a sexual relationship with his handicapped keyboard, f0cks the mother of his best friend.. and quits the relationship with his ex-gf because of her annoying cocaine addiction. 0_x
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...