1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

C-Media Sound Driver Conflict

By risingTide ยท 76 replies
Jan 17, 2008
  1. Greetings.

    Summary: After a recent fresh install of Windows XP, the sound on my computer is no longer working.

    Details: As you can see below my motherboard is a bit old, but still fine for my current purposes. I've been using it for about 6 years with no problems. I recently had to reinstall XP because of a hard drive upgrade. I installed all the drivers that came with the motherboard on CD and also installed all the updates from SOYO's site. At one point during my driver installation the sound WAS working, but at some point it stopped (unfortunately I do not know exactly when). When I try to install the C-Media Driver that is from Soyo's site (listed under the drivers for my specific motherboard) I receive this error: "Our audio chip provides mult-speaker surround and realistic sound effects. Due to the fact that your computer is not equipped with our audio chip, you can not avail yourself of these advanced features. For more information, please contact your computer dealer - C-Media Electronic Inc.

    I have tried installing the latest drivers from C-Media's site (the CMI8738_WDM_0639XP.zip package), but receive a message during install that says "Waiting for audio driver......" that hangs indefintely until I click on Exit, which then restarts my computer, but still without sound. The PCI Audio Applications software installs successfully on reboot, but when I try to run it I receive: "Can not execute all the components of AudioRack. Please check program files and registry settings or just reinstall AudioRack."

    There also seems to be an opensource driver available (CMIDriver-1.1.4-bin-x86.zip). However, when I try to install that I receive this error "Driver Installer (CMI 8738/8768) has encountered a problem and needs to close. We are sorry for the inconvenience." (complete with the handy Send Error Report business to Microsoft).

    Thoughts: It seems to me there is some type of driver conflict going on somewhere but I do not know what else to do or try. There is a more detailed list of my system below. I'm also having random IE7 problems where it freezes and says it has to close and send Microsoft the famous error report, but I believe that my be unrelated (??) However, I am also receiving various BSODs at random times too, not always the same one either. I believe this is probably related.

    Anyway, if anyone has any ideas on what I could try next I would truly appreciate it. I've spent a good bit of time at this myself but have come up quite dry. I have searched a quite a few forums and FAQs for all the associated software vendors involved but have found nothing there either. If there is any more specific information that is needed about my system, I will be more than happy to post it for you!

    System Details:
    Motherboard - SY-K7V Dragon+
    Chipset - VIA KT266A / 8233 CE Version
    Integrated Sound - CMI 8738 (No add-on sound card)
    Windows XP SP2 (with all updates including IE7)

    Sound Related Programs - PCI Audio Applications
    Sound, video and game controllers -
    - Audio Codecs
    - Legacy Audio Drivers
    - Legacy Video Capture Devices
    - Media Control Devices
    - Video Codecs

    More Details about what I have tried/checked:

    - There are no conflicts in device manager.
    - The sound is enabled in the BIOS.
    - When I open Volume Control I receive this message:
    "There are no active mixer devices available. To install mixer devices, go to Control Panel, click Printers and Other Hardware, and then click Add Hardware. This program will now close."
    - Windows Audio Entry is set to Automatic and started.
    - The speaker volume option under Sounds and Audio Devices is actually grayed out completely (as is the Advanced button).
    - There are no default devices for Sound Playback, Sound Recording, or MIDI music playback.
    - Both my TDK CDRW241040B CD-Burner and my TOSHIBA DVD-ROM SD-M1612 are both enabled and at full volume.
    - An Audio Codecs entry is under Hardware, but no "Audio Controller"
    - There are 11 Audio Codecs listed with the Microsoft PCM Converter currently at 11th (and imaadp32.acm 1st).

    Many thanks for even reading this far!
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

  3. risingTide

    risingTide TS Rookie Topic Starter Posts: 101


    I wasn't able to check this post until right now and apparently its been more than 5 hours. Could you open it back up again??

    I'll check every hour until then!

    Thanks so much for your help!
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

  5. risingTide

    risingTide TS Rookie Topic Starter Posts: 101

    Got it! Thanks so much!


    I installed it without complication...it asked for a restart which I did. Upon restart, I opened up the "Multi-Channel Audio Demo" from the Start Menu. The application opens fine but whenever I try to play a sound from it I receive this popup error:

    Failed to open waveform output device.

    There's a prompt to click OK, which clears the error but I get it every time I try to play a sound in the demo.

    Also note that when I try to run Audiorack itself I get a popup error that says:

    Can not execute all the components of AudioRack.
    Please check program files and registry settings or just reinstall AudioRack.

    Any ideas?

    Thanks for your time, kimsland!
  6. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Hi risingTide,

    The "Multi-Channel Audio Demo" I'm not aware of, it's a specific part of the Audio Rack software, that may not be required.

    I'm interested in if sound is working (normally) or not.

    Can not execute all the components of AudioRack
    This may be due to having the old software or drivers loaded with the new (posted) software/drivers

    I'd suggest un-installing Audio Rack
    Then un-installing any other audio/driver software package (Not media player so forth) just any other audio driver package previously installed.
    Then un-install any audio drivers still left in Device Manager - you may also need to click on View, then Show Hidden Devices, in Device Manager too, to fully remove all audio drivers.


    And follow the Audio Rack software install again. (I am also aware that Windows may try to re-install the audio drivers automatically upon restart (if possible cancel this) otherwise continue.
  7. risingTide

    risingTide TS Rookie Topic Starter Posts: 101

    Greetings kimsland, and thanks for your help.

    I've uninstalled Audio Rack and there don't seem to be any other previously installed driver packages that can be "uninstalled". Now, I'm at the point where I'm trying to uninstall any drivers still left in Device Manager. I have enabled the viewing of hidden devices and have enclosed a screenshot of my device manager at that point. I don't know exactly what to uninstall and, more fearfully, I don't want to uninstall too much!


    Any help you could give on exactly what to uninstall would be much appreciated!
  8. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Legacy Audio Drivers
    Media Control Devices

    You may also want to check Device Manager in Safe mode

    Also Start -> Run -> Services.msc
    Scroll down to "Windows Audio" and confirm "automatic" startup

    After a Restart (already done by going to safe mode)

    Re-Install Audio Rack
  9. risingTide

    risingTide TS Rookie Topic Starter Posts: 101

    Well, I uninstalled AudioRack and removed the Legacy Audio Drivers and Media Control Devices (there were none under the former, only under the latter) including one Media Control Device that was hidden. I also checked things out in safe mode, but nothing extra was there. Windows Audio was already set to Automatic as well.

    So I rebooted and as I was reinstalling AudioRack I received a nice BSOD. I rebooted again and it looks like only "half" of the install was complete because some components are there but it won't let me uninstall it, giving me this error when I try:

    - The log file 'C:\Program Files\PCI Audio Applications\Uninst.isu' is not valid or the data has been corrupted. Uninstallation will not continue. -

    So now I'm in a tight spot. I've enclosed the minidump of the BSOD in case that helps.

    View attachment 27963

    What should I do next? Should I try using Microsoft's "Windows Install Clean-up" which I happen to have downloaded already? Or should I try to re-install over top of the bad version? Or does the minidump give any other clues that I should note? (I do have Microsoft's debugger installed as well.)

    Thanks for helping me thus far!!
  10. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Damn power went off here (then on then off... so I turned off for awhile!)

    Probably caused by : afd.sys
    part of the TCP/IP stack in Microsoft Windows (Internet basically)

    Just run CCleaner
  11. risingTide

    risingTide TS Rookie Topic Starter Posts: 101

    I ran the Cleaner and Registry features on CCleaner and that worked fine. When I tried to run the uninstaller on the PCI Audio Applications I received the same error as before. I noticed there is also an option that says "Delete Entry" under that uninstaller tool...is that what I should do instead?
  12. Eddy Rassy

    Eddy Rassy TS Rookie Posts: 69

    I recall 2 years back when I built a PC with Soyo board, I had similar problems (not exactly the same as yours) and my audio rack would not work. Then I found that the Vinyl AC97 codec combo driver was causing it. I then downloaded a new driver ( from VIA and the problem went away.
    Is Vinyl AC97 listed in the device manager under sound? if it is then get the latest driver from VIA and try it.
    Good Luck
  13. risingTide

    risingTide TS Rookie Topic Starter Posts: 101


    Well, I just reinstalled AudioRack over the half-installed version since I couldn't uninstall it correctly. The install was successful but I still have the same results as last time when I try to use it:

    What should I try next?

    (Eddy Rassy, I actually don't have the Vinyl AC97 codec driver at all...but thanks for the input!)
  14. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Another post today had a really horrible issue, that we worked on for days.
    Eventually he tried this
    And it worked perfectly.

    I'm also starting to think we need to find the Audio Rack software again (from somewhere else) and try again. Please do another search for this (sorry I must go for awhile, have have a meeting I must attend.
  15. risingTide

    risingTide TS Rookie Topic Starter Posts: 101


    I checked out that thread you posted and I was very hopeful. I changed the permissions of the registry value with this description:

    But alas, still nothing. I tried to reinstall the C-Media driver on the CD that came with my mobo after that, and the updated one on soyo's site, and an older one on Soyo's site but still nothing.

    I then cleared the DriverCache/i386 folder as well and tried to reinstall but still nothing.

    I also found the AudioRack on the CD that came with my mobo and another version of it on Soyo's site, but although it installs fine...it still doesn't work.
    It also gives me a popup each time saying that

    But like I said, it still installs seemingly fine.

    I also still have nothing under Legacy Audio Drivers and only one driver under Media Control Devices (mciqtz32.dll).

    I'm at a real loss here...any other ideas?

    Thanks so much for your patience!!
  16. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Here's something that I would try (at this stage)

    Go to Users in Control Panel, create a new user with Administor privlidges, call it Audio (or what ever)

    Once created Log out, then log on to the new user account
    After a few moments of all the normal windows adjustments (ie cancel, cancel, cancel of all the popups.

    setup your sound again, with the best driver you have.

    Once setup, try sound

    If it works, log back on to your original account and check there.

    Try that
  17. turbo1

    turbo1 TS Maniac Posts: 353


    this driver CMI8738_WDM_0639XP is for integrated sound as well as for PCI sound cards.

    try re-installing the driver you downloaded from C-media.double click the setup,but when you're in the installation wizard,before you proceed.click the radio button that says "8738 in motherboard".

    the dialog box looks like this ,the one in the link is setting up the PCI sound card,dont do that.click "8738 in the motherboard" instead.then on the check box,the default is Line-in and rear speaker output share the same jack.dont put check on the "Disable MIDI port (device)" as well as the "Disable Game port (device)"...

    then click install.
  18. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

  19. risingTide

    risingTide TS Rookie Topic Starter Posts: 101


    Well, I tried creating a new Audio admin account and installing the drivers under that account. However, I receive the same error message noted in my first post above when I do that. Namely,

    This is also the problem that I have when trying to implement Turbo1's approach as well. The above message comes up before ANY OTHER prompts or anything and stops right there. It appears immediately after I click on the Setup.exe. Therefore I never get to the screen shot that Turbo1 posted.

    HOWEVER, I tried downloading the drivers from the most recent link that kimsland posted above and I have gotten a bit further. When I click on the setup.exe from that download I actually get the screenshot that turbo1 shows above! This is the first time I've seen this screen. I've selected the options as turbo1 has indicated above and the install begins. However, this is what I receive:

    At this point it hangs indefinitely. Here is a screenshot: View attachment 28096 . Eventually I just click Exit. It asks me if I want to restart...but when I do, I still have no sound; nothing has changed.

    Any ideas? Thanks so much!!

    Note: My System Specs are posted in my first post, but I've also posted them in my profile so that they are now more readily available.
  20. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    You know we keep thinking driver (and possibly settings) but I'm starting to think hardware. Maybe the audio card just died. It would make more sense, as to why the driver does not find the card and install properly.
    Glad to see the system specs by the way.
  21. risingTide

    risingTide TS Rookie Topic Starter Posts: 101

    So how do I rule that out (or verify it)?

    I would think so too actually, except for that fact that upon my fresh XP installation (when all this happened) the sound WAS working and then as I installed more drivers and other things it stopped at some point (although I unfortunately don't know when). Plus I still get random BSODs, some of which seem to have to do with a device driver conflict I believe. And I wasn't getting these before the sound stopped working.
  22. risingTide

    risingTide TS Rookie Topic Starter Posts: 101

  23. turbo1

    turbo1 TS Maniac Posts: 353

    one thing i know with the error message is about the onboard sound chip.
    if your onboard sound's driver is CMI8738,then your sound chipset should be:

    CMI8738/6Ch or 4Ch C-Media Technology.

    please download Everest Free Edition HERE,install & run the program.when done,navigate to > Multimedia > PCI/Pnp Audio.

    lets see what sound chip you have with the string value.

    likewise go to device manager,navigate to >Sound,video and game controller.
    find the onboard sound & that should match the value with the result from everest.

    right click the onboard sound > properties.
    on the details tab,you will see the Device instance ID.
    the string value would be like PCI\VEN_xxxxx so & so.

    post it back here as well as the result from everest (sound ).
    providing those informations,we will see the real sound chipset that you have.
  24. risingTide

    risingTide TS Rookie Topic Starter Posts: 101

    Here's a curious thing. Everest works fine except that it brings up a blank screen on BOTH PCI/Pnp Audio and Windows Audio. See View attachment 28115 .

    Also, I don't seem to have an onboard sound listed under Sound,video and game controllers in Device Manager (and this is with the hidden devices being shown). I have a screenshot listed above on posting #7 that shows it.

    So what does that mean?

    My motherboard manual lists this as the onboard sound chip for what it's worth: CMI8738/6Ch C-Media Technology.
  25. risingTide

    risingTide TS Rookie Topic Starter Posts: 101

    Also, I have triple-checked, and my onboard sound is definitely enabled in my BIOS.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...