Call of Duty 2: DirectX error.

By Malganis ยท 7 replies
Dec 7, 2006
  1. I installed CoD2 patch 1.3, I installed the latest ForceWare drivers; verison 93.71, and the latest DirectX 9.0c; the October version.

    But even when I only change the resolution of the game to 1600x1200, it crashes and says: DirectX Error DirectX has encountered an unrecoverable error. Please check DirectX Help document for possible details.

    And it directs me to this file: file:///C:/Games/Call%20of%20Duty%202/Docs/TechHelp/Tech%20Help/Information/DirectX.htm. I did everything that's on that website, and it still doesn't work and it crashes when I only change my resolution, and nothing else, to 1600x1200.

    Who has had the same problem, and who has a fix for it?

    Counter-Strike: Source does work with everything on full @ 1600x1200.
  2. Malganis

    Malganis TS Rookie Topic Starter Posts: 16

    Doesn't anybody know? :(

    I just found out it's only doing this with the Singleplayer version of CoD2, I can play Multiplayer with everything high just fine.
  3. TimeParadoX

    TimeParadoX TS Rookie Posts: 2,273

    Maybe you should reinstall the drivers or go back to a previous driver of your videocard ( Not all updates are good )

    Can you lower the resolution or Qaulity of the game?

    Hope I helped :)
  4. jamesk

    jamesk TS Rookie

    log off xfire
  5. TimeParadoX

    TimeParadoX TS Rookie Posts: 2,273

    What does Xfire have to do with it? :D
  6. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    What videocard? Also, how much VRAM? 128, 256 or 512MB?
  7. jamesk

    jamesk TS Rookie

    Xfire has alot to do with it there is a bug which will not let you change your game settings while logged onto xfire, just try it, it hsa fixed it for most people
  8. steve_sarge

    steve_sarge TS Rookie

    I had issues with 3D Games a little while ago due to direct x issues. I had all the latest 9.0c versions e.t.c. e.t.c. Would you believe running Net Meeting solved my issue. Please don't ask me to explain why, I stumbled across it on the net and thought it was strange too. It didn't hurt anything in my system AND it got me gaming again. It is in Program Files under NET MEETING, the "conf" file is the one to double click. I sincerely hope this strange work around helps

    Regards Steve
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...