Can´t Install Fedora 4 on MSI 915P Combo Fr

By Johnny36 · 27 replies
Jul 21, 2005
  1. Hello:

    I've just upgraded to MSI915P Combo and Intel P4 P550 but I can´t install linux on this machine, the kernel hungs up and the computer stops responding. On the other hand, Windows XP runs OK. Does any one knows if there is an incompatibility problem with this motherboard/chipset and Linux? I´m trying Fedora Core 4.

    Here is the screen text I was able to see:

    kernel panic - not syncing: Attempted to kill init!
    The computer stops responding at this point.

    Since I´m new in linux, I really don´t understand these messages.
    Any help is appreciated.


    MSI 915P Combo Fr (with Intel 915)
    Pentium 4 550 3.4 GHz
    ATI Radeon X600 128 MB
    HDD SATA 160 GB Samsung
    HDD IDE 120 GB Samsung
    HDD IDE 8 GB Samsung
    512 MB DDR2
    CD Recorder SW 252B Samsung
    DVD Player SD 612S Samsung
    Latest BIOS version (1.6)
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    As the Fedora installation guide says, try running the install with acpi=off ("linux acpi=off"). You can try with noprobe and noapic switches too.
  3. Johnny36

    Johnny36 TS Rookie Topic Starter Posts: 17

    I´ve tryied that already and it didn´t work, the behaviour is the same.

  4. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Oh, you might have to turn ACPI off in the BIOS for the duration of the install. (If you can turn it off, that is.)
  5. Johnny36

    Johnny36 TS Rookie Topic Starter Posts: 17

    I turned acpi off in the bios but it didn´t work also. Do you think it may be something related with the bios itself? I downloaded the latest version for this motheboard.

  6. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Its more likely to be a bug with the kernel and your mobo chipset. What happens if you try another Linux or Fedora Core 3?
  7. Johnny36

    Johnny36 TS Rookie Topic Starter Posts: 17

    I´ve started whith Fedora 3 in the first place and it gave the error I described, so I downloaded Fedora 4 to give a try. I also tried a Portuguese version of Linux "Caixa Magica" ( and the result is the same.
    The chip I have is Intel 915P, the website of Intel gives Linux drives for Intel 915G, but I didn´t find any information specific for 915P. Do you know if this chipset supports Linux?

  8. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Here's a weird fix:
  9. Johnny36

    Johnny36 TS Rookie Topic Starter Posts: 17

    Didn´t work either.
    I did as you said, and a second time also with acpi=off noprobe and noapic, turning off acpi in the BIOS.
    In the link you gave, someone says that this happens only in Fedora 4, not in Fedora 3. It is not my case, in my system it happens with all the Linux versions I tried.
    I will subscribe also in that forum and post this problem.

  10. tumi

    tumi TS Rookie

    Can't install Fedora core 4 on my intel SE7210TP1-e server

    Hi there,
    i am having the exact same problem and have tried all the above solutions without any luck.

    has anyone found a solution yet?

    South Africa
  11. Johnny36

    Johnny36 TS Rookie Topic Starter Posts: 17

    Graphics Card

    I suppose that my problem is incompatibility between the kernel and the graphics card. I have an ATI Radeon X600 and was able to install Suse 9.3 with the option at boot "pci=nosort text". I runned in text mode and downloaded drivers specific to Suse and the ATI card. I installed it and got graphics mode.
    After that, I tried the distro Debian sarge 3.1 and no option at boot was needed, but didn´t have graphics mode either. I had to reconfigure Xfree with the drive "vesa" for the card.
    Now I have Linux running.
    What is your harware configuration?
  12. tumi

    tumi TS Rookie

    mediacheck works to install core 4

    hi there, i tried mediacheck then linux mediacheck

    My intel server is now installing

    Thank you
  13. cottonsweet99

    cottonsweet99 TS Rookie

    Dear Mictlantecuhtli:

    I tried the mediacheck and linux mediacheck. I have finished Fedora core 4 installation.

    It was very helpful for me. Thank you for your information. :blush:
  14. Johnny36

    Johnny36 TS Rookie Topic Starter Posts: 17

    Problem Solved

    I also can run the installation for Fedora 4 typing "mediacheck" at boot first, and second : "linux mediacheck pci=nosort text". Without "pci=nosort text" I still get a kernel panic.
  15. Despotic

    Despotic TS Rookie

    Fedora and the Radeon X600

    Hey folks,
    I'm using a Radeon X600 mobile and trying to install Fedora 3. I'm a little reluctant to d/l the Fedora 4 right at the moment.
    I'm having the same problem as the other people here seem to be. As far as I can tell, the Radeon X600 isn't compatible with Fedora (or older versions of Red Hat).
    I'm currently running RedHat 7.2 and the only way to get X to work is to manually change the video driver to the VESA driver as someone else here has pointed out. I was hoping that Fedora would be a little friendlier, however upon beginning the graphical install the screen goes black. It seems to me that the install is still running, there just isn't any display. I've tried the text install with the same results.
    the MediaCheck doesn't help me in this situation and I don't think I want to try any other distributions just yet as I'm still gaining familiarity and I started with RedHat.
    If anyone could shed some light, I'd be most appreciative.
  16. Johnny36

    Johnny36 TS Rookie Topic Starter Posts: 17

    Did you try the option at boot "pci=nosort text"? For Fedora 4 do both, that is, type something nonsense at boot first and after the error message type "linux mediacheck pci=nosort text". If your trying Fedora 3 maybe the "mediacheck" option is not necessary.
    I don't have fedora installed, I have Suse 9.3 but I´m still using the "vesa" driver. However, ATI has a program that produces distribution dependent drivers. Check in their web site.

  17. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Just to clarify, "pci=nosort" is one parameter (tells kernel not to sort PCI devices during their detection), and "text" is another parameter (starts installation in sort of textmode). I say sort of, because it's not a true 80x25 screenmode, more like a VGA framebuffer. One option would be to try "linux text nofb", to start the installation in real textmode.
  18. Johnny36

    Johnny36 TS Rookie Topic Starter Posts: 17

    Yes, I knew they were two different commands. What I didn´t know was the meaning of "pci=nosort". I have a Radeon X600 PCIE and the only way I could run the installation for several linux distributions was with this option at boot. Otherwise I would get a kernel panic and a system freeze.

  19. Despotic

    Despotic TS Rookie

    Well I tried the "linux mediacheck pci=nosort text". I was unable to run a straight "linux mediacheck" then return to the boot option, it went to my terrible blank black screen. upon rebooting and trying the pci=nosort, again the relentless black screen. I tried the text option; again the black screen. If I'm running a text install should there not be a standard default display output?
    Is there a way to get a compatible driver and tell the installer to use it instead of it's default?
    I've given up on linux a number of times in the past because of these kinds of problems and I don't want it to happen again so if I were to switch distributions, is there one that could be recommended that will work with the X600?

    Thanks guys
  20. fabiocsilva

    fabiocsilva TS Rookie

    The pci=nosort argument does not finish completely the problem. The next step is to load the sata driver ... But I don't have the driver and I don't found the driver ... HELP !!! The hard disk isn't detected ... :mad:
  21. Johnny36

    Johnny36 TS Rookie Topic Starter Posts: 17


    I have Suse 9.3 installed in my system and works OK with the vesa driver. I have a Radeon X600 PCIE.

  22. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    I installed FC4 to a laptop with Radeon X300 chipset, had to use "linux nofb" to make the installer work in textmode.
  23. fabiocsilva

    fabiocsilva TS Rookie

    And the SATA Hard Disk problem ?
  24. fabiocsilva

    fabiocsilva TS Rookie

  25. simke

    simke TS Rookie

    Can't install Fedora 4 on Twinhead 12DL

    G'day. Bought a Twinhead 12DL notebook recently. Was trying to install Fedora 4 on it but it didn't work. It hung at kernel_thread_helper+0x5/0x14. I tried so many setup options but it didn't work either, including linux acpi=off, linux nofb, linux text, mediacheck then linux mediacheck or linux mediacheck pci=nosort text & etc.
    My notebook specs are as follow:
    Intel Centrino 1.73Ghz
    512MB DDR Ram
    60GB hardisk
    Intel(R) 915GM/GMS, 910GML Express chepset family
    Combo DVD / CDRW drive

    By the way, I had no problem installing Fedora 2 on the notebook, everything went smoothly. Does anyone know why not with FC 4?
    Thank you.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...