Can anyone help me troubleshoot an external enclosure for an old laptop drive?

By jbarback ยท 4 replies
Aug 3, 2005
  1. Hi,
    My old compaq presario's motherboard died last year, and I had the tech install the 30 gig hard drive in a generic enclosure. Don't know what these usually look like, but mine is a palm-sized aluminum box with one light (green/red). It has a small trapezoidal socket which hooks up to a cable with two separate USB plugs. I'm assuming one is for power and the other is for data?

    The drive worked great for about six months, then stopped working. On two different PCs I get the same situation: the computer recognizes the drive when I plug it in, I get a green light on the drive, but when I try to open the drive I get an I/O device error. The drive and both PCs are XP formatted. I recently popped the enclosure open, firmly seated the drive on its pins, and tried again, but no luck.

    I've been slacking on dealing with this for a while since it's only 30 gigs. But it happens to be just enough extra space for me to comfortably install XP and linux on partitions in my new laptop's drive. If I can get this done myself I'd be very happy, but it's not worth the $40 my local tech wants to charge me just to look at it.

    Thanks for your help.
  2. giyad

    giyad TS Enthusiast Posts: 59


    Are you able to format the drive? You may just have a damaged partition and need to format it. Go right click on My Computer->Manage->Storage->Disk Management. Does the drive show up in there? If it does, does it say inactive, if it does activate it. If it doesn't, does it say unallocated?
  3. jbarback

    jbarback TS Rookie Topic Starter

    thanks giyad-- no luck

    Thanks for your suggestion. The drive appears as Healthy (Active) in Computer Maganement. It is unpartitioned. The only difference with my C: drive seems to be that while both are listed as type-Basic, the C: drive has NTFS file format. Like the Linux partitions on my hard drive, the USB drive does not have a file system listed. I'm assuming that means they are all FAT32? In addition, the USB drive appears as 100% free, which I know it is not.

    Thanks again for your suggestion. I'm not sure if it helps diagnose the problem, but my system slows to a crawl when the drive is plugged in, and immediately resumes normal speed as soon as I unplug the drive.
  4. Trax_1

    Trax_1 TS Rookie

    I am assuming that if you have been into the device manager you have tried all of the driver options, roll back, uninstall, etc. Sometimes I am noticing that flashing your ROM works too. If you've installed SP2 recently sometimes that messes with the enclosures and often they will not work with it. I don't know that any of the options will help but that is about all I can think of. Good Luck.
  5. jbarback

    jbarback TS Rookie Topic Starter

    Thanks Trax

    Thanks for your suggestion.
    I ended up taking the drive to the guys who installed it in the enclosure. They checked it out and told me the drive was dead, I guess its time had come. Seems weird to me because it wasn't particularly old and I was taking good care of it, so I guess I'll blame the crappy generic enclosure they sold me. Well, I'll know better next time.

    Thanks for your help.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...