Cannot access internet, can receive email, use FTP, can ping out

By rodester ยท 12 replies
Mar 27, 2006
  1. Hello from newbie to this forum.
    After searching threads, I could not find solution for this particular and perplexing problem: I have a small network as follows:
    1 Winxp pc
    1 Win2kpro pc
    1 G4 Mac
    All connected through SMC Barricade router, which is connected to adsl modem (Sprint).
    The problem is that the Win 2000 pc has lost ability to connect to internet through any browser(IE6, FF, Moz, Opera)
    I can send and receive email, use my ftp program to connect to remote servers and upload/download files, and can move files from my Mac to PC (via Dave client software.)
    Here is what I have tried so far:
    powered off everything, then powered up modem, router, pc
    bypassed router, hooked pc directly to modem
    disabled firewalls
    uninstalled/reinstalled tcp/ip
    uninstalled/reinstalled nic
    replaced/nic with known good one
    replaced cat5 cable
    I can access internet with the winxp computer (using it now)
    I can ping from win 2000 computer to this computer and mac,
    can ping router and modem from win 2000 pc
    can ping loopback and ip address from win 2000 pc
    ipconfig shows that I am being assigned an address, all pcs on net have same subnet mask address
    I cannot ping the win2000 pc from the mac or the winxp machine
    I have also run WinsockFix.exe
    I have deep scanned with Norton for viruses
    I have run Adaware and MS spyware
    Still no joy :confused:
    I would appreciate any suggestions!
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415

    May sound daft, but have you ran the Internet connection wizard, sometimes it just fixes things.
  3. rodester

    rodester TS Rookie Topic Starter

    Yes, i tried that one too.
  4. LNCPapa

    LNCPapa TS Special Forces Posts: 4,274   +461

    Does DNS look correct on the Win2k machine? Can you ping by hostname from the Win2k machine or only by IP?
  5. rodester

    rodester TS Rookie Topic Starter

    Connection is configured to obtain DNS automatically.
    Here is my ipconfig result:
    Host Name: my computer
    primary DNS suffix:
    Node type: Broadcast
    IP Routing enabled: no
    WINS Proxy enabled: no
    Ethernet adapter local area connection 2:
    Connection specific DNS suffix:
    Description: Realtek TRL8139(A) PCI fast ethernet
    Phisical Address: 00-20-ED-6F-F4-19
    Autoconfig enabled: yes
    IP address:
    Subnet mask:
    Default Gateway:
    DHCP Servers:
    Lease Obtained : tuesday march 28. 2006
    Expires : tuesday april 04, 2006

    I can ping either IP addresses or DNS addresses.

    I cannot ping the win2k computer from mac or winxp pc
  6. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    Just in case ,but did you remember that everyime you run the Wizard(Manually) it will change your Workgroup name to Default?
    Also I have had more stability in Workgroup lans by using Static ip addresses and turning off all auto setting/dns and DHCP on the router.
  7. rodester

    rodester TS Rookie Topic Starter

    Hi Liquidlen,
    I did not know about the workgroup name change, Win2k was originally named "WORKGROUP" and I changed it to MSHOME to match Winxp pc. Do you think the lack of internet access is related to problem with the network? I have connected the Win2k pc directly to modem with no joy.
    Another issue is this modem appears to have all of the features of a router, with a set up page allowing config of DHCP, DNS, etc.
    Another issue is I can ping everything BUT not the router! I can ping through it to the modem.
  8. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    It has been written that it is better to give your workgroup any name but the default which is what you have ,but that is just to help security. I mentioned it because it is a common mistake when going thru the different setup pages.

    If your modem has the same configuration setup as a router ; you may have too much going on especially if settings between the modem and the router conflict in directing traffic to your servers.
    I believe it would be best to use the modem/router (If that is really what it is) with a simple switch to distribute to the lan servers.
    I am not an expert on the hardware side of this stuff .
    Perhaps Nodsu will see this Thread, he is good with that stuff.
    As for settings You want to get the Microsoft Share settings correct. eg Workgroup names ,Shares on each machine, atleast 1 common username/password the same,etc. You make it sound as though the Mac and XP are working.Right?
    If the XP pro machine is working correctly , than run the network setup wizard from that machine on the win 2K machine.

    Also I noticed this from your listing;

    "...Autoconfig enabled: yes
    IP address:
    Subnet mask:
    Default Gateway:
    DHCP Servers: third position should be "3" ????Iam not sure "

    If there is a brand name for the modem/router, post it,or at least find a manual for online.
  9. rodester

    rodester TS Rookie Topic Starter

    The DHCP server addresses correspond thusly: = SMC router = Modem
    Modem is actually made by ZyXel, model 660 which I believe is proprietary for Sprint.(ISP)
    The thing throwing me off is that if I bypass the router and setup everything on win2k computer from scratch, still no internet. It is as though the tcp/ip connection to the browsers is broken (I know that is not necessarily a technical description)
  10. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    Since the other machines can work it might be that your ethernet card in the 2K is burnt.
    Other than swapping the card I am not sure about what's wrong.

    Also all 192.168.*.* are router/switch addresses (private)
    Thats why I though # was funny.
    I don't know that modem but I suspect it is acting like a router and I still believe the two of them may conflict when connected together.You are going to need to find a manual, or somebody around here that is familiar with it.Even though it is proprietary the manufacturer may post a manual.
    Sorry I can't be of more help.The win 2k is acting like it has ports closed since you are getting partial sevices.
  11. rodester

    rodester TS Rookie Topic Starter

    I agree with the idea that ports are closed. Is there a way to check that from cmd prompt?
  12. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    I think either XP pro Resource/2003 Sever Admin tools can , you will have to do some reading .
    You should check your firewall for sure (easier for opening and closing Ports), plus router settings can close ports .
  13. rodester

    rodester TS Rookie Topic Starter

    Hi Liquidlen and all,
    I solved the problem without actually finding it. I restored the registry from an earlier version of winsockfix, then reapplied the fix and voila! I now have connection. I did find an additional winsock entry in the registry which was apparently dropped by a trojan called Riler.E ( according to Norton's website. This is perplexing as I had the current version of NAV installed with all updates and it did not find this. I am attempting to remove it without damaging registry and connections.

    Thanks for the help!!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...