Cannot boot W-XP or go past black screen with msg Windows could not start because...

By gev53 ยท 6 replies
Mar 4, 2006
  1. I was cleaning my disk and the following error msg appeared:

    "Windows could not start because the following file is missing or corrupt: system32\DRIVERS\isapnp.sys
    You can attempt to repair this file by starting Windows Setup using the originalo Setup CD-ROM.
    Select 'r' at the first screen to start repair."

    I cannot get past the black screen with the above msg. I have tried rebooting with and without my XP CD in the drive but to no avail. The same msg appears.

    Seeking all advice...I am using my laptop to communicate...the issue is on my desktop machine.


  2. baddmr2

    baddmr2 TS Rookie Posts: 33

    try this

    Have you tried to get into bios yet and set your CD rom drive as the FIRST boot device? Then put in the xp cd and it should prompt you to boot from cd in the bios screen. If you havent done this yet try it.. Usually a bios screen will tell u what key to press to enter bios (setup)... common ones are delete, F8, ESC, etc.. If you cant get it to enter bios, try to search the web on another puter and find out how to enter bios on your brand of laptop.. What is the make and model #?? Maybe I can help find what key to press to get u into bios.

    Hope this helps

    Good luck!
  3. baddmr2

    baddmr2 TS Rookie Posts: 33

    ahhh..i now see u have 2 puters. and your desktop is the problem.. use your laptop to find out how to boot into bios and change "boot sequence" to cd rom drive first before hard drive.. Google it.. "how to enter bios on HP xxxxx pavillion desktop" or something like that.

  4. baddmr2

    baddmr2 TS Rookie Posts: 33

    if u get into bios and are still stuck...get back to me

    Ill try to walk u through it.. Ive had to do it many times before.. Hope we can get the puter to do a "repair install" off of the win xp cd. As long as the cd is the same one that was on the puter to begin with.

    Let me know..Ill try to help
  5. gev53

    gev53 TS Rookie Topic Starter

    I have been in my BIOS and the 1st boot device is my CDROM. I hear the CD spinning but it still does not boot up. I have two CD ROM drives (the other being a DVDROM). This is an older Gateway E4600 machine that has alot of my data stored on it.

    I do have another desk top machine here. Could I take the errored hard drive out...set as a slave...install in the other machine and then just update the isapnp.sys file then return the drive back to my Gateway box?
  6. gev53

    gev53 TS Rookie Topic Starter


    I took the hard drive out of my one XP Professional desktop machine, switched it to a SLAVE, installed into another of my desk top machines with XP Home.

    Then I renamed the isapnp.sys file in my "problemed" hard drive to isapnp.old and copied the isapnp.sys file from the "good" drive.

    I then (always shut down and unplug the power) the desktop, pulled the "problemed" hard drive, reset the jumper to MAIN from SLAVE, installed into the desktop machine I originally pulled it from and powered up.

    Everything works fine now.

    I appreciate the responses and help.
  7. baddmr2

    baddmr2 TS Rookie Posts: 33

    So you COULD boot past post (bios) screen then!?.... Oh.. I diddnt know that.. if i knew that it was a whole new ballgame.

    glad u fixed it
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...