Cannot delete file

By olefarte ยท 23 replies
Feb 1, 2004
  1. I've been downloading an update for Battlefield 1942, and after several aborted attempts, (download to slow), I've got an update icon for this file on my desk top that is only 18.4 kb.

    Problem is, I can't delete it and I don't want to see it there for the rest of my compters life. When I try to delete it I get a message,

    "Cannot delete Battlefield_1942_v1.6.19: It is being used by another person or program", "Close any programs that are using the file and try again".

    I've been having problems with this game, that's in another thread, and have uninstalled the whole game, and cleaned up any and all files relating to it, except this. For the life of me, I can't find out what program is supposedly using this. I've rebooted, still there, looked in Task Manager/Processes, (nothing evident, but I probably wouldn't recognize anything anyway, and looked at MSConfig/Startup and didn't see anything out of order.

    Anybody got any ideas? Thanks in advance.
  2. Jaguarist

    Jaguarist TS Rookie Posts: 30

    What happens if you right-click on the icon, choose Properties, and see the attributes? Is it read-only maybe??

    Another possible fix is to get to the icon file thru Windows Explorer, or whatever file manager you use. Navigate to your Desktop directory, and try to delete it thru that program....
  3. olefarte

    olefarte TechSpot Ambassador Topic Starter Posts: 1,345   +13

    Jaguarist, it say's it's an application. And I've already tried to delete it through Windows Explorer, and get the same "cannot delete" etc. message.

    Also run Ad-Aware and SpyBot, nothing shows up there.
  4. Jaguarist

    Jaguarist TS Rookie Posts: 30

    Ok, how about just booting into a command prompt, and doing a del from there? If all else fails, that should do it, I would think?
  5. olefarte

    olefarte TechSpot Ambassador Topic Starter Posts: 1,345   +13

    OK, I can boot into command prompt, but I don't know what to do after that, I'm not familiar with it at all. (See my avatar?)
  6. Jaguarist

    Jaguarist TS Rookie Posts: 30

    Ok, post back and tell me the EXACT path to the icon file... I don't know how you have your system set up, nor how many OS's you have installed... So, use Windows Explorer and navigate to the icon file.... If you have a fairly generic system setup, it should be something like C:\Documents and Settings\blah blah blah.... OK? I'll then tell you what to write at the command prompt.. You're almost there !! :)

    Oh yeah, include the exact name of the icon file also.
  7. olefarte

    olefarte TechSpot Ambassador Topic Starter Posts: 1,345   +13

    Ok it's C:\Documents and Settings\Owner\Desktop\battlefield_1942_patch_v1.6.19
    The icon file is battlefield_1942_patch_v1.6.19

    But, on the desktop icon, if I right click and "open", I get the black dos? box and another box over that that says,
    The NTVDM CPU has encountered an illegal instruction.
    CS:0548 IP:0118OP:2e 63 6f 20 Choose "Close" to terminate the application.
  8. Jaguarist

    Jaguarist TS Rookie Posts: 30

    OK. Boot into your command prompt. Then type this exactly

    del C:\DOCUME~1\Owner\Desktop\BATTLE*

    then press the Enter key. If all goes well, and it should, you will be returned to the command prompt.

    Boot back into your Windows, and it will be gone, gone, gone! :grinthumb
  9. olefarte

    olefarte TechSpot Ambassador Topic Starter Posts: 1,345   +13

    Success. Man that did the trick. It's gone.

    Man, can't thank you enough, anyway, thanks.
  10. Jaguarist

    Jaguarist TS Rookie Posts: 30

    Glad to have helped!! There are times when good 'ole basic DOS commands come in handy...

    Now, you could send me some Muscadine jelly, just as a thanks.. LOL Ark is the only place I know of to get any.. I sure do miss that stuff !!

    Alright, well, talk with you again, I'm sure. :)
  11. odno

    odno TS Rookie

    \Same problem also need help....please

    Hello . i have the same problem installed the game Galaxi (guess it is a dos game) and have uninstalled everything. I have an icon i can t gety rid of on my desktop and get the same message as the person above. I followed your instructions and copied the path in the command line .When i copy the path from "properties " on the icon this is what I get C:\Documents and Settings\olivier\Desktop\GALAXI.EXE but when I use "del C:\Documents and Settings\olivier\Desktop\GALAXI* I get an invalid path message. can you help

  12. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    The proper syntax is:
    del "C:\Documents and Settings\olivier\Desktop\GALAXI*"

    Note the location of the " AFTER del and at the end
  13. odno

    odno TS Rookie


    thank you that worked
  14. NewGuy1942

    NewGuy1942 TS Rookie

    hi i have the same problem like those people above can someone help me remove my icon? C:\Documents and Settings\Owner\Desktop\RollerCoastertyphoon2-dm Someone plz help me remove this.!
  15. alpharesearch

    alpharesearch TS Rookie

    exporer.exe has locked this file...

    exporer.exe has locked this file...

    you can try this out... just create a new text file on your desktop - but name it text.exe... you won't be able to delete this file.

    now do start->run cmd (enter) AND open the task manager; kill exporer.exe (dont close task manager)
    use alt + tab to switch between your windows
    use rm text.exe to delete this file in cmd window
    go back to task manager (applications tab and new task) to start exporer.exe

    i hope this helps...
  16. lyallc

    lyallc TS Rookie

    I have a similar problem and I followed your instructions in the command prompt in DOS but it did not delete anything. Instead it says that it cannot be deleted because it is being used by another program. Any other suggestions? Thanks.
  17. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Download the Pocket killbox programme from HERE. Read the instructions.

    That should get rid of them.

    Regards Howard :)
  18. lyallc

    lyallc TS Rookie

    I did as you suggested, and the Killbox came up with message of 'this file does not seem to exist". What am I doing wrong? Perhaps the path and filename ? the offending file is in my C:\Documents and settings\Chris\Desktop
  19. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    You don`t want to delete your desktop do you?

    What is the name of the file you want to delete?

    Regards Howard :)
  20. lyallc

    lyallc TS Rookie

    The file pathnames are:
    C:\Documents and Settings\Chris\Desktop\GravitytGemsSetup-dm
    C:\Documents and Settings\Chris\Desktop\DinerDashSetup-dm

  21. Bernie

    Bernie TS Rookie


    Download and try program called 'Force Delete'
  22. altheman

    altheman TS Rookie Posts: 425

    use unlocker. its free and a simple explorer extension
  23. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Download HijackThis from

    Run the programme and click on the config button. Click on the Misc tools button and then on the delete file on reboot button. Browse to the file you want to delete and click on open. HJT will ask you if you want to reboot. Click yes.

    Once your computer has rebooted, run HJT again and do the same for the other file you want to delete.

    Regards Howard :)
  24. runic12

    runic12 TS Rookie

    plz help

    the same for me and my thing is

    c:\documents and settings/nick/desktop/q3ad.exe

    Please help!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...