Cannot delete Flash9.ocx

By jcroot · 25 replies
Aug 17, 2006
  1. Hi Guys! This is my first post here, I found this website searching on google for a problem...

    I hope I can get some help here and I would like to help others too, since I'm a member of some forums.

    Here is my problem:

    I have Microsoft Windos XP Home Edition Service Pack 2

    I decided to reinstall my system using the "System Recovery" Disk that came with my computer, the company who make the covery disk is: SoftThinks

    So far so good, I reinstall my system using the recovery disk and this process gave me the option to create a backup of my hard drive, this will create a folder with all my data, settings and files to: C:\My Backup (my backup is a folder where all my data is)

    After I finish reinstalling my system I when to: C:\My Backup the first time I couldn't open it, I see the "Access denied error" I had fix this problem I boot my computer in safe mode and added the correct permissions to the backup folder, this fixed the problem, Now I'm able to access all my data, settings and files in this backup folder, now I want to remove or delete this folder but it not letting delete it, I delete all files and folder under: C:\My Backup acept for one file named: Flash9.ocx

    The path of the is: C:\My Backup/windows/system32/Macromed/Flash/Flash9.ocx

    At first I thought this folder have to do with my OS but not at all, I mean is just a backup folder that I want to delete. Every time I try to delete it manually I see this error message:

    Cannot delete: Flash9.ocx Access denied
    Please make sure the disk is not full or write protected and that the file is not currently in use.

    I search on and microsoft's website for this problem with not luck, I even went to, I called the company where I bought my computer and the coudn't help me.

    I used TuneUp to delete the file and not luck, I tried this software: to delete it but it didn't work. I tried to unistall my flash player thinking this could be the problem why is not letting me delete it, but it didn't work, I tried to delete it in safe mode but I see the same error message. I make sure all permission are right but it didn't work, I have full access control to this folder and I'm not able to delete it.

    I don't know what else can I do to delete this folder, I'm not planning to format my disk because I have too many files here. I hope somebody can help me.

    If there is another way to delete this folder I will thank any help.
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Try this.

    Download the Pocket Killbox programme from HERE.

    Extract it to wherever you want.

    Run the killbox.exe file. When it loads type the full path to the file you would like to delete in the field and check the delete file on reboot button. press the Delete File button (looks like a red circle with a white X). It will prompt you to reboot, select no until you have finished inputting the files you want to delete, only then allow it to reboot and hopefully your files will now be deleted.

    Enter this filepath into killbox.

    C:\My Backup/windows/system32/Macromed/Flash/Flash9.ocx

    Make sure you type the correct folder name.

    Once your system has rebooted, hopfully the folder should have been deleted.

    Regards Howard :wave: :wave:
  3. jcroot

    jcroot TS Rookie Topic Starter Posts: 56

    Ok thanks for you answer... Here is what I did:

    I download the Pocket Killbox

    I open the program and in the Full Path I entered this path:


    Why I had enter this path? Well when I tried to delete the file using TuneUp it deleted all files exept flash9.ocx and I guess the tuneup renamed the folder to zzzzzz

    The path before was:

    C:\My Backup\windows\system32\Macromed\Flash/flash9.ocx

    Now I realized that the path is:


    I had try to delete the file using Pocket KillBox and I select Standard Kill but it says: Cannot delete file, access denied.

    Now let me try to delete it selecting delete on rebot

    Thanks, I will come back to tell you more.
  4. jcroot

    jcroot TS Rookie Topic Starter Posts: 56

    Not Luck!

    I made sure I entered the right path but it didn't work, I tried to delete it in rebot option but not luck at all, it's says:

    Access Denied, could not delete file.

    any other idea?
  5. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

  6. jcroot

    jcroot TS Rookie Topic Starter Posts: 56

    It didn't work... I see the same error message, Error: Cannot delete flash9.ocx access denied
  7. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Take a look HERE and HERE.

    Regards Howard :)
  8. jcroot

    jcroot TS Rookie Topic Starter Posts: 56

    Thanks for your answer, I would like to try the following solution but there are some things that I don't understand.

    Here is what I don't understand, please see the bold text:

    First reboot the machine and make sure there are no Flash applications active. You can obtain msizap.exe from Microsoft, and Uninstfl.exe from Adobe, sorry not to specify their download locations, but if you search the site you should be able to find the pertinent information. Next, follow the following steps:

    I search on google to look for msizap.exe and I went to Microsoft's website but this is what I found:

    I don't know where can I download the msizap.exe file


    I guess I will find the Uninstfl.exe here:

    1. run the uninstall command:

    %windir%\system32\msiexec.exe /X{BB65C393-C76E-4F06-9B0C-2124AA8AF97B} /qb-

    (I have to enter the code in the chmd or comand DDos in windows?

    2. run msizap:
    msizap.exe T {BB65C393-C76E-4F06-9B0C-2124AA8AF97B}

    3. run uninstlfl.exe twice using the following switches:
    uninstfl.exe -q -u flash9.ocx
    uninstfl.exe -q flash9.ocx

    I don't understand this "run uninstlfl.exe twice using the following switches"

    can you please help me with this? I'm a little confuse.
  9. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Check this out HERE.

    I must say I have no experience with this tool, so I don`t know what will happen.

    In otherwords, I take no responsibility should anything go wrong.

    Regards Howard :)
  10. jcroot

    jcroot TS Rookie Topic Starter Posts: 56

    Hey, thanks for your help. I already installed the Windows Install Clean Up and I download the unistall.exe from adobe but like I said before I don't know what to do...

    It says:

    1. run the uninstall command:

    %windir%\system32\msiexec.exe /X{BB65C393-C76E-4F06-9B0C-2124AA8AF97B} /qb-

    But I don't know where to run the command, or maybe I have to click start/ run and enter the command.

    After that it says:

    2. run msizap:
    msizap.exe T {BB65C393-C76E-4F06-9B0C-2124AA8AF97B}

    that mean I have to open the windows clean up tool? or I have to run the command?

    Last think.

    3. run uninstlfl.exe twice using the following switches:
    uninstfl.exe -q -u flash9.ocx
    uninstfl.exe -q flash9.ocx

    What did he mean by running unistfl.exe twice using the following switches?

    Sorry about my stupid questions, but I really want to delete this file. I hope you or somebody else can give me a hand with this
  11. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    I`m sorry, but your guess is as good as mine on this one.

    Like I said, I have no experience with this at all, as I`ve never had the problem.

    I admit the instructions do seem a little vague.

    Regards Howard :(
  12. jcroot

    jcroot TS Rookie Topic Starter Posts: 56

    Don't worry Howard!

    Thank you very much for your help, I don't know what else to do, I really want to try this solution but I don't know how, probably somebody else can give me a hand with this.

    Thanks for everything, I will wait for any other reply.
  13. jcroot

    jcroot TS Rookie Topic Starter Posts: 56

    Hi Guys!

    After a lot work I finally got this f.... file deleted from my hard drive

    I decided to come back here to let you know how I deleted.

    I just move the file to a diferent location (I moved it to my documents) and delete from there, this changed the situation.
  14. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hey that`s great news.

    I wish I`d thought of that lol.

    Thanks for taking the time to let us know.

    Regards Howard :)
  15. jcroot

    jcroot TS Rookie Topic Starter Posts: 56


    Thank you very much howard... I will be arround here to help others.
  16. microse

    microse TS Rookie

    flash9.ocx delete solution

    I just did this on this (my son's) pc.
    Rename the flash9.ocx to flash9.ocx.txt, it will give you an error message.Click ignore.
    Then right-click this file and go to properties>security>advanced, then select and remove any/all Type of permission that has Deny listed. Close properties.
    Now delete the flash9.ocx.txt.
  17. jcroot

    jcroot TS Rookie Topic Starter Posts: 56

    Well I just moved the file to my documents and delete it from there.
  18. sunnyyen

    sunnyyen TS Rookie

    I had the same problem and found this site while searching for a solution. Seems like my situation is much more nasty than the one mentioned here. Here's what happened:

    I installed a new WinXP system on drive E: when I couldn't get in the one on drive C: after a virus scan (some infected system files deleted). Then I formatted drive C: and reinstall WinXP on it. Now that the system on drive E: in no longer needed, I just deleted all the directories generated while installing the system, such as Windows, Program Files, Documents and Settings and temp. Everything is fine except Flash9.ocx in windows\system32\macromed\flash\ directory. So I mannually deleted all the other files and directories, and moved the subdirectory flash to E:\

    Having found that I could move it, I tried to move it to other disks. I can do it, like I can move it to C:\ or My Documents, and the ones in the new locations can be deleted, but the one E:\flash\flash9.ocx still exits. If you cut & paste, same thing happens, E:\flash\flash9.ocx just doesn't disappear. I can even rename it, but just cannot change its "read only" attribute and cannot delete it, even after renaming it.
  19. platemoon

    platemoon TS Rookie

    Problem Fixed!!!

    I had the same problem that a lot of people are describing in this forum, I was not a member but since I will like to help others with this problem I became one. I have multiple disks with this file spread across them since I couldn’t delete them after the cut and paste. The problem is an easy one to fix after I got some light in my head from MICROME!!! The real problem here is that you need to delete the checkmark in the security tab that reads “Allow inheritable permission from parent to propagate to this object”. In the pop message select remove and then click ok. Now you can take out the read only attribute and delete the file. Be sure to remove all groups that have privileges to the file except Everyone if it doesn't have it add it.
  20. tthomas

    tthomas TS Rookie


    every time i go to play jewel quest on msn i played far about 10 min. then flash9.ocx come up and close my game up need help
  21. sunnyyen

    sunnyyen TS Rookie

    Thanks man, this is the correct solution. Mission accomplished:haha:
  22. GMT99

    GMT99 TS Rookie

    deleting flash9.ocx

    Hey People, stop screwing around with clean up utilities and simply move the file to another directory, then delete it! Worked for me!

    Some things in life seem so complicated, remember KISS.
  23. kritius

    kritius TS Guru Posts: 2,084

    Indeed, keep it simple, like reading the whole thread, realising this was done and worked and also that it was started 2 years ago.
  24. kficenc

    kficenc TS Rookie

    I had my motherboard on a Win XP Pro system die and HP wouldn't sell me a replacement, so I went out and bought a Vista 64 machine. Put the old HDD in an external USB enclosure and connected to the new machine. No problem assuming ownership of the files, but I can't delete FlashUtil10b.exe or Flash10b.ocx. Tried moving them to different directories on the same drive and still can't delete.

    Any other ideas? Don't want to have to reformat the drive just to get rid of these files!
  25. hellokitty[hk]

    hellokitty[hk] Hello, nice to meet you! Posts: 3,448   +145

    Try the file delete tool mentioned above, remember you MUST reboot when asked for it to work.

    What that means is to create a shortcut, right click and select properties, then add those lines in after the target in the target box. Look at the picture:

    In the highlighted box, is the normal target (in this case, "hl2.exe"), to add the switch, just add in the lines mentioned. The last part of the target should say (in your case) ""...uninstfl.exe" -q -u flash9.ocx" withought the outside set of quotes, and ""...uninstfl.exe" -q flash9.ocx", again withought the quotes.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...