Cannot see mouse cursor but it works invisibly?

By IBN ยท 8 replies
Sep 1, 2006
  1. I have installed SUSE everything seems to be fine but I cannot see my mouse cursor at all. When I hover over files and apps it works and I can click and stuff but its invisible.

    However the bouncing ball shows up when I am waiting for an application or process to happen but thats it.

    I have tried changing the cursor theme but that dont solve the problem. The mouse cursor works but I cant see it.

    EDIT: I am running KDE and SUSE 10.1 the mouse is a normal PS/2 Mouse not USB. I had once before had installed SUSE 10.1 GNOME on the same system and this problem didnt happen.
  2. IBN

    IBN TS Guru Topic Starter Posts: 487

    OK I have found this thread below from a forum to solve the problem. The thing is despited my search not being able to find the xorg file I found it manually under file/etc/x11/org.conf But when i want to edit it I cant.

    RIGHT If you have a working mouse which is invisible / hiden / not showing then do this (for noobs like me):

    1 Boot up Linux
    2 Move your mouse to the bottom right (start menu looking thing) and slowly move it up to switch user
    3 Type "root" in user name and type your root password (the first one you set in linux) in password
    4 Once logged on, move your mouse to the start menu and click find files and folders
    5 This takes a little time but you can do it slowly, change the directory to root
    6 Type in xorg into the search
    7 Click stop search when you see x11/xorg.conf show up
    8 Open up this file by right clicking on it (MAKE SURE IT IS x11/xorg not any others, I edited the wrong file DO NOT DO THIS!!!)
    9 Scroll all the way down to where it says "Section "Device"", this should have a load of graphic settings
    10 At the bottom of this section before "EndSection" add these two lines:
    ##fehlender cursor, hwcursor off rhb#182517
    Option "HWCursor" "off"
    11 Save (make sure you do this aswell lol)
    12 Restart
    13 PRAY that you did it correctly!

    I hope this helps all the noobs out there like me who will hopefully search this post."
  3. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You can only edit this file as the root user.

    I am pretty sure you can turn off the hardware mouse cursor in YAST too. See under the display configuration (SAX).
  4. IBN

    IBN TS Guru Topic Starter Posts: 487

    Thanx for your reply Nodsu.

    I logged in as root too but I still couldnt edit it. I'll have a look in yast to see if i can disable the hardware mouse there as you suggested.
  5. IBN

    IBN TS Guru Topic Starter Posts: 487

    Problem solved - solution

    Ok an update on the situation (happy ending).

    I manged to solve the problem by doing the following:

    1. Log in as root.

    2. Open up the following file


    3.You need to edit the file xorg.conf you may need to open it using an editor ie open with kate

    4. Add the following line Option "HWCursor" "off" before EndSection under Section "Device"

    5. Close the file and save changes.

    6. Reboot.
  6. IBN

    IBN TS Guru Topic Starter Posts: 487

    I just installed SuSE 10.2 and I had the same problem as 10.1! I went to do add the line like i mentioned in the post above, but I did it incorrectly.

    Now my X server doesn't load up!!! Is there any way I could get my X server up again so I could edit the file correctly?

    Many thanks in advance.
  7. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    What prevents you from editing the file in textmode? Don't you have any editors installed (such as nano or vi) ?
  8. IBN

    IBN TS Guru Topic Starter Posts: 487

    I don't know the command in text mode to edit the file i want. I know the file location though.

    (PS i am a bit of a noob but i do try)
  9. IBN

    IBN TS Guru Topic Starter Posts: 487

    Ok Up date on the situation.

    I ended up reinstalling! Those who run into the same problem of editing the file incorrectly, should google vi editor and try give re edit that file.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...