Cannot Shut off Usb HDD

By Liquidlen ยท 6 replies
Nov 3, 2004
  1. I am running a generic USB 2.0 Ext inclosure with a Maxtor 80 on Win2k Srpk4 ,drivrs used came with the enclosure.
    This drive has always worked but it is not used a lot ,It only holds Drive Images of my 3 networked machines.
    Anyway after downloading an image from a computer (which DI says was sucessful)the ext drive refuses to shut off when I use the small taskbar icon to shut down the Mass storage device.
    I am going to try removing the existing drivers and try Win driver.There are no exclamation marks in Device Manager.
    I looked through the search here but my eyes are sore .Any ideas.

    BTW;the drive is formatted NTFS with 4kb clusters,1 partition.Would any of this matter?
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    My suggestion would rather be: start the PC without that drive connected. Then go to Control Panel/Add-Remove Hardware/Uninstall and select "Show hidden devices".
    Uninstall anything to do with that drive. Repeat until all are gone.
    Reboot, when W2K is up, reinsert the USB cable to let W2K re-install the Unit. You probably need to re-install the unit-drivers as well. Check for an online-update.
    Best of Irish!
  3. Liquidlen

    Liquidlen TechSpot Paladin Topic Starter Posts: 1,094

    Good to see you Real..
    If I start the computer with the Ext Hdd disconnected ( off) ,it doesn't show in Dev Man.
    - Univeral Serial Bus Controllr
    -Iiayama usb hub
    -Intel contrllr 2442
    - " " ......... 2444
    - USB Mass storage Device(only when running)
    - USB Root Hub
    Excuse short cuts ,but should I uninstall Just Intel controllers or The whole thing including the USB main controller?

    What affect does the Cluster size have if any ,considering I only use this drive to copy large Drive Image files?
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Cluster-size is irrelevant.
    Uninstall everything underneath "Universal Serial Bus Controller" except (if you have them ) USB mouse or USB keyboard.
    The Iiyama usb-hub, is that built into the monitor? If yes, leave it.

    Surf to and D/L the trial-version of Source-USB if you are not sure yet. Tells you all about your USB-gear.
  5. Liquidlen

    Liquidlen TechSpot Paladin Topic Starter Posts: 1,094

    Thanks for the tip Real...
    I may try that software, depends on what I discover next.
    I changed the Driver that came with the HDD housing for a generic Microsoft.Did not work!
    Tried your advice and reloaded Intel Controller's no change.
    Unplugged the Hdd from IIyama monitor hub and placed it direct to the USB on the rear of my case.
    I guess I should have thought of it earlier ,but the drive has been installed there since day 1It works like new, Go figure.There is only 1 other connection in that 5 point Hub and that is to my Digital camera,which was not connected thru all of this.
    Thanx for your help I am going over too Iiyama to see what I can see. If nothing, then I will try that program you mentioned.Get back to you if I discover anything.
  6. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Glad you got it sorted.
    The monitor-hub probably does not supply enough power for all the units, and it might be an old USB1 version.
    Run that program anyway, it will tell you all the USB-specs of your whole system.
  7. Liquidlen

    Liquidlen TechSpot Paladin Topic Starter Posts: 1,094

    Very interesting discovery.
    I spoke to soon in terms of settling this problem.
    After removing some old files from this drive and then Defragging it .It refused to shut down again.
    I opened the case because this a three year old build and thought I would re-seat all USB connections.
    There is a front USB terminal( Lian-Li 66)and I had originally reversed the '+ ,-' Data terminal connectors at the Motherboard's external USB block.
    I don't know if I ever used this terminal ,all my USB devices are connected at the rear MB panel.
    I guess I am surprised that I did not get errors or some trouble a long time ago and also why the "not shutting down issue" as a symptom of this error would only occur after using the Mass media device with very large files or long processes.
    I am confident I found the answer because I copied some 2gig files and defragged again with no issues.
    Anyway just in case this occurs to someone else.
    It couldn't only be me .Could it?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...