1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

cannot use regedit, disk defragment, or search companion

By blah3
Jun 18, 2005
  1. I have a problem with three of these programs, and I just recently got rid of a trojan virus.

    When I run regedit, the command prompt pops up and then quickly goes away (regedit.exe works fine though)

    -Disk Defragmenter
    When I run Disk Defragmenter, I get this error, "MMC cannot open the file C:\WINDOWS\system32\dfrg.msc. This may be because the file does not exist, or was created by a later version of MMC. This may also be because you do not have sufficient access rights to the file."

    -Search Companion
    When I run Search Companion, I get this error, "The file that is required to run Search Companion cannot be found. You may need to run setup". Then when it opens, the whole thing is blank.
  2. blah3

    blah3 TS Rookie Topic Starter Posts: 21

    Well, I solved two of these problems WITHOUT formatting. I fixed search companion, and disk defragmenter. It was simple. All I did was run my Norton Disk Doctor, Norton WinDoctor, and a few other Norton Utilities. These things only come with Norton System Works though, I think. Regedit still doesn't work for me, but maybe I'll find a way to fix, if I need to, becuase I just use regedit.exe now.
  3. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Try regedt32.exe until you got the problem sorted.

    Get your XP-CD out, click Start/Run, type in sfc /scannow and click OK, to replace damaged or missing files.
  4. senu

    senu TS Rookie

    re: regedit problem

    I had a similar problem and have now solved it

    You still have a virus ( i had several from a nameless a p2p software- why? curiousity and 4m broadband! ) 926 to be exact

    Regedit.exe works fine because that is the right command. You have in your windows\ system 32 \folder a file called regedit .com which hijacks regedit.exe when you run it in the usual way You need to delete regedit. com immediately. It is not a windows system file but is a trojan loader disgused as a genuine file. you will need to go to tool s option view files and make all files including system files unhiddeen before you can see the folder and file .Then run , if you like pandasoftwares free online scanner . try the link below


    :approve: :(
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...