1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Can't access external hard drive -- it won't initialize

By DJC......R ยท 9 replies
Jan 25, 2013
Post New Reply
  1. My Sengate 1T external HD has been working for years. It has vital back ups, files, movies, docs, etc.
    I CANNOT AFFORD TO LOOSE ANYTHING!!! (I am a DJ and also have over 20 000 tracks on there)

    I was using the external HD on a Windows 8 laptop and accidentally pulled the USB cable out of the port while it was loading and changing the "Permissions for SYSTEM and Authenticated User" on a specific file on my external HD.

    When I plugged it back in the drive showed up on my computer as normal but would not open.
    After reading a few posts I went to the device manager deleted the drivers for the external HD then when I plugged it back in it updated the drivers and told me me my device is now working properly and ready to use and my drivers are up to date.

    But now it wont show up on my computer at all.

    I went into disk management and the Disk 1 had an icon with a picture of a HD with a red arrow facing down in a white circle.
    under Disk 1 it says:
    (empty line)
    Not Initialized

    I then right clicked and it said offline. When trying to get it back online it says:
    "The system cannot find the file specified."

    In the properties under Volumes it says:
    Disk: Disk 1
    Type: Unknown
    Status: Not Initialized
    Partition style: Not Applicable
    Capacity: 0MB
    Unallocated space: 0MB
    Reserved space: 0MB

    When I try to Initialize Disk it says:
    "The system cannot find the file specified."

    hd stuffed.

    I have tried it on every port and on a different PC running Vista as well as on my TV (which now says "no USB device plugged in")


    I NEED TO FIX THIS or at least find a way to BACK IT UP and transfer ALL the data onto another drive.
  2. Its4u2n0

    Its4u2n0 TS Rookie

    Similar thing happened to me.. I'd love to hear an answer on how to recover the data as some of it is rather important.. Good luck DJC, I'll check back in and hopefully we will have our files back!!
  3. reha andrew

    reha andrew Banned

    See I think your hard drive is logically damaged in this case I would suggest you to use a data recovery program. For that go online and search some best and renowned data recovery software, you will get them in two version one free and one paid. Just try the free one first then if you think it really working nicely then go for the paid version. And if still any problem then consult a professional data recovery company.
  4. compfixing

    compfixing TS Rookie Posts: 26

    Why don't you go ahead and unplugged the SATA cable, and plug it in again. Then do exactly like you did uninstalled then installed again.
  5. alexe3831

    alexe3831 TS Enthusiast Posts: 27

    SNGX1275 likes this.
  6. misor

    misor TS Evangelist Posts: 1,356   +287

  7. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,545   +429

    Like alex said, I think this is something where you are going to need a recovery tool rather than a diagnostic tool. As long as you just pulled the cord out accidentally and not 'pulled the cord and crashed the hard drive to the floor' your data should be good, just perhaps a partition table got hosed somehow. The data should still be there.

    Although, this should serve as a lesson/reminder to everyone to never have only 1 copy of critically important data. I know sometimes this is hard, especially when you are dealing with giga or terabytes of data, but if it really is irreplaceable the $100-$150 cost of a dedicated backup drive should be worth it.
  8. jmaxx

    jmaxx TS Rookie

    Same problem, please help us. experts share your knowledge.
  9. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,545   +429

    The information is in the thread. Please read it. Without further details we have to assume the answers are already here.
  10. jmaxx

    jmaxx TS Rookie

    This is also my problem, see my screenshots. please let me know if you have solve this problem. I tried everything but nothing happened.
    2. 3.

    Attached Files:

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...