1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Can't connect to server from work

By Browncoat ยท 18 replies
Jan 2, 2007
  1. I know I have the right port open, port 21, and I'm using the same programs that another co-worker is using. But I can't connect to my socks proxy server "Socks Puppet" from work. I foward port 21 on my router, both computers are xp, professional on the client "Laptop", and home edition on the host. I'm using SocksCap as the client. When I check the log on SocksCap, it says
    21:40:57 SOCKS32.DLL[IEXPLORE]: CON S:1388 Proxy server connect: Open communication channel to SOCKS server
    21:40:57 SOCKS32.DLL[IEXPLORE]: CON S:1388 Proxy server connect: SOCKS communication channel established.
    21:40:57 SOCKS32.DLL[IEXPLORE]: CON S:1388 Socket close requested.

    Is it from the host side that it's requesting to close? I reformated the host pc before trying all of this, if that's the problem. I didn't put the entire thing here because I doubt anyone would want. Please, can anyone help out?
  2. Goalie

    Goalie TS Booster Posts: 616

    Can you be more specific about what software you're running and what you want to do with it?

    What software are you using at work to connect to home?

    The error on the surface appears to say that the remote end requested the connection be closed- as I don't know which side you got this log from, I can't say for sure, but if I am thinking right this is saying that something seems to be amiss at your work end.

    Knowing more of what you are trying to do, though, will help greatly.
  3. Browncoat

    Browncoat TS Rookie Topic Starter Posts: 28

    The server that I'm running at my house is Socks Puppet. The client that I'm trying to connect to the server is SocksCap. I found the error on the log on SocksCap. I know they work since someone else is using the same things. So your saying it's from the client side that I'm having the problem? Or the Host?
  4. Browncoat

    Browncoat TS Rookie Topic Starter Posts: 28

    Something weird happens. I can ping the server from work, and telnet it but I can't connect to it. Then when I go home and refresh the whatismyip.com page, it shows a different number. That seems to happen alot, the ip changing alot, but I'm not sure if that's the problem
  5. Goalie

    Goalie TS Booster Posts: 616

    It sounds like your ISP is using a NAT, or a really anal DHCP lease.

    Have you tried using DDNS? Does your router/modem support DDNS updates? Might be an option for you.

    And if you compare your home IP to the reserved IP address spaces, does it fall in there? (anything that starts 10.*, 172.16.*, or the famous 192.168.*?) I mean this for the IP that you leave home thinking you should use...
  6. mikescorpio81

    mikescorpio81 TS Rookie Posts: 293

    You are port forwarding port 21 inbound to where? a LAN IP address? check that you have done that side of things right first off.
    Once you are satisfied the NAT rule is working, try and telnet your public IP address from outside your LAN (goto http://whatismyip.com then in a cmd prompt type: telnet ---.---.---.--- 21). If you get a blank screen or anything really then you know your NAT rule ok good.
    Get that sorted first before attempting anything else.
  7. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    (1) port 21 is the FTP port. try mapping your home server to something else, like 10021
    and then using that number from work.

    (2) you should be aware that ALL ports below 1024 are for well defined services
    and your ISP/EULA will forbid you using any services like these.

    read between the line on (1) and (2) :)
  8. Browncoat

    Browncoat TS Rookie Topic Starter Posts: 28

    I already said I can telnet it. I'm not sure about the NAT or DHCP lease or DDNS. Is that something I have to do on the server itself? I'm using verizon dsl. How would I map my home server to something else? And it usually falls in 72.73.*.*, but also has been 71.72.*.* I'm not a computer genius, so you guys are gonna have to be a bit detailed about what I should try. Different router/modem? talk to isp?
  9. Goalie

    Goalie TS Booster Posts: 616

    Ok, shame on me. I missed that you could telnet into the box. What do you telnet to, though? A telnet daemon? Or to your socks service? If to your socks service, what response do you get when you do that?

    In that case, I would agree with jobeard (although he wasn't totally right.)

    I would suggest moving your server port to something like 10021 (and port forwarding.) How to do that will depend on what server software you have- in this case, you know much better than I do.

    I don't think a different router or modem are needed here. Your IP isn't a reserved address, so that shoots that idea out. You say that when you get home your IP has often changed- are you still able to telnet to your box at the same time you can't connect to the socks server? If so, that tells us the IP change isn't a direct cause of the problems although it certainly can have negative impacts in other aspects. You should be able to connect for at least short periods of time in spite of this, is what I'm saying...
  10. Browncoat

    Browncoat TS Rookie Topic Starter Posts: 28

    I can't move the server to listen to that port, and connect to it from work's end. It needs to be port 21, otherwise it won't work. Only thing I can gather is that its' on the server side since it says on the SocksCap client end "Socket close requested". I'm just not sure what. Windows firewall is allowing the port, and on the server, it says under active "no" so something is stoping the connection.
  11. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    Sorry, I just don't believe this. This would be true if it could not be configured,
    and if that's so, it's a piece of junk. ALL server software needs to be configurable
    and the firewall on the server side needs to allow the correct port.

    "Socket close requested" will be seen for ANY condition that closes the connection,
    voluntary or forced.
  12. Goalie

    Goalie TS Booster Posts: 616

    Actually, Joe, the limitation probably is on his work side, which is kinda a pain. I know, I'm limited to ports 80 and 21 outbound as well, without going through real firewall hoops (as traffic from my net goes through three firewalls before getting to the outside world).

    At this point I'm somehwat suspecting we're having issues in the port renegotiation after the inbound connection since the server sees the first connect but then it's dropped.

    Is it possible for you to set up a packet capture on your home network???
  13. Browncoat

    Browncoat TS Rookie Topic Starter Posts: 28

    yes it is possible, is there a specific program in mind? I know this works because "like the 5th time I said" a co-worker does it all the freakin time.
    what doesn't joe believe? I can configure the program to listen to a specific port, but it has to be port 21.
  14. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    pst: it's jobeard as in J. O. Beard.
    The issue is not you or what you can/can't do, but rather doubt that it
    absolutely must be port 21.
    It might be a necessity due to other considerations, but the software should run on any port.

    in a typical configuration, ports 1-1024 are strictly controlled, both in/out bound
    while outbound 1025 and above are open for outbound.
    this leads quickly to the common ports ftp(20,21), ssh(22), telnet(23)
    being monitored and or access controlled.

    if your server at home were on 10021, your outbound connection to it would
    likely succeed if your firewall would port forward to your server.
  15. Browncoat

    Browncoat TS Rookie Topic Starter Posts: 28

    so your saying that if I change socks puppet to listen to port 10021, then connect using socks cap, it would work?
    And it's ports 21,22,23 that are open, but I'm not sure which one to use. I can't change the port # at work, I have no control over the firewall. And I'm not sure if a packet capture program will do anything.
  16. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    you're starting to see the light. No, you can't control the firewall so you need
    to find WHAT IS LEFT OPEN. Of those open, some will have strict monitoring
    or filtering. Moving your server to a port that is uncontrolled will allow your
    client it's best chance to connect. Again, avoid everything lower that 1024.
  17. Browncoat

    Browncoat TS Rookie Topic Starter Posts: 28

    but from what I'm told the ports open are like 20, 21, 22, or 23. Will it work if I set the server to listen to port 10022, and then connect using sockscap port 22? Or do I have to put 10022 on the client end? Just so you know, co-worker sets it up as this: Socks Puppet Listens on port 23, and on sockscap he puts in the ip, and port 23. It works that way, but will it work the way your telling me?
  18. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    sorry but this is really wearing me out -- so one last time ---

    the client and the server *MUST* talk to each other on the same port --
    any port that they can make a connection with.

    the firewalls *MUST* allow inbound and outbound traffic on that port.

    you're on your own from here ---

    really, best wishes
  19. Browncoat

    Browncoat TS Rookie Topic Starter Posts: 28

    ? on my own from here? I tried with port 10021, and it didn't work. Seems like your theory wasn't quite there. I guess port 23 allows inbound and outbound traffic on that port because that's the one another person uses. The ports that are open"which I'm saying over and over again but you don't seem to listen" is 21, 22, and 23. Those should allow traffic according to what your saying. What I'm saying is that something is wrong with the communication between my host and the client that's closing the connection. since your giving up on me so soon, I guess there's no hope for me.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...