can't defrag

By BlackRussian
Oct 29, 2006
  1. Hi guys, I'm new here but I sure could use some help! I've been battling with my system for over a month now and it seems I may never be able to defrag again. From what research I've done I've figured out the following:
    From doing a "fsutil dirty query c:" the response is dirty. I'm assuming this is why my defrag won't occur and asks for a chkdsk /f on startup. Yet it doesn't matter how many times I perform the chkdsk /f or /r or any combination of chkdsk the autochk runs on startup and finds a host of file system errors that it claims it fixes and I find my system "dirty" right after windows boots again. Still no defrag can occur. I've tried running the recovery console and performing chkdsk /r from there and at first it appears to have cleaned and repaired yet when I tried to defrag it says there r inconsistencies in my file system. Now when I check using the fsutil com. it comes back dirty again. My questions are what is causing this and of course how can this be fixed. There don't appear to be any bad clusters. Could some software or even a virus re "dirtying" my system at boot? I'm aware that some antivirus software or even hotfixes can cause similar problems but how do I know which one. Starting in safemode does nothing to help. FYI...I am running XP on an NTFS file system. I have two hard drives utilizing about 300 gb on a raid0 set-up, so checking my disks with a manufacturer's software doesn't apply I think. Appreciate some expert assistance here! Tx in advance for ur time.
  2. Rik

    Rik Banned Posts: 3,814

    Get speedfan from the downloads section and use it to checkout your hdd's S.M.A.R.T. characteristics to see if your hdd is causing the problem!!!!
  3. BlackRussian

    BlackRussian TS Rookie Topic Starter

    Tx for ur reply and suggestion. I tried speedfan but to no avail..apparently doesn't support Raid controllers. I tried Active S.M.A.R.T also which doesn't support IDE (ATA) controllers at this time either. I just want to remind u though that the error I'm getting at defrag now that I've run chkdsk /p through the recover console is that there are inconsistencies with the file system. I've run sfc /scandisk /scannow and it completes with no apparent errors. The error at defrag just appears to repeat itself even though the volume is no longer "dirty". I haven't seen anything to support the theory that my hard disk(s) r failing. Any other comments/suggestions?
  4. Rik

    Rik Banned Posts: 3,814

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...