Can't detect hard drive after P/S swap

By Ratking496
Feb 23, 2007
  1. My Antec Neo480 p/s quit working the other day and i bought an Antec Neo550 to replace it. Everything went smoothly with the swap but when i turn it on it won't find my boot drive. It states something like no boot drive detected insert boot cd, etc.. I have 2 WD 80g sata drives in raid 0. I quadruple checked all connections, then i unhooked everything and just hooked up the raid drives and vid card power, still the same thing. I also tried disconnected the sata power cables from the drives and hooking in molex power cables, nothing. Also tried other sata power cables aswell. I can't figure out why this is happening with just a P/S swap. Do i need to change something in the bios? Do i need to stick in my spare 80g ide drive and install windows on it, then replug in my satas and see if they'll be detected? Could the new P/S be causing this, it seems to be working properly though? I'm really outta ideas. I'm guessing its something to do with the boot drive being raid, but i've had this setup runing great for a couple years now and all i did was swap P/S.

    I went into bios and all the settings are the same as i had them. On the main bios screen it shows all the ide master, ide secondary, sata master, etc... There all disabled, which i think is correct since the only thing i have plugged in atm is the 2 sata raid drives. On the boot priority tab i have 1.hard disk, 2.cdrom, 3.removable, 4. disabled. The only other selectable option is legacy lan. I tried to enter raid setup during post with f10 but it won't go, prolly because it can't detect drives. In the onboard device configuration there is the NVraid configuration tab. In there it says Raid enabled, and its enabled. Then the following is disabled: ide primary master and slave, ide secondary master and slave, first sata master and second sata master. The third and fourth sata masters are enabled, which is where my drives are connected.

    After post the exact message that is displayed is, "Disk boot failure, insert system disk and press enter." I thought maybe i could put in the xp disk and maybe windows would boot and i could back up my data real quick. So i hooked up my dvd drive and it doesn't seem to be showing up in bios. Also it won't open, like its not getting power. I'm beginning to think this new P/S is borked. But its powering up and all fans are working etc... I was also thinking that my other p/s might have messed up the mobo but it didn't die while the comp was on, it just failed to start the other day completely out of the blue. The same thing had happened to my previous p/s which lasted about the same time 2-3yrs.

    My drives are full of data i can't lose, i kept putting off backing it up. Any and all ideas are most welcomed. I'll try anything. Thanks!!

    My specs:

    WinXP Pro, Asus A8N-SLI Premium, AMD Athlon 64 3200, 2 gigs OCZ Plats (2x1g), eVGA 7800GT, SB Audigy 2, 2xWD 80g 7200 SATA (raid0), 1 WD ide 320g (storage drive), NEC DVD/RW drive, Pioneer slot DVD drive

    EDIT: I found the problem, i scrounged up another p/s from my sisters pc, and swapped it in and bingo everything works perfect. So i'm both relieved and pissed, lol.
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Remove the "non detected" drive and use another drive as the C drive just for test purposes. If this other drive is detected, your old C drive may be bad. We can discuss saving data later
  3. au8219

    au8219 TS Rookie

    hey ratking i am having the same kind of trouble. have you resolved the issue? how did you do it?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...