Can't Get Into Windows XP, NTDLR MISSING ERROR

By gta3freak_2001 ยท 13 replies
Aug 27, 2003
  1. Ok as the topic says I can't get into windows, right now I am using someone else's PC to post. Anyway the other day I went and turned on my pc as usual except right before Windows would normally load I get this error message:

    "Searching for Boot Record from Floppy....Not Found

    Searching for Boot Record from CD-ROM...Not Found

    Searching for Boot Record from IDE-0...OK

    NTDLR is missing
    Press CTRL+ALT+DEL to restart

    When I pres ctrl+alt+del, the computer restarts but still shows the above message. I am running Win XP Home Edition with SP1 I believe.

    Here are my complete specs incase they are important:

    Athlon XP2000+ @1.7GHz
    ECS K7S5A Pro Motherboard
    512MB DDR
    GeForce 4 MX440SE 64MB SDR(I know its crap )
    C-Media Onboard Sound
    Samsung 20.4GB HDD
    HP CD-Writer Plus
    Conexant 56k Modem

    I would like to avoid anything that will format my hard drive as I don't have a WinXP Install disc so I wouldn't be able to get Windows back.

    Any Help would be appreciated.
  2. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Open up your machine, and make sure that all of the cables are pressed tightly into the hard drives, cd-rom drives, floppy disk drive, both on the end that goes into the drive, and the end that goes into the motherboard. If you have changed no system settings and this has happend out of the blue, is likely that a cable has become loose.
  3. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Or a friendly piece of software has wiped out the contents of the Windows boot partition..
  4. schizoid77

    schizoid77 TS Rookie Posts: 113

    I recently ran Norton Utilities on a friends pc and it did exactly that...wiped out the boot partition, I'm thinkin', had to reformat the drive and reinstall 98...she was none too happy, so I gave her my old video card, a coke, and a smile....

    Hopefully it's a cable problem....
  5. Justin

    Justin TS Rookie Posts: 942

    Try to boot from the XP cd and do a "repair install", if it detects the existing XP installation... you may be out of luck, however.
  6. gta3freak_2001

    gta3freak_2001 TS Rookie Topic Starter

    I don't have a WIN XP Install disc because you see I did have a HP computer and I had it upgraded, only keeping the CD-Writer and HDD from the HP machine. HP don't give you an actual WinXP Cd only a stupid recovery cd which won't work anymore because I have new parts and it is now a non-HP PC now. I hope that made sense anyway I have checked all cables and I found none to be loose. However I have searched net a bit and found out the NTDLR is an actual file used to boot up Windows and then I thought if I create a boot disc with the NTDLR.dll on it from another PC then maybe I would be able to get into windows and copy the file to my C:\ thus solving the problem. Here's the site where I got that idea from:
  7. Michael68

    Michael68 TS Rookie

    Go to Microsoft's web site and search their knowledge base on this subject. I found an article there "How to troubleshoot "NTLDR is missing". The first one I found was 318728 in the knowledge base. It is for windows 2000 but should work for XP too. You could probably find it for XP too but I didn't take the time.
  8. ehayes

    ehayes TS Rookie

    NTDLR missing - Repair

    Start the PC using the Windows XP cd. Go into recovery console.
    use the BOOTCFG /repair command to rebuild the boot.ini.
    Go to the i386 subdirectory on the XP cd and copy NTLDR and to the root of c:
    Exit and reboot.

    -Eric Hayes
    Senior PC Tech
    Microspecialists 2000 L.L.C.
  9. edwards1

    edwards1 TS Rookie

    I wonder how many more clowns will tell you to put in your XP CD?

    Anyway, did you fix the problem with another copy of netldr? If not i can email you one off my CD.

    I have had this problem before when installing XP on an old Athlon pc. XP appeared to have problems with the HD (10Gb) and would not boot.

    A friend suggested XP was not partial to old hardware. I installed W2K instead and it went in first go, no probs.

    The reason i tell you this is because in this case, even copying a new Netldr did not solve the problem.

    Do you have (or are you considering buying) another HD. After all i'm sure 20G is not enough. If so, try installing XP onto the other drive. If it is just your data your worried about, maybe the easiest is to remove the drive and stick it into someone elses pc, backup the data, then format the sucker. (Note that any amount of formating did not solve my problem as formating dose not fix the boot sector. The recovery console - fixmbr also did not mix my mbr)
  10. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Just copying over the ntldr file will most likely not solve his problem.

    There is a reason ntldr is missing, and it probably has something to do with a corrupted volume or boot settings, which just copying a file is not going to fix.

    I can honestly say I've never seen "just a" corrupted or missing ntldr. It is also very likely that other files are corrupted to, which is a prelude to a larger problem. Furthermore, you can get this message if you are missing other files too. Just because it says it is missing ntldr, doesn't mean it is really missing.

    If you are against using the XP system repair for some silly reason (highly recommended), you may be able to repair a damage boot sector by loading the XP CD to access the recovery console. First, you might want to verify your disk is in good health by running chkdsk. Type in fixmbr and hope for the best. You may also try bootcfg /rebuild.

    If these things don't work, then you have a larger problem that the XP repair will possible fix. If the XP repair doesn't fix it, then you probably have a disk or memory problem.
  11. czb

    czb TS Rookie

    I've moved a drive with an OK installation of XP Home to another machine. When I try to boot I get the NTLDR missing message.

    As recommended in previous posts I've run the BOOTCFG /rebuild and copied NTLDR and NTDETECT files but this hasn't worked.

    I don't want to lose the data on this drive.

    Can anyone suggest a further course of action?


  12. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    Edward is probably got you started on the best course.
    These companies( HP Dell) use proprietary cd's to force people to use them for upgrades and fixes obviously for $
    If you are going to doityourself get your own microsoft copy of Windows if your budjet can .Also a new Hdd ,install as master and the existing HDD as slave.Once you have loaded your win on the master you should be able to get all your files.

    BTW I really think there is a hardware error as your original problem either connective or compatibility
    Good luck
  13. exclamation55

    exclamation55 Banned Posts: 76

    Bios Firmware Upgrade

    compaq presario 700
    had that problem after installing a replacement 40gig harddrive

    because laptop runing xp eventually died -
    would not come on :dead:

    solved it with firmware bios upgrade :grinthumb
  14. Per Hansson

    Per Hansson TS Server Guru Posts: 1,959   +217

    Download xxcopy16 to a working Windows 2000 or XP install, take a floppy

    Press start run and type cmd.exe press enter

    go to the path where you saved the file, i.e. cd \xxcopy


    XXCOPY16 C:\NTLDR A:\ /H

    Now try to boot with this floppy on your computer, if you are unable to build this floppy I can send you an image of it.

    Hope you can get your data back...

    If this procedure does not work I would create a Bootable Windows PE CD, this will require you to have a Windows XP or 2003 CD and also a Windows 2000, XP or 2003 system with a CD burner to create it from.

    On that CD also include the demo version of R-Studio

    It will scan your computer for all files even though there is no proper partition table and will enable you to recover data (the demo version is limited to files of size less than 64k bit it will give you an idea of how much data you can recover so you know if you should buy it or not...)

    A similar thing has happened to me but I'm on a RAID-0 setup, not to get your hope down but I've been trying for 3 days now without much look (all my data is scrambeled due to the RAID-0)

    EDIT: sorry, I did not see the date of this thread
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...