Can't get two computers networked!!

Not open for further replies.


Posts: 19   +0
Hi there, was wondering if maybe a fresh brain might help on this. I have a laptop and desktop and simply want to network them together via a BT HomeHub, to share files. I had both of them connected fine a few weeks ago but my Vista install went bust after installing a beta driver so I had to reinstall. Now, here's the details of the problem:

- The desktop is Windows XP and the laptop is Vista Ultimate.
- The desktop is wired into the HomeHub, the laptop is wireless.
- Both running Norton Internet Security 2007
- I have NIS2007 on both of them set to trust the network and to trust each computer individually also.
- Windows firewall is turned off on both machines.
- Both machines are in the MSHOME workgroup.
- Have Network discovery and File & Printer sharing turned on in the Vista Network Manager thing.
- I can ping between both machines fine using their name and IP address.

When I go into "View devices" on the laptop, I can see the laptop and another one called "Thomson" which is the Homehub itself but not my desktop. However, when I go to run and type \\desktop\ I do get a folder up but it contains only "Printers" and none of the other shared folders. If I try to access \\desktop\share then I just get a message saying it couldn't be reached. On the desktop if I try to get to \\laptop\ I get nowhere!

I even tried turning Norton off on both machines but it seemed to make no difference. Like I said, I had file sharing working fine before I re-installed Vista and was able to map to drives on the desktop.

Maybe I'm missing something simple here but I CANNOT get this to work!! :(
is it xp pro or home?

xp pro or home my friend

if its xp home you will need to make the user account and passwrd the same on each machine

if thats not the case id say norton is playing games with you. try uninstalling the norton and see if that helps


Posts: 13,957   +1,774
Norton config may be more complicated, so start with NORTON disabled and
enable the Windows FW on both machines.

Use the Exception tab on the FW and enable Print/File Sharing on both.

btw: the actual ports required are
135-139 + 445 tcp/udp in/out allowed

Using View Entire Network->Windows Network->Workgroup should show you
all the system names on your LAN. If not, then the system name that is missing
has a badly configured firewall -- it it fixed and then set permissions.


Posts: 19   +0
  • Thread Starter Thread Starter
  • #4
Jspottt, it's XP Pro :)

I tried disconnecting the WAN and completely disabling Norton & Windows Firewall on both machines, still with no joy. Tried with JUST Windows firewall and nothing. Had Network Discovery and File and Printer sharing as exceptions.

I can reach \\desktop\ from the laptop (i.e. I don't get an error message) but all I get is a folder with "Printers" and none of the shared folders. Originally "Desktop" doesn't show up in the "View Devices", after I browse to it via \\desktop\, it shows up in the list, but when I click on it, again I get only "Printers".

From the desktop \\laptop is not accesible at all. I can ping between both machines fine and can even remote desktop using their internal ip or hostname. At my wits end with this one!


Posts: 19   +0
  • Thread Starter Thread Starter
  • #5
Hmm, kind of (half) fixed the problem.

Seems it may have been a problem with NetBios. I checked the Event Viewer on my XP machine and saw that I was getting an error relating to NetBT "Initialization failed because the driver device could not be created." and when I tried a nbtstat - n, I was getting an error message. I ran a fix ("netsh int ip reset resetlog.txt") and then rebooted both machines.

I can now see Laptop from the "View Workgroup Computers" on the XP Desktop and can connect to it and view its shares. In the Network & Sharing Centre of the Vista Laptop, I can see Desktop on the Devices. However, here's the problem:

I can see the device listed as a Workgroup computer, but if I double click the icon or run \\desktop, I get a "device is not accessible" message. But, if I browse to the actual share name, it seems to open OK (e.g. \\desktop\downloads opens fine).

Not open for further replies.