Can't Install Any Printer Drivers! :-X

By Tryforceful ยท 5 replies
Jun 23, 2005
  1. Hey All:

    I've been searching internet tech forums for a solution to my problem, since people usually have the same problem that I do somewhere out there, but I haven't seen a straight answer to this and I've been getting worried. Here's my spheal:

    I recently installed a new copy of Win XP (now upgraded to service pack 2) after my system started to fail running Win2k -- possibly a virus or something of that sort, though I believe it was the McAfee Firewall's fault, but that's (I hope) irrelevant. Resulting from that failure, I have a bunch of problems I'm still dealing with... corruption, loss of e-mails and personal settings.... so imagine my angst when I find that Win XP won't allow me to install any of my printer drivers!!! Any at all! I'm trying to install:

    HP Deskjet 855C (LPT)
    Epson Stylus CX4600 (network share, via a Mac G5)
    Kodak Printer Dock + (also network share with Mac)

    I know the network works, and as far as I can tell the parallel LPT port isn't the cause of the problem, because no matter which of the above I try to install, I come up with the same error.

    "Printer driver was not installed. Operation could not be completed."
    (when using "Add Printer Wizard")
    "Unable to install <PRINTER>, Windows 2000 or XP, Intel driver. Operation could not be completed."
    (when using "Add Printer Driver Wizard")
    "There was a problem installing this hardware: <PRINTER> An error occurred during the installation of the device."
    (when using "Found New Hardware Wizard" for the HP)

    In the Found New Hardware wizard, I select the HP DeskJet 855C (it's from the 850 series) with its XP driver (v5.1.2600.2180) that's located in C:\WINDOWS\INF\NTPRINT.INF. Strangely, when I have my Win XP cd in, it also searches for the driver there, and the CD's version is v5.1.2600.0, which is located in E:\I386\NTPRINT.INF.

    In all of the driver installations, the progress of copying the drivers to C:\WINDOWS\SYSTEM32\SPOOL\DRIVERS\... goes through almost all the way, i.e. the progress bar fills up all the way. Then I get an error.

    XP drivers for HP printers are already on the computer, and I have the cds containing the proper drivers for the Epson and Kodak networked printers. It's not the driver. I can try to install any old driver, and none will work. But I can install drivers for other hardware, just not printers.

    I updated my BIOS recently, but if I can remember the problem existed even before that.

    I don't get an error with the spooler or RPC.!!!

    Thanks in advance to everyone,

  2. shani

    shani TS Rookie

    i need solution for this problem plz reply me as soon as possible

    You could have just written you have the same problem instead of copying the whole text.
  3. nork

    nork TS Maniac Posts: 306

    I cant really think of anything to help you. You could check your bios and see if there is something there, which i doubt actually, but its worth a shot.

    One bit of help, you might find something at microsoft website?
    Have either of you tried google?
  4. nork

    nork TS Maniac Posts: 306

  5. gjohnson

    gjohnson TS Rookie

    From what you have said, you are unable to load the drivers for the HP855C printer (forget the network printers for the moment) and the HP is directly connected to the computer which will not load its drivers. I have an HP845C and could not get the printer to work either with a driver using the XP wizard. My solution was to load the driver using the printer CD and all was ok (including network printer sharing). This sounds too simple a solution to your problem, but have you tried this? Incidentally, I loaded the complete executable from the HP website and used that rather than a physical CD.
  6. babsly

    babsly TS Rookie

    can't add printers

    I had this problem, woke up one day, no printers, so I added drivers from original disc, from web, still couldn't add printers, in the utilities, said searching for drivers...
    Finally, I went to printer setup utilities -and printer preferences, and from there hit printer set up, found my printer, answered a few questions, and all works fine. Thanks Goodness!!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...