Cant install Rome Total war gold edition

By Superhog ยท 11 replies
Feb 9, 2006
  1. Rome Total war gold edition installation problems

    when i try to install the game it sais d:setup.exe is not a valid win32 application. Can anyone help me?

    the computer is new but i have installed other games on it successfuly.
    im using windows xp home edition but autoplay does not work when i put the disk into either dvd or dvd rw drive.
  2. detrunks

    detrunks TS Enthusiast Posts: 153

    what OS are you using?
  3. JMMD

    JMMD TechSpot Chancellor Posts: 854

    Do you have multiple optical drives? Do you have anything like CloneCD, Alcohol 120% installed?
  4. Superhog

    Superhog TS Rookie Topic Starter


    yes i have a dvd and dvd rw drive with nero startsmart software
  5. JMMD

    JMMD TechSpot Chancellor Posts: 854

    Have you tried both drives to install the game?
  6. Superhog

    Superhog TS Rookie Topic Starter

    yes i have it doesnt work on either drive
    i bought the game cheap online with "clickforgames" could this have any thing to do with it?
  7. john1

    john1 TS Rookie

    Have you got nero suite installed on your computer . if you have it may have come with the drive.
    It can produce this error ,which i also had on my sons machine after we had built it. some games/software may install but after nero we had this message everytime on games. we uninstalled the nero software and no more problems. installed pinnacle instead for writing. there must be a conflict but where?
    i hope this does help as it took us a full day to figure this out after checking & rechecking the computer setup
  8. arima194

    arima194 TS Rookie

    Reply stuff Rome

    This is not just your problem
    I belive this is a microsoft error in install shield and that a download from them may have made it happen
    I have tried to install ROMe total war as well and i get error 1628
    I have also tried to cure the problem myself but was unable
    I have also had Rome total war on the comp before which may also be the problem
  9. ndsc_uk

    ndsc_uk TS Rookie

    I have exactly the same problem. The RTW DVD disk does insall Ok on A tower machine running WinXP but my lap top which has a similar spec gives the error message mentioned in the first post. Both machines have Nero6 software on them so it is not a conflict with that and it is not a duff RTW disk.

    I have two copies of the WinXP pro OS on my laptop. One has no other programs installed ( it is just the bare WinXP pro OS) it didnt recognise the Rome Total War gold edition disk as a valid Win 32 application. So the problem is something to do with the OS rather than a confilct with other programs. The RTW disk did run on the tower machine which also has WINXP pro on it so it must be some specific update of the OS which is causing this. But HOW TO Get AROUND IT?!!!!

    I tried installing RTW but using a different DVD drive on a usb port to the laptop. It worked no problem. This is odd in that the hardware device manager indicates both the internal dvd drive that gave the problem (a NEC DVDRW ND6500A) and the extenal one that worked (Sony DVDRW Dru-700A) use the same driver( MS 5.1.2535.0 01/07/2001). The internal dvd seems to work with other games: MTW, IMPGlory so is not dammaged . So what exactly is the problem? I have encountered a similar problem before when trying to load Windows from a disk on a new high spec tower which had two DVD players. One always gave an error message that the Windows Cd was not a valid application while the other always worked oK. I have no idea what causes this. Does anyone know?
  10. warchief

    warchief TS Rookie

    RTW Install
    For some reason RTW would install when I used my DVD/CD-RW drive but not with my basic CD-ROM drive. Even when I copied all the data from the 3 discs to to a file from my CD-ROM and then installed it would still not work. I have had similar things happen in the past (works with one drive and not the other) with a few other games but it remains a mystery to me as to why.........would really like to know though.
  11. ffrut

    ffrut TS Rookie

    I had "Not a valid Win32 application" when I tried to install RTW but it was possible to copy the disks to hard drive and install from there. Similar problem occurred with another game (LOTR) and was finally solved by upgrading the drivers for Nero and InCD. I found this tip on another site so credit is due to the original source :)
  12. slayer12f

    slayer12f TS Rookie

    Whenever i insert disc 2 it says disc skipping and automatically quits the installation
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...