1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

can't run 16-bit windows program

By aym · 12 replies
Sep 6, 2005
  1. Hi everyone

    I am having troubles reinstalling an educational software which I had runing before on my compaq laptop's Win xp home ed. I had restored my system to its manufacturer orginal while ago and did not reinstall this program since. I am sure it was runing perfectly before but I cannot remember whether this was when I installed sp2 or not last year.

    Now I need to reinstall this software again and all I have every time I try is
    "can't run 16-bit windows program. insufficient memory to run this application . Quit one or more windows applications and then try again"

    According to this article on Microsoft http://support.microsoft.com/default.aspx?scid=kb;en-us;324767

    I first tried the run commands but I still had the same problem. Then I replaced config.nt and autoexec.nt as recomended and this did not fix it too. I couldn't replace the third one (i.e. command.com) because I need my windows installation CD which I don't have as my computer came with preinstalled xp from Compaq and all I have is their recovery CD. I have been searching for two days to find a way around this but could't.

    Everything else is working fine with no problems. I tried to find any solution on compaq/ Hp website but none.

    As a last resort I thought of partitioning my disk so I can backup my files on a separate partition and then reinstall xp using Compaq recovery CD and then reinstall my program but this even seems to be unachievable as I have no "unallocated free space" for new partition.

    I appreciate your help and thank you in advance.
  2. greenflash

    greenflash TS Rookie Posts: 99

  3. aym

    aym TS Rookie Topic Starter

    Yes I tried everything and still have the same problem....I also did system restore to an old date back to about two months ago but this didn't work either.

    I am thinking of restoring to the point of installing sp2 which I did straight after my last reinstallation (using Compaq recover CD) and then try to reinstall my application. The only thing that stops me from doing a new restoration (i.e reinstalling to original manufacturer status) is having to backup my files (over 5 Gig) and my only way to do this now is having to burn 7-8 CDs which is not so appealing to me at all....

    I am so pissed off by the way Compaq (and I guess all manufacturers) restrict your options to do anything other than restoring to their original status. It is rediculous that you cannot do a normal system repair as per any ordinary windows intallation :mad:

    many thanks
  4. urbandragon

    urbandragon TS Rookie Posts: 229

    XP home go here

    XP Pro Go here

    the problem you are seeing is due to the OEM version of windows that is installed by HP/Compaq. I have seen this many times.

    See if one of the above options work for you if not you will need to download the appropriate version of the autoexec.nt, command.com and config.nt

    i have used this fix many times to fix this problem so it should work.
  5. aym

    aym TS Rookie Topic Starter

    Thanks so much urbandragon, this is what I was looking for (the command.com file in particular). I hope it works when I try it when I go home and I will keep you updated.

    Thanks a lot
  6. aym

    aym TS Rookie Topic Starter

    Unfortunately, this did not fix the problem !!! I still have the same "can't run.." error :confused: :confused:

    I couldn't even find an older restore point to when I did my last reinstallation. The oldest point was last June (it seems like allocated max space was reached and old restore points deleted).

    Please help
  7. john3593

    john3593 TS Rookie

    damaged cd scratched cd causes same error

    Get this. I put in an old educational software tonight into my laptop - It ran fine - I was not careful in taking it out of tray and scratched it - I didn't notice until I got some unrecoverable read errors in Nero when I went to burn a copy of it - Yikes - I never got that - I then took the original CD, placed it back into laptop and received the "insufficient memory to run this application""can't run 16-bit windows program" message. I couldn't believe it - It has just worked minutes prior.

    I tried the same original "retail" (hmm,hmm) cd in another pc - same error message - which I knew was impossible on my clean workhorse video editing machine. That's when I saw the slight scratch I gave it. Uuugh.

    I never would have guessed this one, but the damaged CD (of the old 16 bit program) actually caused the "insufficient memory to run this application can't run 16-bit windows program" message! Therefore, the message is misleading but it is how Windows XP SP2 may respond to the damaged CD - WOW. Hope this might help.

    By the way, I was able to intentionally burn a copy at a LOWER speed (I set Nero to read at 8x) and write ay 20x (way below what settings allow) - This worked this time - no errors, and whew, a good copy of my damaged original CD.
  8. aym

    aym TS Rookie Topic Starter

    Thanks John3593

    I will check wether this might be the case with my CD although it was well kept and I usually take care of my Cds.

    I will keep you updated and hope I come back with good news.
  9. aym

    aym TS Rookie Topic Starter

    Well, my CD seems to have slight scratches on it but I am sure they are old and existed when I would install it in the past. However, I tried to burn it to see if it gives me any errors or I can have a better copy. I couldn't burn it even at the lowest speed using Roxio (always giving me the underrun error).

    However, I just tried to install my same old CD on another computer which still hasn't got SP2 on it and it started the installment as would normally do. So it seems that the problem is in SP2 or one of its updates.....what a headache......I did backup for my important files and burned 6-7 CDs...wooofff...but I had been still reluctant to uninstall SP2. I just have so many programs installed and not so excited about having to reinstall all of them again. Any ideas around this ?!!

    Do you think I would have the same problem runing the program if installed properly and then I reinstalled SP2 ?

    Thanks for all your help
  10. gbhall

    gbhall TechSpot Chancellor Posts: 2,419   +77

    check your CD drive

    Although you have correctly run your install on a pre-SP2 machine, this may not prove anything except the CD drive in your SP2 machine cannot read the install CD but the drive in the SP1 machine can.....

    To avoid this possible problem could you copy the install on the SP1 machine, and burn a fresh copy CD ?

    IF on the other hand, SP2 is REALLY the cause of the problem, installations FOLLOWED by applying SP2 are most unlikely to work.

    Depending on how crucial this install is to you, the following would work - you need to obtain partitioning software to shorten the existing SP2 partition, then create a fresh XP install from the Compaq install partition. Then you have a multi-boot (2 XP operating systems), one of which is not updated to SP2, and will thus run your important package.

    Not simple, but it would work fine.
  11. Vigilante

    Vigilante TechSpot Paladin Posts: 1,634

    How much RAM do you really have? How much is used? How big is your swap file? Perhaps you autoexec.nt is fine, but needs a value within to be increased? Compare your autoexec.nt and config.nt with the same files on the system that DOES work.

    Also, you should be able to just uninstall SP2 without losing programs or data. Check add/remove programs to see if it's there.
  12. MikeMcC

    MikeMcC TS Rookie

    Not sure if this overlaps with your issue but I discovered the same error message trying to run an application from a folder on a separate disk which wasn't my Windows XP installation.

    For some reason copying the app to my Desktop on my C drive or to a directory on the other drive with shorter directories in the path or with no spaces resolved the "Can't run 16-bit Windows program" error pop up.
  13. gbhall

    gbhall TechSpot Chancellor Posts: 2,419   +77

    This has been going some time !

    MikeMcC has a very good point. Dos programs had all sorts of hidden restrictions that have become obsolete (the authors themselves could never have dreamed of them). Path length is one, paths with only eight characters per directory level could be another, memory size or use of expanded, EMS or XMS memory is another, use of High memory is another.

    First off, you MUST be running under control of system32/cmd.exe not command.com

    If the properties of the link trying to start your application do not contain a memory tab you will definitely get nowhere. First try running compatibility mode for Windows 98/ME which should cause the memory tab to appear, then try all combinations of memory restriction. The most common one would be to restrict Ms_DOS protected mode memory (DPMI) to 8Mb, none for EMS or XMS memory, does not use HMA, not protected.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...