Can't run setup from CD's

By Nilgan ยท 9 replies
Apr 16, 2006
  1. I'm running windows xp service pack 2. I cant seem to install any programs from cd's. Whenever I try to run it, it says that it has encountered an error and must close. I can install programs that i download from the web fine. I can also uninstall programs.

    I wanted to try repairing windows but as with other programs it encounters an error when i try to run the setup. any help is greatly appreciated
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Go to your device manager and uninstall your cd drive/s. Reboot your computer and let Windows redetect them. See if that helps.

    If not, try changing your cd drive/s ide cable.

    If none of that works, try another cd drive.

    Regards Howard :wave: :wave:
  3. Nilgan

    Nilgan TS Rookie Topic Starter

    I tried uninstalling and the driver's reinstalled on reboot. However the same error occured when i tried to run the windows xp cd. I did get different error messages on a few other cd's i tried

    "procedure entry point postMessageA could not be located in the dynamic link library User32.dll"

    and on another

    "SETUP caused a General Protection Fault in SETUP.exe at 001:021C"

    also when I go to Services my Windows Installer keeps turning off on it's own or switches from automatic to manual sometimes. I've scanned for viruses and spyware etc etc and found nothing.

    Also I should say that I have 2 CD drives. One is DVD drive (the one which cant run the setup) and the other does not even appear in "My Computer." my DVD drive can open the cd and i can copy the files onto my computer. It just wont run the setup.

    In device manager there is also an exclamation on somehtign called a PCI Simple Communications Controller
  4. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    disable if you have not done so
    IMAPI CD-Burning COM Service
    there is a installer fix for windows 2000 and xp
    if you can't find let me know will post on my web site
  5. Nilgan

    Nilgan TS Rookie Topic Starter

    i still havent had a chance to try the IDE cable.

    @samstoned: I tried what you said and ti didnt seem to have an effect on them. When i double click on setup.exe it thinks for a second and then stops, nothing happens
  6. N3051M

    N3051M TS Evangelist Posts: 2,115

    update your chipset drivers for your motherboard and any pci cards. they can be found at the respective manufacturer's page, or by googleing the make and model of the device.

    to find out what mobo you have you can use Everest Home by Lavalys or SIW (downloaded at the download section of this website)

    while your at it.. you may as well update all drivers for everything else......
  7. Coolmatt

    Coolmatt TS Rookie Posts: 66

    Add more RAM.
  8. Nilgan

    Nilgan TS Rookie Topic Starter

    i updated all the drivers. still no go :\
  9. N3051M

    N3051M TS Evangelist Posts: 2,115

    at least your pci controller thing in device manager should be gone now?

    try installing from safe mode...
  10. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    not be using the correct 32-bit drivers for your disk drives
    but you loaded the correct MB drivers right
    installer link
    can you run from cmd line?
    have you looked at event viewer
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...