Tech Stocking Stuffers: 18 awesome gifts under $50

Can't set region, can't play DVDs

By adiamond
Aug 24, 2005
  1. I have an Nforce 2 athlon xp shuttle motheboard system with an optowrite dvd-rw. I can't play movie DVDs because any DVD software complains that my region isn't set.
    In the DVD's hardware properties it says that the region isn't set but if I set the region (region 1) and then try again the same thing happens and then the Properties again lists the region as not set. However, unfortunately, it does properly keep the count of how many times I've reset the region and so now I'm down to 2.

    I tried removing the DVD from the hardware list and rebooting/redetecting but the same thing happens.

    I've looked in the registery under the system/controlset/control/class/{random-***-classID}<numbers> and I see that the DefaultDvdRegion is set to 1.

    I'm stumped.
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

  3. adiamond

    adiamond TS Rookie Topic Starter

    Thanks so much for replying.
    Unfortunately, I still seem to be stumped.
    I tried the Drive Region Info V2.2 from the first link you gave. It returned "problem with ASPI layer detected" and that I should try turning off the DMA for my DVD drive or if I have a via chipset get new drivers. However
    1) I don't understand what to do about ASPI drivers considering, as I understand it, the SCSI (ASPI?) system is what underpins the win2k IDE system is provided with the OS
    2) I don't see any option for DMA in my DVD's hardware properties
    3) I don't have a via chipset.

    I didn't see anything on your second link that would seem to address my issue.

    On a clarification of my previously described symptoms. When there is no DVD inserted, the DVD hardware properties will list the player as region 1 but when I insert a DVD it shows as "no region selected."

    BTW, the DVD is an Optorite DVD RW DD0405 140E.
  4. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    You could flash the drive's firmware with RPC1 one. RPC1 drives have the same region change limit of five times, but the counter can be reset.

    For your Optorite drive, the RPC1 firmware can be found from here (RPC1 E Series firmwares based on 150E, and 160E).

    Of course that voids the warranty and you do it at your own risk etc.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...