can't start RPC server!

By jan3toc
Jul 12, 2005
  1. ..My computer is running windows XP.. i ran a service pack 2 update.. and it left my comp with out sound.. can't copy/paste.. and i can't install any of the drivers to my printer/sound card/ or anything because it tells me the RPC server is not available... i went to services and tried to start the RPC and it won't let me ... i can start the RPC locator .. but not just the RPC ... what else can i do!? the only option i'm thinking is to just wipe my hard drive and re-install everything... =( help!!
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Maybe there`s no need to format.

    Try a repair install first. Instructions can be found HERE

    Regards Howard :wave: :wave:
  3. bajpaiabhinav

    bajpaiabhinav TS Rookie

    Starting RPC by Abhinav Bajpai

    Abhinav Bajpai.

    Restart your computer by using the Safe Mode startup option. To do this, follow these steps:a. Restart your computer, and when the Boot menu appears, press F8.
    b. Under Windows Advanced Options Menu, select Safe Mode, and then press ENTER.
    c. When the Boot menu appears again with the words "Safe Mode" displayed at the bottom of the menu, select the operating system that you want to start, and then press ENTER.

    2. Click Start, click Run, type regedit, and then click OK.
    3. In the left pane, locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Hardware Profiles\Current\System\CurrentControlSet\Enum\ROOT\LEGACY_RPCSS
    4. On the File menu, click Export.
    5. In the File name box, type a name for the registry file.
    6. In the Save in list, click the location where you want to save the registry file, and then click Save.
    7. Right-click LEGACY_RPCSS, click Delete, and in the Confirm Key Delete dialog box, click Yes.

    Note Do not delete any one of the following subkeys that may be found under the ROOT subkey:• MS_L2TPMINIPORT

    8. Exit Registry Editor.
    9. Restart your computer by using the Restart Windows Normally startup option.
  4. Leader(XFX)

    Leader(XFX) TS Rookie

    OK....Well, I'm having the same problems but it wont let me delete Legacy_Rpcss. I'm in a corner and could use any information on this.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...