Card Reader Problem

By Acoustics4me ยท 5 replies
Jul 6, 2006
  1. Hi'a guys,

    When I first boot up my pc, and insert my camera's memory card into the card reader, everything goes fine. To remove it, I use the 'remove hardware safely' option, and that's fine. But when I want to insert it at a later date, unless I have rebooted my pc, my reader wont recognise that the card is inserted. If I reboot, all is well. When I look in device manager, under "universal bus serial controllers" there is a device with the yellow exclaimation mark, which when I look at the properties I get this message "Windows cannot use this hardware device because it has been prepared for "safe removal", but it has not been removed from the computer. (Code 47)" I am assuming this is my card reader drive? But I always "safely remove" my card, so I don't know what's up.

    I am running Windows XP sp2, and the card reader make is apacer. This has only recently started happening, but I can't think of anything I've installed that may conflict with it. Any advice would be greatly appreciated, just keep it simple for this girl. Thanks...

    Me :)
  2. fastco

    fastco TS Booster Posts: 1,123

    Does it work if you just remove the card without using the "remove hardware safely" thingy? Also did you install SP2 recently?
  3. Acoustics4me

    Acoustics4me TS Rookie Topic Starter

    Fastco, thanks for the quick reply. I haven't tried that, but I will tomorrow, and will let you know (very late this side of the planet, I'm off to bed). Why do you think that would make a difference?

    Buona Giornata (have a nice day!)

    Me :)
  4. N3051M

    N3051M TS Evangelist Posts: 2,115

    Good habit.. if only people start doing that to usb flash drives then half the problems would be solved. But thats for another rant. Do bear in mind that removing the media without this step is ok, as long as there is no transfer of data or use of the media happening..

    I believe the symptoms you state happens with card readers a lot. Is yours an USB one or an internal one? If its USB then just unplug it and plug it back in instead of rebooting.

    Try instead of the "safely remove hardware" thing, go to My computer, right click the removable media drive with the card and goto eject, like you do to a CD/DVD drive.. then remove.
  5. Acoustics4me

    Acoustics4me TS Rookie Topic Starter


    Good morning everyone...

    Well, I tried both bits of advice, and both worked. Thank you both so much for your effort.

    N3051M, it is an internal unit, so I don't have the option of unplugging....bummer.

    Fastco, I keep wanting to spell your name 'Fatso' cos when I look at it, that's what first came to Anyway, no, I have sp2 installed for ages, so that can't be it eh. Thanks for that site link you gave's very good, and I'll do some more research on other things also.

    Cheers you guys,

    Me :)
  6. N3051M

    N3051M TS Evangelist Posts: 2,115

    Good to hear its solved :)

    yes, internal units do suck, as you'll need to reboot or restart the device somehow but for convienience hey...

    Have fun!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...