CD Burner stoped working

By XtR-X ยท 16 replies
Apr 9, 2004
  1. I have a Samsung 52x24x52 CD-RW as well as Easy CD Creator 5. I've been burning stuff to a certain type of disks... TDK brand name and all has gone very very well for me.

    Well, lately, with the same disks, my burner doesn't burn into them. It acts like it does, it wastes my time, it makes the noise, the red light showing it's burning is on on the drive.

    I take out the CD, try to play/use it, and nothing can read it. It's blank! I can even try to burn something else on it b/c my computer thinks it's a blank!

    I haven't recently modified my startup. All my CD utilies and stuff are enabled to boot. It doesn't make sense. Why would it stop working?

    I have all the latest patches for everything.

    All cables/wires are plugged in snug and correctly.

    Thanks for your time.
  2. StormBringer

    StormBringer TS Maniac Posts: 2,244

    Tried cleaning the drive? Changing write speed? Will it read discs that already have data on them?
  3. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    I have seen bad drives do this, so I would not be surprised if it had finally kicked the bucket.

    What I might try here at home is test the CD-Burner in a different system. If it works - Great. You know the problem is with your computer. If it doesn't work, then you know it is bad for sure.
  4. XtR-X

    XtR-X TS Rookie Topic Starter Posts: 863

    Yes it still reads.

    Also, how am I supposed to clean it?
  5. StormBringer

    StormBringer TS Maniac Posts: 2,244

    You can buy kits to clean a CD drive, or you can open it and clean it using denatured alcohol, but I wouldn't recommend it unless you are familiar with it. Also, I don't know if cleaning will do any good since its still able to read discs.
  6. BrownPaper

    BrownPaper TS Rookie Posts: 407

    if the drive is still under warranty, RMA it. if you try to open the drive up and clean it, you will void the warranty on your drive.
  7. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    Have you tried uninstalling it from the device manager and reinstalling it? That has helped with more than one situation I've been in the past.
  8. XtR-X

    XtR-X TS Rookie Topic Starter Posts: 863

    I don't really want to resort to this because I love Easy CD Creator 5. I know my burner needs updates from them to work, but sadly, I lost everything... my serial... my proof of purchase... my box... everything... but I still have the CD. I can't download updates so is there any other alternative?

    BTW, I also tried burning with Nero, the program that came with my CDRW drive... no luck..
  9. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    No no no.. You won't have to uninstall your software to uninstall your burner from Device Manager.

    Search for more information on if you need help using Device Manager.
  10. XtR-X

    XtR-X TS Rookie Topic Starter Posts: 863

    Thanks, but I tried that when poertner told me. I right clicked it, and uninstalled it, and then it was gone. I restarted, and it was back, and still didn't work.

    Any ideas?

    Also, it's getting worse. It used to recognize blanks but not record them, now it doesn't recognize them anymore.
  11. XtR-X

    XtR-X TS Rookie Topic Starter Posts: 863


    My CDRW Drive no longer reads anything anymore, but stilll works. It opens and closes and is still recognized in My Computer. It no longer works!!!
  12. OS samurai

    OS samurai TS Rookie Posts: 159

    Do you have another comp to put the drive in to test it like Rick asked? If it works in the other system we know there is something wrong with the comp that the drive was originally in? did you attempt to clean the drive like storm advised?
  13. XtR-X

    XtR-X TS Rookie Topic Starter Posts: 863

    I will attempt to clean in later this week. I currently don't have a test computer laying around anywhere, because all my friends took their computers home. So time will tell.
  14. OS samurai

    OS samurai TS Rookie Posts: 159

    ok, keep us posted :)
  15. qwedsc

    qwedsc TS Rookie

    i have the same problem

    i have a laptop and the internal burner acts like it's burning but when i check the disk it says that it's blank. i also have an external burner and it shows up when i plug it in but when i click on it is says it cant be found. all the old burned disks work and dvds play normally. i used the restore disk that came with the laptop and restored my whole system and it still doesnt work. the only thing i can think of is that maybe some core software might be damaged and since the restore disk is not a full version of windows maybe it cant fix the gonna try the external burner on my girlfriends computer to see if it works but the internal one i obviously cant. can someone please help me with this problem. ps. maybe a registry cleaner or some kind of program to fix software that my restore disk cant fix. thanks
  16. qwedsc

    qwedsc TS Rookie

    just to leave an update

    well, just to let anyone who has the same problem know that the problem is in the registry. I tried everything else to fix the problem with no luck but just for the hell of it I tried a registry cleaner. I used Registry Mechanic and the problem is gone. My laptop is running like new. ok latta
  17. xo melodramatic

    xo melodramatic TS Rookie

    i have a similar problem with my computer.. except it won't burn at all!

    i don't know what the problem is.. it will only burn to CD-RW but only a certain type of CR-RW if it feels like it.

    it does the same for writing files or burning music. help!!!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...