1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

CD-Rom Drives not recognised in OS?

By nebulus ยท 6 replies
Feb 20, 2003
  1. I have attached two drives (CD-RW & DVD) To my new motherboard (Asus A7V8x). CD-RW as Secondary Master and DVD as Secondary Slave. These are UDMA2 (66) and are rooted by a normal 40 conductor-IDE Cable.
    UDMA 66, I know to be supported by my Mobo.

    On the Ultra-DMA Connector, I have two HDD, one as Primary Master and the other Primary Slave connected by a 80 conductor-UDMA Cable.

    I have checked in the BIOS, they are present/detected. Also, when I boot up, the POST shows that the two Disk Drives have been recognised. However, when I enter Windows, in 'My Computer', nothing! :confused:

    All connections seem to be correct with cables, and I have tried known-working alternative cables. All Jumper-settings seem to be correct?

    I am assuming this is a software problem, as that is what seems to be the most obvious here, but of what kind, I have not a clue?
    Do I need to install some sort of driver here to aid recognition in Windows?

    I have looked into the 'cd-rom controllers' given in the 'hardware wizard' from 'Control Panel', where I have 3 possible controllers listed, these being Mitsumi, Panasonic and Sony, by which, none of my drives are manufactured? (mine are NEC and Samsung)

    Any advice would be appreciated here please, as this has stumped me?

    Thanks for reading.
  2. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Any recent and not-so recent CD-ROM/DVD does not require drivers to work in Windows.

    Check your device manager and list any (!) icons you have next to your hardware. If there are none, double check your jumper settings. The devices CAN be listed in the BIOS but not be properly jumpered.
  3. nebulus

    nebulus TS Rookie Topic Starter Posts: 32

    No exclamations in DM. Under CD-Rom Drives I have in there only my 'Ce-Quadrant-Emulator Drive'.
    Re-checked jumpers, all seem to be correct?
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You should check the settings for IDE controllers and install recent chipset drivers.

    You can also try removing the IDE controllers in Device Manager and then reinstalling them.
  5. StormBringer

    StormBringer TS Rookie Posts: 2,244

    Look and see if any devices are listed in there that you don't have. I've seen things like this where drives would be listed as "generic storage device" or even misidentified as something else. If you find any such entry, remove it and try to reinstall the device again.
  6. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    "CeQuandrant Emulator Drive" sounds like a virtual device. It could be messing with your REAL drives. Uninstall CeQuadrat and restart... Maybe that will help.
  7. nebulus

    nebulus TS Rookie Topic Starter Posts: 32


    Ahhhh, solved now my friends, the coconut goes to Nodsu on this one. Really lame I know, but the answer was simply that I had not installed the 'VIA Bus Master PCI IDE Controller', duhhh :blush: .

    I put my HDD into another PC and got the driver off the cd-rom, then installed it back into current machine and all now working fine, hehe :D

    Thanks for all advice folks, and thanks Nodsu!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...