CD-ROM Issues with Dell Dimension 2400

By BGPhilbin
Jun 10, 2007
  1. I disconnected my CD-Rom/Optical Drive from my Dell Dimension 2400 desktop PC in order to connect a Hard drive and quickly transfer some files - but once I reconnected the optical drive, the PC doesn't seem to recognize it. I tried resetting my BIOS options to original, but no go.

    Can anyone out there help me? I tried another known good optical drive and I know that the IDE cable is good and my BIOS is A05, which is the most current.

    I can't figure this out for the world of me. If any of you experts out there have any idea where my next step should be, I would greatly appreciate any help you can give me!



    Forgot to mention, both this and the other KG optical drive power up just fine - it's just that the system never recognizes it.

    I also got a message when I first connected it that indicated that the PC had found a floppy drive, rather than an Optical Drive. I don't have a floppy, so that was a bit confusing to me, and nothing is recognized when I put a CD in it.

    Thanks, again!

  2. gavinseabrook

    gavinseabrook TS Rookie Posts: 316

    What else changed about your system. 10 to 1 you wont have problems like this just from switching your cd drive for a hard drive. I do it all the time and have never had problems. Does it see the drive in the POST? Make sure your bios is set to auto detect everything.
  3. BGPhilbin

    BGPhilbin TS Member Topic Starter

    Really, that's it - right now, it looks like a floppy drive and I don't see that that drive is recognized as an optical drive during POST, but it has also stopped warning me that it doesn't find a drive there at all since I reset to original BIOS specs. It's possible that I used a different part of the IDE cable to connect it, but that's really all that changed - other than the fact that I had to reset the BIOS to default.

    Trouble with the A05 BIOS is that it really isn't very user friendly - I had to press ALT+F in order to reset it during POST, rather than just choosing that option in the BIOS itself.

    Since you seem to think I'm missing something, what else could possibly have changed that would result in the system not finding an optical drive when powered up and attached - even though it will recognize the hard drive every time? Any direction you can give me will be helpful!

Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...