CD-RW weirdness

By DennisB · 24 replies
Dec 31, 2005
  1. This one's got me stumped. I have two CD drives on my PC, a CD-ROM (drive E:), and a CD-RW (F:). The CD-ROM works fine, but recently the CD-RW began doing a strange thing. I can format a disc and both read and write to it. However, when I try to create a new folder on the disc (or rename an existing one) the entire system crashes when I make the next click. I get a blue screen saying that Windows (XP) has closed for my protection, and that I need to reboot. After powering off and on, the system boots normally and all's well until I try again to write a new folder on the CD-RW disc. This writing a new folder process works fine on my laptop (also running XP).

    Anyone have an idea what's causing this? I don't know if this is related, but drag-and-drop works erratically. In Windows Explorer, I can drag and drop files or folders once or twice, but then get a command to insert a disc in E:, which, as you'll recall, is the CD-ROM drive. If I open and close the CD-RW drive, the message goes away and I can drag and drop once or twice more before getting another insert disc in E: order.

    Since this glitch does not prevent me from backing up files and loading new software, finding the answer is not urgent. But it could indicate that there may be a bigger problem in store down the line.

    Here's hoping someone will have a suggestion.
  2. CBH

    CBH TS Rookie

    Are you using the eject button on the drive? Check the UDF Software you have installed and if it has an eject option use that instead (right clicking on the UDF Software in the Systray should show Eject) - ejecting the disc using the drive button can easily cause a corrupt disc.

    In saying that it could also be something related with the UDF software directly - what software are you using to format discs?
  3. DennisB

    DennisB TS Rookie Topic Starter

    I suppose opening the drive with the button could be a problem, but I've been doing it that way since I've had this computer (Dell), and this problem only arose recently. Also, there is not problem with disc corruption; I can read and write to the discs, I just can't create a new folder.

    As for burner software, I'm using Roxio EZCreator 5, which came with the system. I use CD-RW for backups and images, so once I've formatted some new disc, I have little occasion to do it again.
  4. CBH

    CBH TS Rookie

    Although you can still read/write to the disc there still can be corruption, sometimes it’s very difficult to tell when a disc is actually corrupted so lets look at other causes in the meantime.

    Did you get a separate Roxio install disc or is the program built into the Dell System Recovery discs?

    Make sure that you’re not using Easy CD Creator 5.0 < 5.1 or higher is needed. You can find updates under

    See and look at the error codes, anything look fimilar?

    Do you have ant-virus installed? Can you disable the software before inserting the CD-RW into the drive?
  5. DennisB

    DennisB TS Rookie Topic Starter

    Your points are well taken, but in this case disc corruption doesn't seem to be a factor. CD-RW discs that crash the system when I try to create new folders on them work fine (that is, I can create as many new folders as I like) when I load them into my laptop (also running XPSP2). If a disc was corrupted in some way by the PC, you wouldn't expect it to run OK on another computer. Or would it? Also, I am running Roxio version 5.1.

    Also, the laptop is up to date with all MS patches (as is the PC), so the problem wasn't introduced with one of those fixes. I'm guessing that somewhere along the line I loaded a piece of software that caused the problem. This wasn't recent -- I replaced the OS partition with a two-month-old image and the problem was still there. Unfortunately, I don't have any images older than that.
  6. CBH

    CBH TS Rookie

    Not always the case which makes corrupt disc hard to detect but dont get me wrong yes to some extent a corrupt disc will fail on 2 PC's depending on the specific problem.

    Another few option to try:

    Check the DMA for the drive, go into the Device Manager and under IDE/ATAPI controllers double click on the Secondary (im guessing your drive is installed onto the Secondary IDE Port), under advanced settings you will see options for DMA - Disable the DMA apply and OK, reboot and test again. If it was disabled then try it enabled. Sometimes you need to force the DMA on/off on the BIOS if the Device Manager doesnt work.

    Another is the ASPI Layer, has this been looked at yet? Take a look at ASPI Layer Help for some tools on the ASPI.

    Good Luck.
  7. DennisB

    DennisB TS Rookie Topic Starter

    I went into the secondary IDE/ATAPI controller as you suggested. There is no option to enable or disable DMA, but there were two options: "DMA if available" (which was selected) or PIO only. I select the latter and rebooted. Problem still there: can't create a new folder on a disc in the CD-RW drive.

    I looked as the cd-burner help site you linked, but was unable to download the aspichk.exe -- broken link. However, I did download aspiinst.exe, though I haven't run it yet. Might that help?

    I also noted on that site that Roxio CD Creator v5 is incompabible with XP SP2. However, this is not the case with the v5.1 on either my pc or laptop. Both will format and burn discs, the only problem being this inability to create folders on the pc burner.

    When I was in Hardware Manager, I checked for updates for the CD-RW driver. Got a reply that there was nothing newer than what's already loaded.

    It's possible that updating Roxio might be the solution to this. However, I'm reluctant to buy a current version without first being sure that that would fix the glitch. Maybe it might be worth uninstalling Roxio and loading another program to format CDs. I'd be willing to try that. Can you recommend one?

    Thanks for your interest and suggestions.
  8. DennisB

    DennisB TS Rookie Topic Starter

    Problem identified--maybe. I downloaded and install a copy of CDBurner XP Pro 3 and tried that. After formatting the disc, I was able to create new folders on the disc with no trouble. So, it would seem that the problem is with Roxio CD Creator 5 (I did upgrade to 5.3 -- made no difference).

    That's the good news. The bad is that after creating these new directories on the CD, the backup program I use won't work. This program writes folders on the hard drive to the same folders on the CD, with compression and (optionally) with mirroring. So, I either need to find another burner program that will work with the backup, invest in a newer version of Roxio, or simpy learn to live with it.
  9. CBH

    CBH TS Rookie

    Dennis I am stuck for time to answer your updates in full but as soon as I get a chance I'll respond.

    In the meantime I leave you with this MS Article to ponder over, somehow I think its a lame excuse in their part.;[LN];303008
  10. SultanGris

    SultanGris TS Booster Posts: 158

    Nero is about a bazillion times better than roxio.

    did u check your event viewer under administrative tools? any error messages?
  11. DennisB

    DennisB TS Rookie Topic Starter


    That link you sent may have an error -- I get a "web page not available."


    I'm not familiar with Event Viewer. What sort of error messages should I look for? Also, although I have no doubt that Nero is superior to Roxio, all I ever use Roxio for is copying (occassionally) and formatting CDs.

    I'm guessing that the glitch I've got is due to a conflict between Roxio 5 and XP SP2. Everything was working fine and there was no such glitch some months ago, before I loaded SP2. If I had a pre-SP2 image available, I'd load that and see if the problem was still there. But, unfortunately, I don't and uninstalling SP2 just to check this out is not very appealing.
  12. SultanGris

    SultanGris TS Booster Posts: 158

    right click on your taskbar, properties, start menu tab, customize, advanced tab, scroll down to system administrative tools and put the dot in display in all programs and start menu. ok, ok, yada yada, then click start, administrative tools, event viewer.

    also, i personally experienced a multitude of issues with sp2, ended up getting pissed and formating/reinstalling with just sp1.
  13. CBH

    CBH TS Rookie

    Sorry for the late reply.

    SultanGris is right with SP2 and having lots of issues but this Roxio problem is the only thing that is wrong, correct?

    Is Windows Media installed? If so do you know what version it is? You may want to try disabling the Roxio CD Burning Plug-in for Windows XP - go into the control panel, Admin Tools and Services - you should find IMAPI CD Burning, disable this and test again.

    If your CD Burner is internal it wont have specific drivers for the device but instead uses the IDE/ATAPI drivers. To update these drivers you would need to update the motherboard drivers also known as the chipset drivers. Would this solve your problem? Its a long shot but I thought I should share this info as you had mentioned looking for the drivers.

    You had mentioned using a backup program, what is this and what’s it actually do?

    If this the only problem you have then I wouldn’t downgrade to SP1, as you said you don’t really want to risk this.

    Sorry about the ASPI link - Try ASPI from Adaptec

    The Microsoft link should have been

    And take a look at;en-us;324129
  14. kapeed1986

    kapeed1986 TS Rookie Posts: 19

    dude ! who uses the burning s/w that comes XP ? Try using Nero etc.. also, disable CD writing on the drive ... maybe this may help
  15. DennisB

    DennisB TS Rookie Topic Starter


    Yes, I've been running SP2 since it came out and this is the first glitch I've noticed. As I noted earlier, one thing that's puzzling is that my laptop is running XP SP2 and the same Roxio version and there's no problem there.

    As for Media Player, I'm running v10. Also, I disabled IMAPU CD Burning as you suggested -- no joy, problem still there.

    For backups, I used two methods. For my C: partition (OS and programs) I image with BootItNG. For user and data files, I backup with a program called AKGBackup, which copies (and restores) selected folders on my D: partition to folders with the same name on CDs, with options to use compression and mirroring. Very nice utility, fast and free.

    Just for kicks, I uninstalled SP2 and tried writing a new folder on a CD-RW. Same old thing -- crash. So, unless SP2 changed some things that remained even after the uninstall, an incompatibility between Roxio (v5.3) and XP SP2 doesn't seem to be the problem. I restored an XP SP2 image after determining this.

    I looked at the links you sent but didn't see anything that seemed relevant.

    My initial concern with this glitch was that it might be a symptom of a larger problem. However, since nothing else seem to be giving me problems, I'm inclined to simply live with it. If I do need to write folders on a CD for backup purposed (with AKGBackup), I can do that with the laptop.

    I may at some point want to get a new burner program and when and if that time comes I'll look at Nero or at least something other than Roxio.
  16. SultanGris

    SultanGris TS Booster Posts: 158

    seriously, check out those event logs, look for ones that say warning, or error. my cdrw drive started to wear out, they are only good for about 1000 burns supposedly, although i didnt burn nearly that many before mine cratered, but it listed problems in the event viewer pretaining to my cd drive. put in a new drive, and problems went away, except for my copy of nero was tied to the drive, and doesnt work with the new one, :p
  17. CBH

    CBH TS Rookie

    Very strange indeed. Well if you can settle to live with it just make sure you make recent backups of any important info.

    SultanGris is rights about the logs maybe they will show something but i doubt it will tell you exactly the fault. I wouldnt see this as a hardware problem more of a software conflict.

    If you do decide to change software look into Nero but make sure to remove all traces of Roxio first. You can download roxiozap from Roxio which will remove all of their files.

    kapeed1986 lots of people use Windows XP burning, not everyone likes Nero or Roxio.

    Good Luck.
  18. DennisB

    DennisB TS Rookie Topic Starter


    Re: your suggestion to check the Event Viewer logs. I've looked through these logs and didn't see anything that appeared to be relevant to this glitch. As a test, I tried writing a folder on a formatted CD-RW to bring about a crash. I restarted and then looked in the Event Viewer to see if there were any new warnings or error messages. None under any other the three heading, application, security, or system.

    What does this tell you?
  19. SultanGris

    SultanGris TS Booster Posts: 158

    what is the exact error message that it displays when u crash?
  20. DennisB

    DennisB TS Rookie Topic Starter

    Sorry, thought I'd made it clear; there was no error or warning message after I restarted after the crash. Wish there had been. Maybe that would have provided some clue as to the cause.

    Should there have been some sort of error message? After a system crash, you'd think that there would have been some sort of message.
  21. SultanGris

    SultanGris TS Booster Posts: 158

    I get a blue screen saying that Windows (XP) has closed for my protection, and that I need to reboot.

    is that all it says? is there an error before the reboot? does it reboot itself?
  22. DennisB

    DennisB TS Rookie Topic Starter


    The blue screen error message reads as follows:

    "A problem has been detected and windows has been shut down to prevent damage.


    If this is the first time you've seen this stop error screen, restart your computer. IF this screen appears again, follow these steps:

    [It then goes on to say check for proper installation of all programs and if the message persists, to uninstall any new hardware or software. The last part is:]

    Technical Information:

    STOP: 0x00000027 (OxBAAD009C, OxEEB84C64, OxEEB84C60, EFD52E04)

    base at EFD1F000, DateStamp 3dff88b3"

    To restart, I need to power off and on, and I boot normally into XP. The only new hardware I've added recently is a new DSL modem that my ISP supplied when they upgraded the speed. As for software, I install new utilities from time to time, and I suppose I could start uninstalling them one by one to see when (if ever) the glitch disappears.

    Anyhow, does this error suggest anything to you?
  23. SultanGris

    SultanGris TS Booster Posts: 158

  24. DennisB

    DennisB TS Rookie Topic Starter

    That MS page refers to Win2K systems. Does it also apply to XP? In any case, it could be that I need an updated CD-RW driver. However, I don't know what kind of CD-RW burner I have. My system is a Dell Dimension 2400. Also, Device Manager lists the drive as HL-DT-ST CD-RW GCE-8481B.

    Where would I go to see if there are newer drivers available? I looked through the downloads available from Dell, but I didn't find one for this burner.
  25. Harry1941

    Harry1941 TS Rookie

    Please Help Me

    I have windows 2000 professional. The CD-Rom does not want to load my CD master disk at start up. How come?

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...