CDROM stopped working overnight, not accessible in windows

By Clearbeard ยท 6 replies
Feb 12, 2005
  1. Perhaps the answer to this is as simple as "it's frelled," but I thought I'd ask. Everything worked fine yesterday. Today I'm showing a "Code 31" error in the device manager on my Toshiba CDROM XM-6102B. I'm running Win2k, and the hardware troubleshooter is, as usual, no help at all. Supposedly, code 31 means the device depends on another device that is not functioning properly, but as far as I can tell, there is no other device that is not functioniny properly. I have un/reinstalled the drivers, and removed and replaced all the connections. The drive is getting power, as it can open and close, and it does show up in the post screen, and in the device manager in windows, with the yellow "!". I don't have another drive I can swap in to see if that works, but can probably get one in the next few days. Any suggestions in the mean time? Or what to try if another drive shows the same problem?

    The 6'2" Dwarf
  2. zephead

    zephead TechSpot Paladin Posts: 1,569

    you probably have corrupted system files or registries. reformatting and reinstalling windows will fix it.
  3. Clearbeard

    Clearbeard TS Rookie Topic Starter

    Okay, tried purging the windows directory and reinstalling, and no joy. Will be getting a friends drive to test tomorrow, and he's testing my drive in his machine, on the off chance it's the drive itself.

    I did recently (about 2 weeks ago) get a new Syntax K7SV266AD motherboard, could there be some defect there that is causing this? I swapped the two IDE cables, to see if it was the IDE port, and both will run the hard disks fine. Can't think of anything else to try, if the drive itself checks out okay.
  4. zephead

    zephead TechSpot Paladin Posts: 1,569

    i ran a google search for your board and model and the first page or so was filled with links to forums where people had posted thier problems with said board to get help. sounds like one of them patchy riceboard companies that likes to cut corners. continue to get that drive checked out in another system.

    PS, was your reinstall a 'clean' install or did you opt not to totally wipe the drive.
  5. Clearbeard

    Clearbeard TS Rookie Topic Starter

    Didn't totally format the drive, just purged everything in the windows system folders. I didn't have anything better to do, so I tried the reinstall again, and this time, lo and behold, it works, at least for now. May be an intermittent bug with the mobo, but I guess I got what I paid for (replaced my old one that died, so went with the $25 model since I can't afford a new processor/mobo set just now).

    Thanks for the help, hopefully it won't happen again, but if it does, sounds like I need to go ahead and upgrade everything after all, and get a quality board, or else try a full drive format. *sigh*
  6. zephead

    zephead TechSpot Paladin Posts: 1,569

    thier website wasn't even in english, btw.
  7. Triton

    Triton TS Enthusiast Posts: 82

    Windows 2000

    Windows XP
    "NOTE: There may be other third party CD-Writing Software that exhibit similar behavior. Some or all of these troubleshooting steps can apply to them if they also add entries under the UpperFilters or LowerFilters registry values by either adding their filter drivers or by removing the registry keys and values outlined in this article that start with:"
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...