Certain web sites will not load images

Have a recent issue of certain web sites not loading properly. Attached screenshot from steam homepage.
I'm using chrome, but confirmed same problem on another browser. Looks like the steam client has the same problem too on the store page. Thoughts on what's going on?

Using Win 7


Untitled.jpg
 

Puiu

Posts: 5,198   +4,061
TechSpot Elite
To clear your Chrome data for a specific website press the small lock icon next to the domain name --> click Site settings --> Clear Data.

To clear the cache data for Chrome go to Settings (the 3 dots on the right) --> Privacy and Security --> Clear browsing Data --> select just "Cached images and files" if you don't want to delete all of the settings, saved logins, etc.

If clearing browser cache doesn't work then try clearing your DNS cache. In your Command Prompt type:
ipconfig /flushdns

Restart your browser and try it again.
 
Last edited:
I think clear all the cache data on Chrome. Otherwise,
Google may have cached a version of the web page when the images weren’t working. Until the cache is refreshed, the cached version of the page will continue to load.

Clear the cache to pull the newest version of the web page to see if the Chrome cache is the problem.

1. Type chrome://history/ into the URL field of your browser and press Enter.
2. In the left menu, select Clear browsing data.
3. This will open the Clear browsing data window. Make sure at least Clear images and files is selected and select Clear data.
4. Another way to do this is to select the Advanced tab. Make sure Cached images and files is selected and select the Clear data button.

In the nuthshell, follow the above step and solve the problem.