Chaintech VolariV3 128 MB Video card doesnt work?

By newbee64
Jul 21, 2005
  1. I have a 1.7 Ghz Intel Celeron processor and a 32MB integrated video device. I wanted to play WoW so I bought a Chaintech 128 MB video card. I tried to install it, but whenever I plugged it into the AGP port the computer turns on into nothing, blank black screen. The power button also does not light. I've tried disabling the integrated video, and still no luck.

    help plz?
  2. SOcRatEs

    SOcRatEs TechSpot Paladin Posts: 966

    Hello! Welcome to TechSpot

    Try this...
    remove the new vid card.
    The onboard video is prolly still working?
    If so then boot into bios and disable shared ram for video,
    then disable on board video and/or select either 1st video device
    as agp or pci. exit bios and save as soon as screen goes blank
    shut off the power on back of machine. Install new vid card and
    attach monitor cable...Boot to windows and install drivers.
    You should be on your way then.
    POst back if your still havin trouble.
  3. springy101

    springy101 TS Rookie Posts: 28

    volari's are just horrible cards all around, return it or something if you can and get like a 9600xt
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...