Changing IRQs in Win98

By doniel ยท 20 replies
Jul 9, 2004
  1. My USB ADSL modem loses power (supplied by the USB port) frequently, mostly during downloads, and on rare occasion, while basically doing nothing.

    One possible cause of the problem might be that the PCI to USB controller and sound card (actually, an onboard sound chip) share the same IRQ: 11.

    I freed up IRQ 5 by disabling COM2 in both the BIOS and Device Manager, but Windows won't let me change the sound card's IRQ. I was able to change it in Safe Mode, but after rebooting in normal mode, it was back at IRQ 11.

    I removed the sound card in Device Manager, hoping that when I rebooted Windows and it found the sound card, it would assign it IRQ 5, but no such luck.

    Any suggestions?
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Welcome to TechSpot
    Check if you can change the IRQ of the soundcard by moving jumpers on that card.
    Depending on your BIOS settings, W98 might or might not change IRQs. When BIOS is set to PnP OS installed, uninstall the soundcard software, then move the soundcard physically to another slot and reinstall the soundcard.
    Chances are it now uses the IRQ5
  3. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    I've seen a lot of defective DSL and Cable modems do the same thing. I might talk to your DSL provider about a replacement.
  4. doniel

    doniel TS Rookie Topic Starter

    My thanks to you both.

    To realblackstuff: maybe you should lay off the Guinness. :) If you'll reread my original post, you'll note that I specified that it's not actually a sound card, but rather an onboard chip. If I try to move it as you suggest. I'll probably void the warranty. :eek:

    To Rick: I neglected to include in my problem description that I'd already swapped the modem for a new one. I'm not discounting the possibility that it's still a modem problem, but I can't in good conscience scream at the phone company (which supplies the modem) without being absolutely certain that the source of the problem is not at my end.

    Surely, there must be a way to change the IRQ setting. But how?
  5. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Tell us about your rig (fill in the data under "user cp", top of this page), specifically the mobo.
    Depending on the drivers that came with your soundchip (see, I do pay attention), they may have a possibility to change the IRQ.
    Also, if you can get into the resources (within Device Manager) of that soundchip, you should be able to (manually) make the change.

    PS: look at the time 09:32AM of my post, you think I take my PC to the pub?
  6. doniel

    doniel TS Rookie Topic Starter

    Done. If you need more info, please be specific. Thanks.

    As I wrote, I'm able to change the IRQ in Safe Mode, but the change is gone when I reboot in Normal Mode. Trying to change it in Normal Mode gets a message that it can't be changed.

    How do I know you don't live in a pub? :)
  7. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Disabling COM2 frees up IRQ3 not 5. IRQ5 is quite often used for a second printer (LPT2), and is normally free anyway.
    COM1 would free up IRQ4.

    Make sure you have nothing in PCI-slots 2 and 6, they share with your audio-chip, and PCI-slot 3 shares with USB.

    In Device Manager, what does it say under Computer, ACPI or Standard?

    The latest BIOS is 10.05, you have that?
    Are Via 4-in-1 drivers installed, and the Sound-drivers from Asus?
    Perhaps an update of either might bring something.

    PS: I live about 5 minutes (by car) away from the nearest pub, and I only go there on Mondays and sometimes Thursdays.
  8. doniel

    doniel TS Rookie Topic Starter

    Well, then, we'd better finish this up before tomorrow. :)

    You are, of course, correct about the freed IRQ. What happened was that after disabling COM2 freed up IRQ 3, ACPI IRQ Holder for PCI IRQ Steering (which also uses IRQs 10, 11 & 12) moved from IRQ 5 to IRQ 3, leaving IRQ 5 completely unused.

    Regarding the PCI slots, without opening up the computer, which I'd really like to avoid if possible, I figure there aren't any sharing problems since both the audio chip and USB are using IRQ 11, and nothing else is. Would you agree, or do you think I still need to check?

    In Device Manager, System shows ACPI BIOS. Is that what you were asking?

    By the way, I just found something interesting. System Information shows IRQ 5 to be unused. However, double-clicking on Computer in Device Manager shows IRQ 5 to be in use by an unknown device. That may be because I set the audio chip to IRQ 5 in Safe Mode. I'll have to check that.

    As far as the BIOS version and drivers go, I'll have to look at those later. I'm going to be tied up for the next several hours.

    I just want you to know that I really appreciate all your help. Thanks for sticking with me, and for the thought you're putting into my problem.
  9. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    You could also check to see if the modem is getting enough power from the USB port. Some old boards did not really follow the USB specs to the letter (amongst other things) & sometimes with a lot of USB devices you can start having problems like the one you've described.

    Connect the modem as the only USB device or hook it up to a USB hub that has its own external power supply & see if you still get the disconnections.
  10. doniel

    doniel TS Rookie Topic Starter

    Actually, the power consideration is what started me on this odyssey. It may be the most difficult aspect for me to check out, which is why I've first been pursuing other possibilities.

    Although I have a USB scanner, I disconnected it long ago, but that didn't help.

    I don't have a hub with external power.

    I do have a friend who has a similar setup to mine, and if it comes down to it, I'll check my modem in his computer and his in mine, but I'd really prefer not to have to trouble him.
  11. doniel

    doniel TS Rookie Topic Starter

    Didou, my apologies. I hadn't noticed that the reply was not from realblackstuff. Welcome to the thread, and thanks for joining.

    I think a key here may be the mystery of conflicting info regarding IRQ 5 that I mentioned earlier. I found that apparently at some point I undid the manual resource changing which I'd implemented in Safe Mode. When I now went into Safe Mode, Use automatic settings was checked, and it was set to IRQ 11. It may be that if someone can figure out why double-clicking on Computer in Device Manager shows IRQ 5 to be in use by an unknown device when System Information claims it's free, I'll be able to assign it to the audio chip.
  12. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    In Device Manager, under yoor sound-settings, there is a box where you can tick "Use automatic settings". Untick that, then change the settings to the interrupt that is free.

    PS: you have a GSOH.
  13. doniel

    doniel TS Rookie Topic Starter

    I guess I wasn't clear enough on this point. I did uncheck that box. Windows still tells me that the resource can't be changed.

    As I said in my last post, I believe that if someone can come up with an explanation for the contradiction concerning IRQ 5 between System Information and Device Manager, the problem will be solved.

    Thanks for the compliment. Runs in the family.
  14. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    It being Windoze 98, you probably have to repeat that procedure twice, same as enabling DMA for HDs.
  15. doniel

    doniel TS Rookie Topic Starter

    No change.
  16. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

  17. doniel

    doniel TS Rookie Topic Starter

    Both Sandra and Everest don't list IRQ 5. That still leaves the question of why double-clicking on Computer shows the IRQ to be in use by an unknown device.
  18. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

  19. doniel

    doniel TS Rookie Topic Starter

    Thanks you very much!

    It is very interesting. Since the author appears to be quite knowledgeable on the subject, I wrote him a note describing the problem and asking him if he has any ideas. Will let you know.

    I really hope you didn't spend a lot of time searching for the article. I've put in quite a bit of time looking for help on the 'Net, and didn't come across it.

    Thanks again!
  20. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    One search with Google using "irq5 used by unknown device"

    Hope you get your answer soon.
  21. doniel

    doniel TS Rookie Topic Starter

    Hard to believe it's a month since the last post.

    I apologize for taking so long to get back to you. I was waiting for a reply from the author of the article you steered me to (which never came), and then got swamped.

    I recently upgraded to Second Edition, and the modem's been performing flawlessly ever since.

    I want to thank you again for all your time and help. I'm really grateful.

    Take care.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...