Choppy DVD playback on slack9 using xine

Status
Not open for further replies.
Hi again all, I have another minor problem. I got my DVD working :) but when I play a DVD the playback is very choppy, i've tried screwin with the settings in xine but nothing changes. The DVD will lag every 3-4 seconds with a 1 second skip , it seems to keep lagging when the disc light is on. strange. any input would be nice thnx
 

Mictlantecuhtli

Posts: 4,049   +13
Check that your DMA is enabled on your DVD drive with hdparm /dev/dvd (or whatever the device is, might be /dev/cdrom or something). If it's not, you can enable it with hdparm -d1 /dev/dvd.
 
I noticed after i reboot the DMA is no longer set to on. Is there away to make this default on my DVD drive so i don't have to do the hdparm every time?
 

Mictlantecuhtli

Posts: 4,049   +13
Modify or create a file called /etc/init.d/bootmisc.sh

Add a line hdparm -d1 /dev/cdrom there (if you have more than one IDE device, you can add them with their parameters too, naturally). Usually harddisks are configured from /etc/sysconfig/harddisks though.

In the end of the file there should be

: exit 0
 
Status
Not open for further replies.