Compability problem with Vista and External Harddrive

By nilesp ยท 4 replies
Jan 8, 2008
  1. Hi!

    I have a laptop that came with vista (HP Pavilion dv9045) to which I oftenly have connected an external drive (Seagate Freeagent 500Gb).

    It seems to me that the Seagate is blocking the startup-process somehow. I'm not sure if this happens all the time (it does not happen on restarts of vista) but when I power up the laptop with the HD connected I get stuck at a black screen. If I remove the USB connector the screen with the vista logo and the green process bar immediatly pops up and vista continues loading as if nothing had happened

    Any suggestions?

  2. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    Not uncommon - usually caused by the lack of drivers for the device at boot as they are only loaded by the OS (windows). I have a freecom external drive that is much the same.
  3. nilesp

    nilesp TS Rookie Topic Starter Posts: 20

    Perhaps it's solved

    I got this response from Seagate:

    "With regards to your query, I understand that the computer does not boot with the drive connected. I would suggest you to check the boot the priority for the"USB" device in "BIOS " is disabled if so enable it."

    I tried putting the USB Hard Drive post as the first post in the list but that did not help. Instead I put the Notebook Harddrive first (instead of the CD) and I think it may have solved the problem although I've only booted up the computer once since so I'm not sure yet.

    It's a little bit of a hassle if one has to resort to the bios every time one wnats to boot from the cd but it's better for me at least, seeing as how I have the external drive connected almost permanently.
  4. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    You will find that most experiened users deliberately stick the CD/DVD drive at the bottom of the boot priority list so that the pause for the system to check for bootable media is avoided, thus reducing the boot time.
  5. nilesp

    nilesp TS Rookie Topic Starter Posts: 20

    That's reasonable, after more reboots I discovered that the problem remains unresolved. Is the consensus that there isn't any ready solution available then?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...