Computer not recognizing my External USB 2.0 Hard Drive

By dotcomma ยท 8 replies
Jan 21, 2007
  1. I purchased a Digital Research External USB 2.0 320 GB Hardrive and my computer simply isn't recognizing it. I have tried installing it several times - with the computer turned on and off. Tried through the Install Hardware Wizard, and all the troubleshooters. I have tried all the different USB ports on my computer to see if that would make a difference, but no luck. It is simply not being recognized. My ports are USB 1.1., but I believe they are backward compatible. My puter is Pentium IV. Any suggestions?
  2. N3051M

    N3051M TS Evangelist Posts: 2,115

    isn't simply recognizing.. how do you know it?

    -does it give you that two tone beep like when you plug in a USB device?
    -do you see the "Safely remove Hardware" icon on your taskbar?
    -can you see it under My computer, or a blank space between two icons?
    -can you see it when going to Disk management?
    >right click the My computer Icon
    >select Disk Management
    >scroll down
    -what service pack are you running and have you got all available windows updates?
  3. dotcomma

    dotcomma TS Rookie Topic Starter

    The answer is no to all of the above questions. I am running SP2 and do have all updates.

    However I should have mentioned before that I had purchased the same drive last week, after plugging the drive in a new drive letter did appear in "My Computer" folder. I dragged the desired folder to the drive letter "G", and the box came up saying everything was being copied ... this lasted most of the day. When that finished, I went to the drive to see how things looked, etc. and there was nothing there. When I tried to move anything after that I received the message:

    Cannot copy "file name": Cannot find the specified file. Make sure you specify the correct path and file name.

    I ran all the appropriate troubleshooters and everything indicated that the drive was working o.k. I allso rebooted, uninstalled the drive, plugged it in to different ports. I finally contacted Digigital Research support and after 1-1/2hours trying different thing, they suggested I return it for a new one.

    I uninstalled the first drive using the safe uninstall icon. I thought there might be some installation files from the previous drive that are messing things up but I can't find anything.

    Sorry I didn't tell you all of this before but perhaps this will provide you with more necessary info. Thank you for your help ... much appreciated.
  4. c156787

    c156787 TS Rookie

    Hello I am new on this forum,

    I have got a similar problem with my excelsior hardrive that I used as an external one. I have a IBM thinkpad laptop and when I recently removed my CD-ROM drive and put it back it corrupted my external drive which now does not appear on my computer. The USB port recognise it but I cannot have access to it. I do not want to format it as I have some important files in it that I do not want to lose.

    Does anybody know what I should do?

    Thank you for your help
  5. NetCablesPlus

    NetCablesPlus TS Maniac Posts: 228

    Check the simplest thing first: are you sure that the USB 2.0 cable that you are using is okay? Please check out the hard disk with a known good USB cable before you begin working on more complicated solutions and/or returning the device for a new one.
  6. michaelnewyork

    michaelnewyork TS Rookie

    hello everyone im new to all this. my laptop fitted with external drive-usb is picking it up-but in my computer icon says not there
  7. c156787

    c156787 TS Rookie

    My external hardrive appear on disk management but no letter is allocated to it. I remember that it was working before I reconnected the CD-Rom drive. Does this mean that I have to partition and then format again my hardrive?
  8. roadrash8414

    roadrash8414 TS Rookie

    Similar Problem

    I'm running service pack 2, I hear the two tone when I plug in the drive, a few bubbles show up in the lower right corner ending with "Your hardware is installed." I can't find the drive in My Computer or in Disk Manager.
  9. NetCablesPlus

    NetCablesPlus TS Maniac Posts: 228

    michaelinnewyork, c156787, and roadrash8414: you really should start your own threads on your particular problem as most people will not be following this older thread in the forum.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...